Opened 10 years ago

Closed 9 years ago

#9659 closed Bug Report - General (Need more Info)

MythNews locks machine solid requiring mythfrontend to be killed with "pkill -9"

Reported by: ramjet@… Owned by: beirdo
Priority: minor Milestone: unknown
Component: Plugin - MythNews Version: Unspecified
Severity: medium Keywords: mythnews
Cc: Ticket locked: no

Description

I've been trying to get MythNews? working and after much faffing about managed to do so. But only after finding a forum post that suggested I should manually create "~/.mythtv/MythNews" from a terminal window. This was the missing piece that got MythNews? initially working.

The same fix was then also required to get MythWeather? to work (i.e. manually create "~/.mythtv/MythWeather")

So in the first instance I'd like to ask why these directories are not created by the MythTV system (with the correct permissions) as required ?

Anyway, having now got my system almost working to my taste I decided I wanted to set up a totally new user who would be automatically logged in to a mythfrontend session when the box is booted up.

Having done this I rebooted the box (switched it full off then back on again), the new user was automatically logged in and mythfrontend ran. DVD playing worked, music playing worked and TV viewing and recording worked.

However as soon as I go into MythNews? the "left hand" list of news feed categories is displayed but the front end then locks up solid. i.e. it does not respond to any button presses and the only way I can get the machine to respond again is to use Ctrl+Alt+F2 to open a new session where I can kill the frontend with "pkill -9 mythfrontend".

As a first guess I manually created the ".mythtv/MythNews" directory but this makes no difference. I also tried copying in the files from the original users directory and setting the permissions of everything to 777 (I've also tried changing the owner of the directory/files etc. etc.)

Even worse I have also tried logging in with my original user (the one I used to initially set the box up) and the same thing happens as soon as I launch MythNews? from the Information Centre (again this is from a totally clean, powered off, boot)

So no matter what I try MythNews? now simply locks mythfrontend solid and mythfrontend has to be manually killed before the box will respond again (As a test I left it for an hour to see if it would time out but this didn't help)

Unfortunately I do not know enough to say what is happening but I have a hunch that this is a permissions problem and a script is hanging waiting for something which will never arrive.

Please let me know if you require any log files, directory listings etc. etc.

Thank you.

Change History (18)

comment:1 Changed 10 years ago by paul@…

I've had MythNews? working in 0.23 but I get the same symptom in 0.24/fixes ie frontend locks up and have to killall to restart it..

comment:2 Changed 10 years ago by ramjet@…

Just to mention that I eventually managed to get MythNews? working again. To do this I "unticked" MythNews? in the Myth control centre, then used synaptic with the option to completely remove MythNews? and all it's configuration files. Following this I reinstalled it, reenabled it in the control centre... and it locked the machine as soon as I ran it !

At this point I used "rm -rf" to delete the "~/.mythtv/MythNews/" directory and all it's contents after which I manually recreated it. However this still didn't work until I put full 777 permissions on the directory.

I'm therefore deeply suspicious that the problem is file related where MythNews? is attempting to either create or write to a file but instead of failing cleanly when it can't (with a nice diagnostic message in the log telling you the full name of the file etc.) it's simply waiting forever, locking the box in the process.

comment:3 Changed 10 years ago by paulh

ramjet, your problems really sound like some permissions problems at your end. Many parts of myth write stuff to its config directory which is usually ~/.mythtv but can be changed by setting an environment variable (MYTHCONFDIR). In your case it looks like you are using the default behaviour and using the .mythtv directory in the users home directory. If the user running mythfrontend can't write to its own home directory then something is really screwed and I don't think you can blame myth for this.

comment:4 Changed 10 years ago by warpme@…

Hi,

I have also problem with MythNews? hard lockups. Issue is random and proportional to number of mythnews feeds. I.e. with 6 feeds I have stable mythnews on 3 production FEs, but with 20+, lockups are average once per week (launching mythnews 2 times per day). FE lockup is hard (telnet gives greetings but no prompt, only reboot helps). Lockup is quite similar to situation where there is oom. My fe has 2G and there is always plenty of free RAM so I'm sure it is not problem of memory resources.

comment:5 Changed 10 years ago by paul@…

Just a note as I had a similar problem and I resolved it by deleting all my subscriptions and cache, must have been a corrupted item or a bug caused by my subscription. but now it doesn't hang when I enter the News Plugin.

Note I do get a problem when I select an article the browser crashes but possibly another problem

comment:6 Changed 10 years ago by warpme@…

@paul

This is interesting. I tried to do this in past as well. In past I deleted & entered again all bookmarks - but do this directly in DB (newssites table). Do You believe direct mods in DB instead of mythnews UI might be problem ? Also I verified all my news feeds with W3C validation tool just to be sure are all my feeds correct & valid. I think issue is related to userspace system resources exhausting as in my case FE becomes uncontrollable but is running. It behaves like system with malfunctioned/halted/freeze/deadlocked userspace but running OK kernel things (as telnet to box gives greetings but no prompt). br

comment:7 Changed 10 years ago by Kenni Lund [kenni a kelu dot dk]

Trac is not a discussion forum, it's a bugtracker. Please keep discussions on the mailing lists and add *conclusions* from these discussions to Trac afterwards. Please read the TicketHowTo.

comment:8 Changed 9 years ago by beirdo

Status: newinfoneeded_new

To the original poster: please post the output of mythbackend --version for the affected system. Also, see http://www.mythtv.org/wiki/Debugging for instructions on how to attach gdb to the hung process to get a backtrace for us to investigate.

comment:9 Changed 9 years ago by Paul Wilson <paul@…>

MythTV Version : v0.24.1-11-g40a3124 MythTV Branch : fixes/0.24 Network Protocol : 63 Library API : 0.24.20110505-1 QT Version : 4.6.3 Options compiled in:

linux release using_alsa using_jack using_oss using_pulse using_pulseoutput using_backend using_bindings_perl using_bindings_python using_dvb using_firewire using_frontend using_hdhomerun using_hdpvr using_iptv using_ivtv using_joystick_menu using_libfftw3 using_lirc using_mheg using_opengl_video using_opengl_vsync using_qtdbus using_qtwebkit using_v4l using_x11 using_xrandr using_xv using_xvmc using_xvmc_vld using_xvmcw using_bindings_perl using_bindings_python using_mythtranscode using_opengl using_vdpau using_ffmpeg_threads using_live using_mheg

comment:10 Changed 9 years ago by warpme@…

Davin,

Thx for picking-up this ticket. Issue is so annoying that I totally disable this plugin. May You advice me how can I get trace from totally unresponsive system (screen/kbd dead. telnet reporting only that successfully connection to port but no greetings/prompt). My sys is latest master (build last weekend). Thx

comment:11 Changed 9 years ago by beirdo

warpme: I don't know that that's relevant to this ticket. Please leave this ticket for the originally reported issue. I don't want to be tracking 3 variations at once. Once the reported bug is fixed, we'll see if your problem is fixed in the process, and if not, please open another ticket to further investigate.

comment:12 Changed 9 years ago by beirdo

Owner: set to beirdo

comment:13 Changed 9 years ago by ramjet@…

Hello,

Sorry for the late reply but I've only just found time to collect my emails this week. And I'll get the requested version information and gdb trace done a.s.a.p. but it might not be until Saturday as I'm somewhat busy this week.

Cheers.

comment:14 Changed 9 years ago by sphery

ramjet, please see http://www.gossamer-threads.com/lists/mythtv/users/485896#485896 , which references http://www.nvnews.net/vbulletin/archive/index.php/t-150725.html , where Mark Lord recommended trying to boot with the kernel option:

pci=nomsi

in the post from 10-01-10, 12:23 PM (on page http://www.nvnews.net/vbulletin/archive/index.php/t-150725-p-3.html ). Please try the option even if you're not running on an ION system (as it seems the theory is that there's a bug in some low-level hardware component such as the network driver or the SATA/AHCI driver).

If that helps, please let us know, and then continue discussion in the mythtv-users list thread, and perhaps people can help narrow down exactly which hardware is common among the machines affected so that driver developers will be able to figure out why MSI is causing issues. (Or, if you need help testing with pci-nomsi, please ask for help on the thread on the -users list.)

See, also, thread at http://www.gossamer-threads.com/lists/mythtv/users/459687#459687

Thanks.

comment:15 Changed 9 years ago by beirdo

Still waiting for a gdb backtrace, and the mythbackend --version output.

comment:16 Changed 9 years ago by Paul Wilson <paul@…>

ok I'll try and get this tonight, but as the system doesn't appear to have crashed I'm guessing its in a hard loop, do I follow the same procedures as documented on the wiki site? eg http://www.mythtv.org/wiki/Debugging#Getting_a_Backtrace ?

comment:17 Changed 9 years ago by beirdo

Yes, in particular look at the section about attaching to a running process.

comment:18 Changed 9 years ago by beirdo

Resolution: Need more Info
Status: infoneeded_newclosed

I'm closing this. If someone can actually get us a backtrace of mythnews hanging, then please attach it and we can reopen and go from there. I can't reproduce the issue here, and we have nothing to work from.

Note: See TracTickets for help on using tickets.