Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#9745 closed Bug Report - General (fixed)

Mythbackend deadlock with slave backend connected

Reported by: redpepperracing@… Owned by:
Priority: minor Milestone: 0.25
Component: MythTV - General Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

This appears to be different from 9721, 9704 and was not fixed by commit 3e2375faa09956dd3f32d862a156d57fc4127668.

I can reliably reproduce the problem with current trunk by starting a backend, a slave backend, and a remote frontend, and trying to enter live tv. The backtraces from the two BE and BE and remote FE logs are attached.

All systems are running freshly compiled trunk:

Please attach all output as a file in bug reports. MythTV Version : v0.25pre-1825-g6496880 MythTV Branch : master Network Protocol : 65 Library API : 0.25.20110421-1 QT Version : 4.6.3 Options compiled in:

linux debug use_hidesyms using_alsa using_oss using_backend using_bindings_perl using_bindings_python using_bindings_php using_dvb using_frontend using_hdhomerun using_hdpvr using_iptv using_ivtv using_joystick_menu using_lirc using_mheg using_opengl_video using_qtdbus using_qtwebkit using_v4l using_x11 using_xrandr using_bindings_perl using_bindings_python using_bindings_php using_mythtranscode using_opengl using_vdpau using_ffmpeg_threads using_live using_mheg

All systems are also running up to date FC13 installs. The master has 2x HDHR tuners (4 total) and 2x PVR-x50 tuners, the slave has 1x HD-PVR via USB, the slave records to an NFS mounted storage group from the MBE.

If you need any more info or debug testing, let me know.

Attachments (5)

gdb-mbe.txt (72.7 KB) - added by redpepperracing@… 9 years ago.
Master back end backtrace
gdb-sbe.txt (25.8 KB) - added by redpepperracing@… 9 years ago.
Slave back end backtrace
mythbackend-mbe.log (29.0 KB) - added by redpepperracing@… 9 years ago.
Master back end log
mythbackend-sbe.log (3.3 KB) - added by redpepperracing@… 9 years ago.
Slave back end log
mythfrontend.log (15.1 KB) - added by redpepperracing@… 9 years ago.
Frontend log

Download all attachments as: .zip

Change History (10)

Changed 9 years ago by redpepperracing@…

Attachment: gdb-mbe.txt added

Master back end backtrace

Changed 9 years ago by redpepperracing@…

Attachment: gdb-sbe.txt added

Slave back end backtrace

Changed 9 years ago by redpepperracing@…

Attachment: mythbackend-mbe.log added

Master back end log

Changed 9 years ago by redpepperracing@…

Attachment: mythbackend-sbe.log added

Slave back end log

Changed 9 years ago by redpepperracing@…

Attachment: mythfrontend.log added

Frontend log

comment:1 Changed 9 years ago by sphery

In 3e2375faa:

Fix a potential deadlock in AutoExpire?

With danielk's changes that I merged in, he has us use Sleep() internally almost exclusively. However, Sleep() requires the instance_lock to be pre-locked, and in this place, it wasn't. This can cause problems.

comment:2 Changed 9 years ago by zeloise@…

Hello

the problem is still there even after commit 3e2375faa.

I hope this helps zeloise

comment:3 Changed 9 years ago by Github

Milestone: unknown0.25
Resolution: fixed
Status: newclosed

Initialize update_thread in ctor

This seems to help with avoiding the deadlocks when slave backends attach, and should be otherwise non-harmful.

Fixes #9745

Signed-off-by: Gavin Hurlbut <ghurlbut@…>

Changeset: f33e9a69c254d879be6d42e766755493519c2839

comment:4 Changed 9 years ago by beirdo

If this did not in fact fix it, please re-open.

comment:5 Changed 8 years ago by zeloise@…

Problem solved with commit f33e9a

thanks zeloise

Note: See TracTickets for help on using tickets.