Opened 10 years ago

Closed 8 years ago

#9818 closed Bug Report - General (Invalid)

Myth internal player (DVDPlayer) does not play this DVD: black screen + squaring

Reported by: sergeevsp43@… Owned by: peper03
Priority: minor Milestone: 0.27
Component: MythTV - DVD Playback Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Hello!

Myth DVDPlayer does not play this my DVD from HDD:

http://depositfiles.com/files/bxrn6tz9h http://depositfiles.com/files/xhvh80c5v

The files are split tar-archive (2GB) which contents folder VIDEO_TS with files inside. Black screen and squaring. Only DVD-menu plays normally. My Myth version is 0.25pre-2067-gd641372.

Attachments (1)

myth.log.gz (65.3 KB) - added by sergeevsp43@… 10 years ago.
myth-log

Download all attachments as: .zip

Change History (10)

comment:1 Changed 10 years ago by markk

Priority: majorminor
Status: newaccepted

Can you please attach the full output of mythfrontend -v playback for the dvd in question. I'd rather check whether this is a known issue before downloading 4GBs of files:) Thanks

Changed 10 years ago by sergeevsp43@…

Attachment: myth.log.gz added

myth-log

comment:2 Changed 10 years ago by sergeevsp43@…

Both files are 2BG together!

comment:3 Changed 10 years ago by markk

The problem here doesn't seem to be the DVD code per se but something more generic in our handling of the mpeg2 in the VOB file/stream. Opening the vob files directly gives blocky/broken playback as well but mplayer, vlc and (more importantly) mythffplay handle them correctly.

Possibly a regression in the latest ffmpeg sync and possibly related to #9778

Last edited 10 years ago by markk (previous) (diff)

comment:4 Changed 10 years ago by sergeevsp43@…

This is old problem. I've never written about it before. I have several more DVDs with this problem from other publisher.

comment:5 Changed 10 years ago by robertm

Mark, Dupe of #9083?

comment:6 Changed 9 years ago by markk

Owner: markk deleted
Status: acceptedassigned

comment:7 Changed 9 years ago by beirdo

Milestone: 0.25unknown

comment:8 Changed 8 years ago by stuartm

Owner: set to peper03

comment:9 Changed 8 years ago by stuartm

Milestone: unknown0.27
Resolution: Invalid
Status: assignedclosed

Looks like the files are no longer available and the ticket is two years old, there's a very good chance this has already been fixed.

Note: See TracTickets for help on using tickets.