Opened 9 years ago

Closed 8 years ago

#9083 closed Bug Report - General (Upstream Bug)

some DVDs don't play with VDPAU

Reported by: managementboy@… Owned by:
Priority: minor Milestone: unknown
Component: MythTV - DVD Playback Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Some of my DVDs don't play with VDPAU. After starting the main feature (menu works) the screen stays mainly black with occasional blocks appearing. Sound work either. When I switch to a different renderer the DVD plays flawlessly. Attached a full log of "mythfrontend -v playback,audio". The Nvidia driver is version 260.19.06 on a nVidia Corporation GT218 210? (rev a2), but I tested it with other drivers, too.

mythfrontend --version Please attach all output as a file in bug reports. MythTV Version : 26731 MythTV Branch : trunk Network Protocol : 63 Library API : 0.23.20100917-1 QT Version : 4.7.0 Options compiled in:

linux debug using_alsa using_jack using_oss using_pulse using_pulseoutput using_backend using_bindings_perl using_bindings_python using_dvb using_firewire using_frontend using_hdhomerun using_hdpvr using_iptv using_ivtv using_joystick_menu using_lirc using_mheg using_opengl_video using_opengl_vsync using_qtdbus using_qtwebkit using_v4l using_x11 using_xrandr using_xv using_xvmc using_xvmc_vld using_xvmcw using_bindings_perl using_bindings_python using_mythtranscode using_opengl using_vdpau using_ffmpeg_threads using_live using_mheg

running on Mythbuntu 10.10

Attachments (3)

dvdplayback.log (62.9 KB) - added by managementboy@… 9 years ago.
mythfrontend -v playback,audio
dvdplayback.2.log (43.5 KB) - added by managementboy@… 9 years ago.
update of log for 26th of october 2010
patchedfrontend.log (214.7 KB) - added by managementboy@… 9 years ago.
log of mythfrontend -v playback,audio

Download all attachments as: .zip

Change History (18)

Changed 9 years ago by managementboy@…

Attachment: dvdplayback.log added

mythfrontend -v playback,audio

comment:1 Changed 9 years ago by beirdo

Component: MythTV - GeneralMythTV - DVD Playback
Owner: set to markk
Status: newassigned

comment:2 Changed 9 years ago by markk

Status: assignedinfoneeded

Please re-test with latest trunk - which has had many changes to DVD playback.

comment:3 in reply to:  2 Changed 9 years ago by managementboy@…

no change, still the same issue. VDPAU does not work, but ffmpeg does. I have updated the log today.

mythfrontend --version Please attach all output as a file in bug reports. MythTV Version : 26977 MythTV Branch : branches/release-0-24-fixes Network Protocol : 63 Library API : 0.24.20101017-1 QT Version : 4.7.0 Options compiled in:

linux debug using_alsa using_jack using_oss using_pulse using_pulseoutput using_backend using_bindings_perl using_bindings_python using_dvb using_firewire using_frontend using_hdhomerun using_hdpvr using_iptv using_ivtv using_joystick_menu using_lirc using_mheg using_opengl_video using_opengl_vsync using_qtdbus using_qtwebkit using_v4l using_x11 using_xrandr using_xv using_xvmc using_xvmc_vld using_xvmcw using_bindings_perl using_bindings_python using_mythtranscode using_opengl using_vdpau using_ffmpeg_threads using_live using_mheg

Changed 9 years ago by managementboy@…

Attachment: dvdplayback.2.log added

update of log for 26th of october 2010

comment:4 Changed 9 years ago by markk

Milestone: unknown0.25

Can you please test the patch in #9143 and see if it helps.

comment:5 Changed 9 years ago by stuartm

We're still waiting for feedback from managementboy

comment:6 Changed 9 years ago by robertm

Resolution: Invalid
Status: infoneededclosed

No info provided.

comment:7 Changed 9 years ago by managementboy@…

sorry, had actualy done the requested change but forgot to post the results. Did it again today, manualy adding the patch (as the source file has changed since). The error percists and the work arround using ffmpeg and XVideo still applies.

Sometimes the OSD gets a color inversion when playing the ISOs/DVDs that have this problem.

"mplayer -vo vdpau kikujiro.iso" does work, but fails in using myth.

Attached a log of the testing I did (mythfrontend -v playback,audio)

Thanks for looking into it.


Tested following botha as ISOs and DVDs

DVDs that Work:

Kurz und Schmerzlos

Meet the Parents

DVDs that don't: Chaos Kikujiro


mythfrontend --version Please attach all output as a file in bug reports. MythTV Version : v0.25pre-1627-ge2b49a5 MythTV Branch : master Network Protocol : 65 Library API : 0.25.20110328-2 QT Version : 4.7.0 Options compiled in:

linux debug use_hidesyms using_alsa using_jack using_oss using_pulse using_pulseoutput using_backend using_bindings_perl using_bindings_python using_bindings_php using_directfb using_dvb using_firewire using_frontend using_hdhomerun using_iptv using_joystick_menu using_libxml2 using_lirc using_mheg using_opengl_video using_qtdbus using_qtwebkit using_x11 using_xrandr using_xv using_bindings_perl using_bindings_python using_bindings_php using_mythtranscode using_opengl using_vdpau using_ffmpeg_threads using_live using_mheg using_libxml2

Changed 9 years ago by managementboy@…

Attachment: patchedfrontend.log added

log of mythfrontend -v playback,audio

comment:8 Changed 9 years ago by sphery

Resolution: Invalid
Status: closednew

comment:9 Changed 9 years ago by sphery

Status: newassigned

comment:10 Changed 8 years ago by markk

Status: assignedaccepted

comment:11 Changed 8 years ago by Brent Helgerson <bahelgerson@…>

I can reproduce this using mplayer with VDPAU instead of the internal player. Would this indicate that it's not a MythTV issue? All the discs from Dexter season 3 (region 1) exhibit this behavior.

Thanks

comment:12 Changed 8 years ago by Raymond Wagner

Version: UnspecifiedTrunk Head

comment:13 Changed 8 years ago by markk

Owner: markk deleted
Status: acceptedassigned

comment:14 Changed 8 years ago by beirdo

Milestone: 0.25unknown

comment:15 Changed 8 years ago by stuartm

Resolution: Upstream Bug
Status: assignedclosed
Type: defectBug Report - General

Reporter can reproduce outside MythTV and we've had no further reports of the same behaviour from other users. It doesn't prove much but Dexter Series 3 Region 2 DVDs played just fine with vdpau for me. I'm closing this as a driver/hardware issue as it doesn't seem to be a MythTV bug.

Note: See TracTickets for help on using tickets.