Modify
Warning Please read the Ticket HowTo before creating or commenting on a ticket. Failure to do so may cause your ticket to be rejected or result in a slower response.

Opened 3 years ago

Closed 3 years ago

Last modified 2 years ago

#9822 closed Bug Report - General (Fixed)

MythTV OSD is displayed under subtitles

Reported by: Ville Aakko <ville.aakko@…> Owned by: markk
Priority: minor Milestone:
Component: MythTV - Video Playback Version: Master Head
Severity: medium Keywords: subtitles OSD
Cc: Ticket locked: no

Description

Hi,

When there is subtitles shown (which is quite often here in Finland - i.e. all YLE channels showing anything in a foreign language), the OSD is unreadable when changing channels, because the subtitles overlap it.

I think the OSD should overlap the subtitles, since when OSD is showm, it is most probably what the user want's to see, in preference to the subtitles.

Steps to reproduce:

  1. Watch a channel (LiveTV) with DVB subtitles currently being displayed
  2. Change the channel

(This could be probably also triggered in other situations with subtitles, too - not necessarily only DVB and LiveTV.)

Actual results:

The OSD is under the subtitles, and hence, unreadable.

Expected results:

The OSD should be over the subtitles.

Attachments (1)

MythTV-Subtitles-over-OSD.jpg (244.2 KB) - added by ville.aakko@… 3 years ago.
MythTV subtitles over OSD while browsing channels

Download all attachments as: .zip

Change History (7)

comment:1 Changed 3 years ago by robertm

  • Component changed from MythTV - DVB to MythTV - Video Playback
  • Owner changed from janne to markk
  • Status changed from new to assigned

comment:2 Changed 3 years ago by markk

  • Milestone changed from unknown to 0.25
  • Status changed from assigned to infoneeded

Can you please attach a screenshot/photograph of the osd/subtitle problem. thanks, Mark

Changed 3 years ago by ville.aakko@…

MythTV subtitles over OSD while browsing channels

comment:3 Changed 3 years ago by ville.aakko@…

I was not able to take a screenshot of MythTV (probably because of VDPAU / OpenGL; nothing is grabbed from Mythfrontend), so I took a photo.

comment:4 Changed 3 years ago by Github

OSD: Fix subtitle window painting order.

The order of iterating over a QHash is arbitrary and the fact that
subtitle and interactive screens have (mostly) been drawn in the correct
order since the OSD re-write is pure luck.

So switch to a QMap which, while marginally slower, will order on the
basis of the key (QString) and force the subtitle/interactive screens to
be painted first by adding some numerics to their identifiers.

Should fix the ordering issue seen in #9822 and occasionally in the yet
to be enabled blu-ray HDMV navigation mode.

Refs #9822

Branch: master
Changeset: be25039cd6e511bedc550dcede34794bb5d39671

comment:5 Changed 3 years ago by markk

  • Milestone changed from 0.25 to 0.24.2
  • Resolution set to Fixed
  • Status changed from infoneeded to closed

This should be fixed in 0.24 in 1be38ea4edbbf251f0a0, though I couldn't actually replicate the issue myself (but it was easy enough to see how it might happen).

If it is still a problem, please re-open.

comment:6 Changed 2 years ago by stuartm

  • Milestone 0.24.2 deleted

Milestone 0.24.2 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'new'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.