Modify
Warning Please read the Ticket HowTo before creating or commenting on a ticket. Failure to do so may cause your ticket to be rejected or result in a slower response.

Opened 3 years ago

Closed 3 years ago

Last modified 2 years ago

#9823 closed Patch - Bug Fix (Fixed)

[PATCH] MythPlayer: fix stutters at program transition and during channel switch

Reported by: Lawrence Rust <lvr@…> Owned by:
Priority: minor Milestone:
Component: MythTV - General Version: 0.24-fixes
Severity: medium Keywords: playback stutter
Cc: Ticket locked: no

Description

During LiveTV playback of a DVB-S channel the video & audio stutter when the program changes (according to the EPG) even though the source material is continuous.

This reverts part of commit 08a8a65535638de185e68f76898c118161d4bf88 (Force reload of context and stream properties when switching between LiveTV and reorders some code to reduce interference with RingBuffer? prefetching and decoding.

I can't reproduce (on DVB-S) the problems that commit 08a8a655 is supposed to fix and the disruption to program switching it causes is very annoying.

Attachments (1)

0038-mythplayer-Avoid-stutters-between-programs-and-when-.patch (6.5 KB) - added by Lawrence Rust <lvr@…> 3 years ago.

Download all attachments as: .zip

Change History (5)

Changed 3 years ago by Lawrence Rust <lvr@…>

comment:1 Changed 3 years ago by Jiri Fojtasek <jiri.fojtasek@…>

commit 08a8a655 was reponse to ticket #9542. I think issue in #9542 was not fixed by other way so this patch should introduce it again.

comment:2 Changed 3 years ago by danielk

  • Resolution set to Fixed
  • Status changed from new to closed

Fixed in [5161a5f43df98250314acbfda15ab5f8e3d8002d]

Revert "Force reload of context and stream properties when switching between LiveTV segments."

Fixes #9823. Refs #9542. This was already reverted in master, but we missed the backport to 0.24-fixes.


This reverts commit 08a8a65535638de185e68f76898c118161d4bf88.

comment:3 Changed 3 years ago by wagnerrp

  • Milestone changed from unknown to 0.24.2

comment:4 Changed 2 years ago by stuartm

  • Milestone 0.24.2 deleted

Milestone 0.24.2 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'new'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.