Opened 8 years ago

Closed 8 years ago

#9964 closed Bug Report - General (Invalid)

backend

Reported by: Lawrence Rust <lvr@…> Owned by:
Priority: minor Milestone: unknown
Component: MythTV - General Version: Master Head
Severity: medium Keywords: SQL
Cc: Ticket locked: no

Description

Commit 4dfcdb8dd0 and 1fb0a77fc prevent me from viewing live TV. Reverting these 2 commits restores normality.

  • The FE & BE both run git master on one box
  • The BE is setup to use the demo recorder.
  • The mysql database runs on an Ubuntu 10.04 LTS system
  • mysql --version reports Ver 14.14 Distrib 5.1.41,

The FE reports:

2011-08-05 10:27:17.666810 N TV: Spawning LiveTV Recorder -- begin 2011-08-05 10:27:18.164702 N TV: Spawning LiveTV Recorder -- end 2011-08-05 10:27:18.166805 E GetEntryAt?(-1) failed. 2011-08-05 10:27:18.166811 E It appears that your backend may be misconfigured. Check your backend logs to determine whether your capture cards, lineups, channels, or storage configuration are reporting errors. This issue is commonly caused by failing to complete all setup steps properly. You may wish to review the documentation for mythtv-setup. 2011-08-05 10:27:18.166840 E EntryToProgram?(0@Thu Jan 1 01:00:00 1970) failed to get pginfo

The BE reports:

2011-08-05 10:27:17.797794 E DB Error (InsertProgram? -- insert): Query was: INSERT INTO recorded (chanid, starttime, endtime, title, subtitle, description, season, episode, hostname, category, recgroup, autoexpire, recordid, seriesid, programid, inetref, stars, previouslyshown, originalairdate, findid, transcoder, playgroup, recpriority, basename, progstart, progend, profile, duplicate, storagegroup) VALUES (?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, 0, ?) No error type from QSqlError? Strange... (above entry repeated many times then...) 2011-08-05 10:27:18.120446 E Couldn't insert program 2011-08-05 10:27:18.129734 E DB Error (Chain: AppendNewProgram?): Query was: INSERT INTO tvchain (chanid, starttime, endtime, chainid, chainpos, discontinuity, watching, hostprefix, cardtype, channame, input) VALUES(?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ? ); Bindings were: :CARDTYPE=IMPORT, :CHAINID=live-gagarin-2011-08-05T10:27:17, :CHAINPOS=0, :CHANID=92009, :CHANNAME=1, :DISCONT=false, :END=2011-08-05T10:30:00, :INPUT=, :PREFIX=myth://gagarin:6543/, :START=2011-08-05T10:28:07, :WATCHING=0 Driver error was [2/1048]: QMYSQL3: Unable to execute statement Database error was: Column 'input' cannot be null

Change History (3)

comment:1 Changed 8 years ago by danielk

Status: newinfoneeded_new
Summary: Revert commit 4dfcdb8dd0 - Fix SQL reconnection logic...backend

Lawrence, did you check your backend configuration?

From the error message it looks like you don't have an input configured for your recorder.

comment:2 Changed 8 years ago by Lawrence Rust <lvr@…>

The setup was working perfectly before 'pull'ing these commits and worked again after reverting them. It's reproducible.

The BE doesn't have a real tuner, it's configured with a demo and a file recorder. My production system with real tuners is too valuable to use for testing.

comment:3 Changed 8 years ago by danielk

Resolution: Invalid
Status: infoneeded_newclosed

You still need to configure the demo recorder properly. From the data you've produced it appears that a configuration error wasn't getting reported before that and it is now.

Note: See TracTickets for help on using tickets.