Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#10699 closed Bug Report - General (Works for me)

Channel Scanner cannot acces DVB-S2 card

Reported by: nils_rohrer@… Owned by: danielk
Priority: major Milestone: unknown
Component: MythTV - Channel Scanner Version: 0.25-fixes
Severity: high Keywords: Channel Scanner broken
Cc: Ticket locked: no

Description

Channels which are allready scanned are visible with live TV. A scan for new channels is not possible as the mythtv-setup tells me that the card is not accessible. In mythtv-setup.log I get

May 6 18:39:47 server mythtv-setup[24769]: E CoreContext? cardutil.cpp:404 (ProbeDVBType) Can't open DVB frontend (/dev/dvb/adapter0/frontend0) for /dev/dvb/adapter0/frontend0.

On the same card it is possible to watch live TV and to make recordings.

Change History (5)

comment:1 Changed 8 years ago by stuartm

Resolution: Works for me
Status: newclosed

Have you shut down the backend before trying to scan? Are you running mythtv-setup using the same user as mythbackend?

I'm unable to reproduce and I strongly suspect that this is a permissions issue. This isn't a support forum, so I suggest taking this to the mythtv-users mailing list or IRC channel.

comment:2 Changed 7 years ago by info@…

i have the same problem. I have checked the rights and they are ok. I even added my current user to the video and mythtv group. Also tried to run mythtv-setup with sudo. Now upgraded to MythTV 0.26 but still the same problem. On my old installation (MythTV0.23) everything worked perfectly fine! I'm even considering about changing back... :/

comment:3 Changed 7 years ago by J.Pilk@…

comment:4 Changed 7 years ago by info@…

Hey Thanks for the help! I already tried running "femon -H -aX" (femon -H -a0) but that doesn't seem to work... I get this: Problem retrieving frontend information: Operation not supported status | signal 0% | snr 0% | ber 0 | unc 1872361544 |

I did manage to get live-tv working a few hours ago by restoring an old backup from my previous setup MythTV0.23 and upgrading it to the new database scheme, but the DVB-S2 still isn't working on Astra 3 (23.5E). Sometimes I get channel lock and tv plays well, sometimes it doesn't... Strange... Everything worked perfectly fine before on MythTV0.23, I even replaced the DVB card just to be sure it isn't hardware related (I have 2 exactly the same cards where one is a spare). I use the Technotrend S2 3200 budget card.

comment:5 Changed 7 years ago by J.Pilk@…

#11403 continued the same theme and seemed to have tracked down a real fix - but it might not be quite the same problem. Good luck.

Note: See TracTickets for help on using tickets.