Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#10873 closed Bug Report - General (Invalid)

Cant watch TV Permission Denied opening recording file despite chmod a+rwx

Reported by: John <jb2904@…> Owned by:
Priority: minor Milestone: unknown
Component: MythTV - General Version: 0.25-fixes
Severity: medium Keywords: recording folder permission
Cc: Ticket locked: no

Description

On a new installation I can't watch TV or record if I use a 2TB HD, but can if I use the boot disk, despite the recording folders on both drives having a+wrx permissions.

When trying to record to the 2TB drive the log (more attached) shows:

(/media/data/mythtv/recordings/1003_20120611121014.mpg:-1): Opening file '/media/data/mythtv/recordings/1003_20120611121014.mpg'.#012#011#011#011eno: Permission denied (13)

However, as stated above, that folder has wide open permissions:

$ ls -l /media/data/mythtv/

drwxrwxrwx 2 mythtv mythtv 4096 Jun 11 12:08 recordings

I am reporting this as a mythtv bug because every other application accesses this drive without a problem. I am at a loss.

I have attached my fstab in case mythtv is taking an exception to the way I have mounted the drive. If it is, then it shouldn't be.

If I change the recording folder to the boot SSD disk with the same permissions then it works fine:

# ls -l /users/mythtv

total 4 drwxrwxrwx 2 mythtv mythtv 4096 Jun 13 10:12 recordings

So the problem is something specific to mythtv accessing the 2TB HD.

Attachments (3)

log extract.txt (2.3 KB) - added by John <jb2904@…> 8 years ago.
log extract
version.txt (846 bytes) - added by John <jb2904@…> 8 years ago.
mythbackend --version
fstab (1.2 KB) - added by John <jb2904@…> 8 years ago.
fstab

Download all attachments as: .zip

Change History (5)

Changed 8 years ago by John <jb2904@…>

Attachment: log extract.txt added

log extract

Changed 8 years ago by John <jb2904@…>

Attachment: version.txt added

mythbackend --version

Changed 8 years ago by John <jb2904@…>

Attachment: fstab added

fstab

comment:1 Changed 8 years ago by Kenni Lund [kenni a kelu dot dk]

Resolution: Invalid
Status: newclosed

John, please start out on the mythtv-users mailing list, as this is highly unlikely to be caused by a bug in MythTV. If it turns out that it really is a bug in MythTV, then we'll reopen this ticket.

comment:2 Changed 8 years ago by John <jb2904@…>

Mythtv is evidentally is sensitive to the permission of the mount point when the drive is unmounted rather then than permissions of the actual folder. Every other program use to access the same drives uses the permissions of the mounted folder. Therefore, if this is not a mythtv bug then I'd consider it to be an extremely undesireable feature!

Note: See TracTickets for help on using tickets.