Opened 6 years ago

Last modified 6 years ago

#11046 new Bug Report - General

Channel scan mixes sources

Reported by: Ian Richardson <grandmastermarclar@…> Owned by: danielk
Priority: minor Milestone: unknown
Component: MythTV - Channel Scanner Version: Master Head
Severity: low Keywords:
Cc: Ticket locked: no

Description

I've been going mad over this one!

I'm marking this as Priority critical because there is no workaround short of rewiring outside. I'm not doing that because it's worked since 0.24.

I'm marking this as Severity high because of the WAF.

I've got 4 tuners: DVB-T (0, 1), DVB-S/S2 (2,3). The DVB-S/S2 tuners are each connected to a DiseqC. One output from each is connected to one LNB (28E), the other to another LNB (13E).

Recently I switched from 0.25 to 0.26 (currently 2:0.26.0~master.20120823.6566c3c-0ubuntu0mythbuntu2). A channel scan of the DVB-T source is fine! So is one for the 28E DVB-S/S2 source. However, a scan for the 13E source gives me a migraine.

Scanning on a single transponder:

12149000 V 275000000 3/4

I end up collecting some channels from the 13E source, and some from the 28E source. I've done this repeatedly, even deleting all the transports for one, some, or all of the sources.

Now generating a log using:

mythtv-setup.real --verbose chanscan >~/mythtv-setup.real.chanscan 2>&1 &

Deleted all the channels, deleted all the transports. Re-scanned using the one transport above.

Has this got something to do with 10997 ?

Attachments (1)

mythtv-setup.real.chanscan.gz (811.8 KB) - added by Ian Richardson <grandmastermarclar@…> 6 years ago.

Download all attachments as: .zip

Change History (6)

Changed 6 years ago by Ian Richardson <grandmastermarclar@…>

comment:1 Changed 6 years ago by Kenni Lund [kenni a kelu dot dk]

Priority: criticalminor
Severity: highlow

Resetting to the defaults. TicketHowTo.

comment:2 Changed 6 years ago by Kenni Lund [kenni a kelu dot dk]

Are you saying that this works in 0.25-fixes? Or only in 0.24-fixes?

comment:3 Changed 6 years ago by Ian Richardson <grandmastermarclar@…>

This worked in all versions from 0.24 up to my switch to 0.26. I'd noticed some weird behaviour in this regard around the time of 10997 (I don't know if this made it to 0.26). I switched to 0.26 on the day of the Olympics closing ceremony, and re-tunes from that point on started to behave oddly. However, I'm now finding that if I want to pick up anything from Hotbird, a channel scan picks up a mixture as detailed in the original attachment (and that's only after I can find a transport to lock on to!)

Does that help? If you need me to obliterate certain tables and re-tune from scratch with whatever logging you want, I can and will provide exactly what you ask for. Just ask, simply because the options within the app for generating logs are as enormous as they are bewildering!

Thank you :-)

comment:4 Changed 6 years ago by Ian Richardson <grandmastermarclar@…>

Just tried the following with 2:0.26.0~master.20120826.3b81805-0ubuntu0mythbuntu2

  • Delete all Video Sources
  • Recreate just Hotbird setup. (i.e. DiseqC 1 LNB 2, DiseqC 2 LNB 2).
  • Scan for Hotbird

...and it's now picking up just the Freesat stuff. This leads me to believe it's not sending the DiseqC commands at all.

It's not a hardware fault; last night I was able to use w_scan to check all feeds successfully (simultaneously):

w_scan -ft -a0 -cGB -E0 -X >> ~/channels.dvb-t.free.conf
w_scan -fs -cGB -sS28E2 -D0c -E0 -X >> ~/channels.dvb-s.Astra_and_EuroBird.free.conf
w_scan -fs -cGB -sS13E0 -D1c -E0 -X >> ~/channels.dvb-s.HotBird.free.conf

...taking ~10, ~20. and ~40 minutes respectively.

Note I had tried to import the channels.dvb-s.HotBird.free.conf to set up the transports and then do a scan of all transports. That was simply a different route to the same result.

Just had a thought that it might be the TBS driver I updated as well, but I've rolled that back with exactly the same result.

Any more information I can provide? Any SQL to run?

comment:5 Changed 6 years ago by Ian Richardson <grandmastermarclar@…>

It looks like a rather more subtle bug. I can scan for channels on 13E, but only if I'm explicitly using the higher numbered tuner, via the inputs screen. If I go in via channels it uses the lowest numbered tuner for the selected input source, and that one refuses to scan.

...but I swapped the leads while the BE was running and about to scan for channels, and could then re-scan on both. Rebooted, then was back to where I was before. The disconnect may have forced the resending of DiseqC commands.

Have there been any changes in the area of "I don't need to tell the DiseqC anything because I already know what state it's in" which have made it through to the channel scanning code???

Note I'm now running 2:0.26.0~master.20120828.ae54e3b-0ubuntu0mythbuntu2

Note: See TracTickets for help on using tickets.