Modify
Warning Please read the Ticket HowTo before creating or commenting on a ticket. Failure to do so may cause your ticket to be rejected or result in a slower response.

Opened 20 months ago

Closed 17 months ago

#11047 closed Bug Report - Crash (Fixed)

Possible mythuiimage decref segfault

Reported by: trebor_s@… Owned by: stuartm
Priority: major Milestone: 0.26.1
Component: Plugin - MythMusic Version: Master Head
Severity: low Keywords:
Cc: Ticket locked: no

Description

The call to im->DecrRef?() in mythuiimage.cpp in the customEvent method can cause a segfault. I had one segfault when I was listening to internet radio with the mythmusic plugin and it tried to fetch the Deutschland Radio logo.
Adding a check "if (im)" fixed that. Patch attached.

Attachments (1)

mythuiimage_decref.patch (540 bytes) - added by anonymous 20 months ago.

Download all attachments as: .zip

Change History (8)

Changed 20 months ago by anonymous

comment:1 Changed 20 months ago by stuartm

  • Component changed from MythTV - General to Plugin - MythMusic
  • Milestone changed from unknown to 0.26
  • Owner set to stuartm
  • Priority changed from minor to critical
  • Status changed from new to accepted

comment:2 Changed 19 months ago by stuartm

The patch treats the symptom but not the root cause. That pointer should not be null and I'll need to do some digging to discover exactly how it came to be deleted.

comment:3 Changed 19 months ago by stuartm

  • Milestone changed from 0.26 to 0.26.1

comment:4 Changed 19 months ago by Stuart Morgan <smorgan@…>

In b4deb185994d6388b55cea18aa3e861c71541101/mythtv:

Prevent a segfault in MythUIImage, this doesn't fix the root cause of the problem but at least we won't crash. Refs #11047

comment:5 Changed 19 months ago by Stuart Morgan <smorgan@…>

In 178ea5aaa562845e3685ffeff585ea57c6014a64/mythtv:

Prevent a segfault in MythUIImage, this doesn't fix the root cause of the problem but at least we won't crash. Refs #11047

comment:6 Changed 19 months ago by stuartm

  • Priority changed from critical to major
  • Severity changed from medium to low

comment:7 Changed 17 months ago by stuartm

  • Resolution set to Fixed
  • Status changed from accepted to closed

Too many other things to worry about, so closing this.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'new'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.