Opened 7 years ago

Closed 7 years ago

#11048 closed Bug Report - Crash (Duplicate)

Segfaults on BBC recordings

Reported by: Andy Boff <mythtv@…> Owned by:
Priority: blocker Milestone: 0.26
Component: MythTV - Video Decoding Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

(Version set to "Master Head" as 0.26beta isn't available)

MythFrontend/Mythavtest? segfaults when attempting to play back all tested recordings from BBC4, and a majority from BBC2 (both FreeView?). I don't have any BBC3 recordings to test with.

Having run with "mythavtest --loglevel debug -v libav", it would appear that the segfault occurs whilst parsing the MPEG streams (of which there are several data streams in addition to the AV & subtitle streams).

Mythtranscode --mpeg2 also segfaults on the files (presumably for the same reason). Processing the files with "ffmpeg -i <file> -acodec copy -vcodec copy <outfile>" results in a file that Myth will play.

Some of the recordings that segfault have previously played back fine under 0.25-fixes.

Attached should be a backtrace for the segfault (generated running mythfrontend under gdb), mediainfo and "ffmpeg -i" for an affected file, and a log from running "mythavtest -v libav --loglevel debug" for the same file.

A gdb backtrace of mythavtest for that same file is not included, as the file plays back successfully when running under gdb, but segfaults when run normally (possibly indicating a race condition?)

Version info:

> mythavtest --version
Please attach all output as a file in bug reports.
MythTV Version : v0.26-beta-32-g7203f17
MythTV Branch : master
Network Protocol : 75
Library API : 0.26.20120807-1
QT Version : 4.8.1
Options compiled in:
 linux profile use_hidesyms using_alsa using_oss using_pulse using_pulseoutput using_backend using_bindings_perl using_bindings_python using_bindings_php using_crystalhd using_dvb using_firewire using_frontend using_hdhomerun using_ceton using_hdpvr using_iptv using_ivtv using_joystick_menu using_libcec using_libcrypto using_libdns_sd using_libxml2 using_lirc using_mheg using_opengl_video using_qtwebkit using_qtscript using_qtdbus using_v4l2 using_x11 using_xrandr using_xv using_bindings_perl using_bindings_python using_bindings_php using_mythtranscode using_opengl using_vaapi using_vdpau using_ffmpeg_threads using_live using_mheg using_libass using_libxml2

Attachments (4)

segfault-backtrace.txt (5.1 KB) - added by Andy Boff <mythtv@…> 7 years ago.
Backtrace of segfault (mythfrontend)
segfault-libav_log.txt (7.1 KB) - added by Andy Boff <mythtv@…> 7 years ago.
Mythavtest libav debug log
segfault-mediainfo.txt (3.1 KB) - added by Andy Boff <mythtv@…> 7 years ago.
Mediainfo of affected file
segfault-ffmpeg-i.txt (2.4 KB) - added by Andy Boff <mythtv@…> 7 years ago.
ffmpeg -i of affected file

Download all attachments as: .zip

Change History (9)

Changed 7 years ago by Andy Boff <mythtv@…>

Attachment: segfault-backtrace.txt added

Backtrace of segfault (mythfrontend)

Changed 7 years ago by Andy Boff <mythtv@…>

Attachment: segfault-libav_log.txt added

Mythavtest libav debug log

Changed 7 years ago by Andy Boff <mythtv@…>

Attachment: segfault-mediainfo.txt added

Mediainfo of affected file

Changed 7 years ago by Andy Boff <mythtv@…>

Attachment: segfault-ffmpeg-i.txt added

ffmpeg -i of affected file

comment:1 Changed 7 years ago by mythtv@…

I am experiencing the same problem on some recordings (from BBC THREE) recorded from freeview. I can provide a link to a .mpg file that exhibits this behaviour on my system on request (poke me on IRC)

-- Seeker`

comment:2 Changed 7 years ago by douglas.mackay@…

Possibly the same or related to ticket #11029

comment:3 Changed 7 years ago by stuartm

Milestone: unknown0.26
Priority: minorblocker

comment:4 Changed 7 years ago by mythtv@…

Able to reproduce behavior by adding the offending file to Myth Video and attempting to play back from there. Doesn't seem to matter which playback profile is in use.

comment:5 Changed 7 years ago by Jim Stichnoth

Resolution: Duplicate
Status: newclosed

Closing as a duplicate of earlier ticket #11029. Thanks Andy Boff for the debug output and Seeker` for the sample.

Note: See TracTickets for help on using tickets.