Modify
Warning Please read the Ticket HowTo before creating or commenting on a ticket. Failure to do so may cause your ticket to be rejected or result in a slower response.

Opened 17 months ago

Closed 9 months ago

#11290 closed Bug Report - General (Fixed)

New recordings don't show in mythweb

Reported by: Yianni Vidalis <yiannividalis@…> Owned by: dekarl
Priority: minor Milestone: 0.27
Component: Plugin - MythWeb Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

In mythweb, the most recent recording that shows up in the Recorded Programs screen is of 22 Nov, any more recent are not visible. If I choose from the Show Recordings list any individual show, they appear if all the recorded episodes are before that date. If even one episode is more recent, the screen returns to the "All recordings" group.

I keep database backups and I know that on that date I was on 3e01436 (mythtv) and probably f9f5a1f43f2ddf in mythweb.

I tried reverting mythweb to that commit but due to all the other changes in mythtv the Recorded Programs screen was not even visible (just white...).

MythTV Version : v0.27-pre2-350-g5173ecb-dirty
MythTV Branch : master
Network Protocol : 76
Library API : 0.27.20121204-2
QT Version : 4.8.3
Options compiled in:
 linux debug use_hidesyms using_alsa using_oss using_pulse using_pulseoutput using_backend using_bindings_perl using_bindings_python using_bindings_php using_dvb using_frontend using_ceton using_hdpvr using_libcrypto using_libfftw3 using_libxml2 using_libudf using_lirc using_mheg using_opengl_video using_qtwebkit using_qtscript using_qtdbus using_v4l2 using_x11 using_xrandr using_xv using_bindings_perl using_bindings_python using_bindings_php using_mythtranscode using_opengl using_vdpau using_ffmpeg_threads using_mheg using_libxml2 using_libudf

Best Regards,

Yianni

Attachments (0)

Change History (8)

comment:1 Changed 13 months ago by kormoc

  • Status changed from new to infoneeded_new

Is this still an issue?

comment:2 Changed 13 months ago by Yianni Vidalis <yiannividalis@…>

Yes, unfortunately it is. I've updated to 6b1671b4c7 just in case it was corrected but the most recent recorded show is of Oct 31, 2012 (due to autoexpiring, I assume).

How can I help solving this?

comment:3 Changed 11 months ago by Yianni Vidalis <yiannividalis@…>

I am now at mythweb commit 7b86ada21aa8c (mythtv head at c1fa4a2e8df77)and I've noticed that by entering the "All recordings" screen I get the "No matching programs found. Showing all programs" message.

The "Show recordings" list has two entries:

All recordings
UPDATE_FILE_SIZE 4023 2013-04-18T04:25:00Z 0

How can I decypher this?

comment:4 Changed 9 months ago by paulh

  • Status changed from infoneeded_new to new

comment:5 Changed 9 months ago by Karl Dietz <dekarl@…>

In 032d7633949015b7489e2b1c4e52b20d19d1aa45/mythtv:

mythweb does not handle MESSAGEs from the backend

This changes the announce to not receive any events at all.
I could not find a reference to any uses of events with PHP, if
there are some we can turn this into a parameter.
This fixes the recording list on mythweb erroring out with the
option to select the series "UPDATE_FILE_SIZE 4092 2009-09-29T02:58:42 290586314"
if a recording is in progress and the event comes down the socket before
the list of recorded programs.

Refs #11290

comment:6 Changed 9 months ago by yiannividalis@…

I can confirm I have my recordings back. Thanks, Karl.

comment:7 Changed 9 months ago by dekarl

  • Milestone changed from unknown to 0.27
  • Owner changed from kormoc to dekarl
  • Status changed from new to accepted

comment:8 Changed 9 months ago by dekarl

  • Resolution set to Fixed
  • Status changed from accepted to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'new'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.