Opened 6 years ago

Last modified 5 years ago

#11297 new Bug Report - General

Artifacts in H264 decoding on internal player, software decoding

Reported by: Chris <wombatius@…> Owned by:
Priority: minor Milestone: unknown
Component: MythTV - Video Playback Version: 0.26
Severity: medium Keywords:
Cc: Ticket locked: no

Description

When a video is being played on the internal player using software decoding, artifacts slowly creep into the frame, and then are cleared every few seconds. (The graphics card in the machine doesn't support VDPAU, so I can't switch to that). The weird thing is that this doesn't happen if I compile ffplay with the myth* variants of the ffmpeg libraries, (and mplayer on the same machine has no problems).

https://filetea.me/t1sc8b62 is a clip that shows this, the video was originally ripped with handbrake, but I've used avidemux to rip out one scene where it's pretty obvious (when the camera pans towards the guy on the piano). This process seems to cause the internal player to stutter a bit, but the corruption is still there (and doesn't happen using the myth version of ffplay)

Change History (8)

comment:1 Changed 6 years ago by Chris <wombatius@…>

This is what I get for not reading how file uploads work - here's an actual link to the file https://anonfiles.com/file/97484620ec1929a583cd369c42ec7f6f

comment:2 Changed 6 years ago by Chris <wombatius@…>

After some more experimentation with my encoding settings, part of the problem seems to be related to weighted p-frames. If I use handbrake and turn them off, the artifacts are reduced (but still there unlike in mplayer). I don't know if this is just masking the true problem, since ffplay compiled with the myth* libraries still doesn't show these artifacts.

comment:3 Changed 6 years ago by J.Pilk@…

I've been testing transcoding from DVB-T2 (UK) to near pal-dvd format. Using ffmpeg I see artefacts - mostly small random rectangles; using mythffmpeg from a week-old build of 0.26-fixes, they aren't there. ATrpms and related builds, el6 i686.

Bad version: built on Mar 20 2012 04:56:34 with gcc 4.4.6 20110731 (Red Hat 4.4.6-3)

Good version: (myth)ffmpeg version 0.10.2.git Copyright...

built on Dec 16 2012 16:32:40 with gcc 4.4.6 20120305 (Red Hat 4.4.6-4)

mythffmpeg -threads 2 -v verbose -i "/home/john/Mythrecs/1102_20121207205600.mpg" -target pal-dvd -b:v 6000k -s 720x576 -acodec mp2 -b:a 256k -ac 2 -aspect 16:9 "/mnt/MythOnRoot/Mytharch_work/work/1/newfile2.mpg"

Of course it's much easier to get something like this by recording the SD version...

comment:4 Changed 6 years ago by Chris <wombatius@…>

Transcoding isn't the issue for me - it's just when stuff is being played back with the internal player that these show up. This problem has been around since at least 0.22, I can't remember if it happened before that though.

comment:5 Changed 6 years ago by shauns2029@…

I had the same problem. Fixed by turning on the deblocking filter.

Setup > TV Settings > Playback > Playback Profiles Make sure that Deblocking Filter is turned on.

comment:6 Changed 6 years ago by stuartm

Status: newinfoneeded_new

comment:7 Changed 5 years ago by Chris <wombatius@…>

Sorry for the long delay, took me a while to get back to the machine that has this problem. On 0.27 with the deblocking filter on, I still get the corruption.

comment:8 Changed 5 years ago by Karl Egly

Status: infoneeded_newnew
Note: See TracTickets for help on using tickets.