Opened 6 years ago

Closed 5 years ago

#11548 closed Bug Report - Hang/Deadlock (Duplicate)

mythffmpeg gets stuck while archiving to a DVD

Reported by: Mark Munkacsy <Mark_Munkacsy@…> Owned by:
Priority: minor Milestone: unknown
Component: Plugin - MythArchive Version: 0.26
Severity: medium Keywords: mythffmpeg
Cc: Ticket locked: no

Description

While using mytharchive to create a DVD, mythffmpeg sometimes gets stuck, apparently at the end of the conversion process. The mythffmpeg process will run for days (if you let it), slowing growing in memory use. Based on the size of the converted file being created, it looks like mythffmpeg runs okay up until the output file is about the expected final size. Then the file stops growing, and mythffmpeg just sucks up CPU. In the attached logfiles, mythffmpeg locked up while converting the third of four files being put onto the DVD.

Attachments (3)

mythburn.log (39.6 KB) - added by Mark Munkacsy <Mark_Munkacsy@…> 6 years ago.
progress.log (10.0 KB) - added by Mark Munkacsy <Mark_Munkacsy@…> 6 years ago.
gdb.2.txt (13.4 KB) - added by Mark Munkacsy <Mark_Munkacsy@…> 6 years ago.

Download all attachments as: .zip

Change History (6)

Changed 6 years ago by Mark Munkacsy <Mark_Munkacsy@…>

Attachment: mythburn.log added

Changed 6 years ago by Mark Munkacsy <Mark_Munkacsy@…>

Attachment: progress.log added

Changed 6 years ago by Mark Munkacsy <Mark_Munkacsy@…>

Attachment: gdb.2.txt added

comment:1 Changed 6 years ago by Mark Munkacsy <Mark_Munkacsy@…>

(Please ignore attachment "gdb.txt" -- I'll delete it if I can figure out how. The correct attachment is gdb.2.txt, which contains a trace of mythffmpeg after it became stuck.)

comment:2 Changed 6 years ago by martin.scharnke@…

My experience with mytharchive in 0.26, after correcting for UTC issues, is that mythffmpeg ALWAYS (not sometimes) get stuck.

comment:3 Changed 5 years ago by paulh

Resolution: Duplicate
Status: newclosed

Duplicate of #12026

Note: See TracTickets for help on using tickets.