Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#12440 closed Bug Report - Crash (Duplicate)

Video crash on Frontend playback

Reported by: Justin Alcorn <justin@…> Owned by: JYA
Priority: major Milestone: 0.28
Component: MythTV - Video Playback Version: Master Head
Severity: high Keywords: playback video crash
Cc: Ticket locked: no

Description

Mythtv on Ubuntu, 0.28

Mythfrontend has been working fine, I use it to check commercial detection before transcoding. Since recent update, playback of recordings on the Frontend results in a window with Please Wait..., then video crash and audio continues. I have to killall mythfrontend.real to stop the audio.

I ran mythfronend -v playback and captured the following...

2015-04-24 20:03:04.372269 I TV::TV(): Creating TV object 2015-04-24 20:03:04.392334 I TV::TV(): Finished creating TV object 2015-04-24 20:03:04.392359 N Suspending idle timer 2015-04-24 20:03:04.394731 I TV::Init(): Created TvPlayWindow?. 2015-04-24 20:03:04.467456 I TV::HandleStateChange?(): Attempting to change from None to WatchingPreRecorded? 2015-04-24 20:03:04.468589 I FileRingBuf?(/var/lib/mythtv/recordings/2207_20150424050300.mp4): OpenFile?(/var/lib/mythtv/recordings/2207_20150424050300.mp4, 2000 ms) 2015-04-24 20:03:04.504298 I TV::StartPlayer?(): Elapsed time since TV constructor was called: 132 ms 2015-04-24 20:03:04.533992 E ALSA: snd_pcm_info_get_card: Operation not permitted 2015-04-24 20:03:04.548942 N AudioPlayer?: Enabling Audio 2015-04-24 20:03:04.553509 I Player(0): Stretch Factor 1, allow passthru 2015-04-24 20:03:04.553710 I AFD: Buffer size: 32768 streamed 0 seekable 1 2015-04-24 20:03:04.655414 I AFD: Stream #0, has id 0x1 codec id H264, type Video, bitrate 1145714 at 0x5fe7a40 2015-04-24 20:03:04.655443 I AFD: Stream #1, has id 0x2 codec id AAC, type Audio, bitrate 160521 at 0x5fe8840 2015-04-24 20:03:04.655452 I AFD: codec AAC has 2 channels 2015-04-24 20:03:04.655462 I AFD: Looking for decoder for AAC 2015-04-24 20:03:04.658057 I AFD: Opened codec 0x5fe8c20, id(AAC) type(Audio) 2015-04-24 20:03:04.658139 I AFD: Stream #2, has id 0x3 codec id AC3, type Audio, bitrate 384000 at 0x5feca60 2015-04-24 20:03:04.658148 I AFD: codec AC3 has 2 channels 2015-04-24 20:03:04.658154 I AFD: Looking for decoder for AC3 2015-04-24 20:03:04.658628 I AFD: Opened codec 0x5fece40, id(AC3) type(Audio) 2015-04-24 20:03:04.658652 I AFD: Trying to select best video track 2015-04-24 20:03:04.658677 I AFD: Selected track #0 (id 0x1 codec id H264, type Video, bitrate 1145714 at 0x5fe7a40) 2015-04-24 20:03:04.659828 I VDP: Accepting: cmp(> 0 0) dec(ffmpeg) cpus(2) skiploop(enabled) rend(opengl) osd(opengl2) osdfade(enabled) deint(greedyhdoubleprocessdeint,greedyhdeint) filt() 2015-04-24 20:03:04.659848 I VDP: LoadBestPreferences?(2048x2048, 0) 2015-04-24 20:03:04.659879 I VDP: LoadBestPreferences?(2048x2048, 60) 2015-04-24 20:03:04.659902 I VDP: LoadBestPreferences?(720x404, 60) 2015-04-24 20:03:04.659969 I AFD: Using 2 CPUs for decoding 2015-04-24 20:03:04.659981 I AFD: InitVideoCodec?() 0x5fe7e40 id(H264) type (Video). 2015-04-24 20:03:04.660020 I AFD: Selected FPS is 30 (avg 30 codec 179.82 container 90000 estimated 60) 2015-04-24 20:03:04.660049 I Player(0): SetFrameInterval? ps:1 scan:3 2015-04-24 20:03:04.660077 I Player(0): detectInterlace(Detect Scan, Interlaced Scan, 30, 404) ->Interlaced Scan 2015-04-24 20:03:04.660110 I AFD: Using ffmpeg for video decoding 2015-04-24 20:03:04.662242 I AFD: Opened codec 0x5fe7e40, id(H264) type(Video) 2015-04-24 20:03:04.662458 I AOBase: Opening audio device 'default' ch 2(2) sr 48000 sf 32 bit floating point reenc 0 2015-04-24 20:03:04.683416 E ALSA: no playback control PCM found on mixer device default 2015-04-24 20:03:04.683429 E ALSA: Unable to open audio mixer. Volume control disabled 2015-04-24 20:03:04.683523 I Dec: Selected track #1 (type 2) in the Unknown language(0) 2015-04-24 20:03:04.683541 I Dec: Resyncing position map. posmapStarted = 0 livetv(0) watchingRec(0) 2015-04-24 20:03:04.684917 I Dec: SyncPositionMap? prerecorded, from DB: 0 entries 2015-04-24 20:03:04.685642 I AFD: Recording has no position -- using libavformat seeking. 2015-04-24 20:03:04.685789 I AFD: Successfully opened decoder for file: "/var/lib/mythtv/recordings/2207_20150424050300.mp4". novideo(0) 2015-04-24 20:03:04.687997 I VideoOutput?: Allowed renderers: xv-blit,xshm,xlib,opengl,opengl-lite,vdpau,openglvaapi 2015-04-24 20:03:04.688045 I VideoOutput?: Allowed renderers (filt: ffmpeg): xlib,xshm,xv-blit,opengl,opengl-lite,vdpau,openglvaapi 2015-04-24 20:03:04.688933 I VDP: Accepting: cmp(> 0 0) dec(ffmpeg) cpus(2) skiploop(enabled) rend(opengl) osd(opengl2) osdfade(enabled) deint(greedyhdoubleprocessdeint,greedyhdeint) filt() 2015-04-24 20:03:04.688953 I VDP: LoadBestPreferences?(2048x2048, 0) 2015-04-24 20:03:04.688981 I VDP: LoadBestPreferences?(2048x2048, 60) 2015-04-24 20:03:04.689004 I VDP: LoadBestPreferences?(720x404, 60) 2015-04-24 20:03:04.689033 I VideoOutput?: Preferred renderer: opengl 2015-04-24 20:03:04.689047 I VideoOutput?: Trying video renderer: 'opengl' 2015-04-24 20:03:04.698912 I VDP: Accepting: cmp(> 0 0) dec(ffmpeg) cpus(2) skiploop(enabled) rend(opengl) osd(opengl2) osdfade(enabled) deint(greedyhdoubleprocessdeint,greedyhdeint) filt() 2015-04-24 20:03:04.698935 I VDP: LoadBestPreferences?(2048x2048, 0) 2015-04-24 20:03:04.698964 I VDP: LoadBestPreferences?(2048x2048, 60) 2015-04-24 20:03:04.699008 I VideoOutWindow::SetPIPState. pip_state: 0] 2015-04-24 20:03:04.699021 I VDP: LoadBestPreferences?(2048x2048, 30) 2015-04-24 20:03:04.699062 I Display Rect left: -323, top: 0, width: 2566, height: 1080, aspect: 1.33333 2015-04-24 20:03:04.699077 I Video Rect left: 0, top: 0, width: 720, height: 404, aspect: 1.78218 2015-04-24 20:03:04.699089 I VDP: LoadBestPreferences?(720x416, 30) 2015-04-24 20:03:04.699117 I Display Rect left: -323, top: 0, width: 2566, height: 1080, aspect: 1.33333 2015-04-24 20:03:04.699131 I Video Rect left: 0, top: 0, width: 720, height: 404, aspect: 1.78218 2015-04-24 20:03:04.699143 I VDP: SetVideoRenderer?(opengl) 2015-04-24 20:03:04.699153 I VDP: SetVideoRender?(opengl) == GetVideoRenderer?() 2015-04-24 20:03:04.699164 I ColourSpace?: PictureAttributes?: Brightness, Contrast, Colour, Hue, Studio Levels, 2015-04-24 20:03:04.713828 W OpenGL: Could not determine whether Sync to VBlank is enabled. 2015-04-24 20:03:04.722065 I Trying the OpenGL 2.0 render 2015-04-24 20:03:04.729198 I OpenGL2: GLSL supported 2015-04-24 20:03:04.729289 I OpenGL: OpenGL vendor : X.Org 2015-04-24 20:03:04.729298 I OpenGL: OpenGL renderer: Gallium 0.4 on AMD ARUBA 2015-04-24 20:03:04.729304 I OpenGL: OpenGL version : 3.0 Mesa 10.1.3 2015-04-24 20:03:04.729317 I OpenGL: Max texture size: 16384 x 16384 2015-04-24 20:03:04.729324 I OpenGL: Max texture units: 8 2015-04-24 20:03:04.729342 I OpenGL: Direct rendering: Yes 2015-04-24 20:03:04.729349 I OpenGL: PixelBufferObject? support available greedyhdeint: size changed from 0 x 0 -> 720 x 416 greedyhdeint: size changed from 0 x 0 -> 720 x 416 2015-04-24 20:03:04.759816 I OpenGL: Initialised MythRenderOpenGL 2015-04-24 20:03:04.759828 I VidOutGL: Created MythRenderOpenGL device. 2015-04-24 20:03:04.760826 I VideoOutput?: Pixel dimensions: Screen 1920x1080, window 1920x1080 2015-04-24 20:03:04.760857 I VideoOutput?: Xinerama display dimensions: 381x286 mm Aspect: 1.33217 2015-04-24 20:03:04.760866 I VideoOutput?: Estimated window dimensions: 381x286 mm Aspect: 1.33217 2015-04-24 20:03:04.760903 I OpenGL painter using existing OpenGL context. 2015-04-24 20:03:04.760905 I OpenGL painter using existing QGLWidget. 2015-04-24 20:03:04.760941 I GLVid: Viewport: 1920x1080 2015-04-24 20:03:04.762179 I GLVid: Creating master filter. 2015-04-24 20:03:04.765087 I GLVid: Using custom UYVY input textures. 2015-04-24 20:03:04.765105 I GLVid: Creating resize filter. 2015-04-24 20:03:04.770511 I OpenGL: Created frame buffer object (720x404). 2015-04-24 20:03:04.770572 I GLVid: MMX: 1 PBO: 1 2015-04-24 20:03:04.770606 I VDP: GetFilteredDeint?() : opengl -> 'greedyhdoubleprocessdeint' 2015-04-24 20:03:04.771373 I FilterManager?: GetFilterInfo?(convert) returning: 0x0 2015-04-24 20:03:04.771392 I FilterManager?: GetFilterInfo?(greedyhdoubleprocessdeint) returning: 0x7d5bfd0 2015-04-24 20:03:04.772097 I VideoOutput?: Using deinterlace method greedyhdoubleprocessdeint 2015-04-24 20:03:04.772148 I Display Rect left: -323, top: 0, width: 2566, height: 1080, aspect: 1.33333 2015-04-24 20:03:04.772158 I Video Rect left: 0, top: 0, width: 720, height: 404, aspect: 1.78218 2015-04-24 20:03:04.772199 I Display Rect left: -323, top: 0, width: 2566, height: 1080, aspect: 1.33333 2015-04-24 20:03:04.772210 I Video Rect left: 0, top: 0, width: 720, height: 404, aspect: 1.78218 2015-04-24 20:03:04.773871 I Over/underscan. V: 0, H: 0 2015-04-24 20:03:04.773891 I Display Rect left: -323, top: 0, width: 2566, height: 1080, aspect: 1.33333 2015-04-24 20:03:04.773901 I Video Rect left: 0, top: 0, width: 720, height: 404, aspect: 1.78218 2015-04-24 20:03:04.773946 I Player(0): LoadFilters?(..) -> 0x0 2015-04-24 20:03:04.775302 I Player(0): Decoder thread starting. 2015-04-24 20:03:04.779239 I OSD: Loaded window osd_message 2015-04-24 20:03:04.784500 I OSD: Loaded window osd_input 2015-04-24 20:03:04.793683 I OSD: Loaded window program_info 2015-04-24 20:03:04.799546 I OSD: Loaded window browse_info 2015-04-24 20:03:04.804495 I OSD: Loaded window osd_status 2015-04-24 20:03:04.807964 I OSD: Loaded window osd_program_editor 2015-04-24 20:03:04.818569 I OSD: Loaded window osd_debug 2015-04-24 20:03:04.818585 I OSD: Loaded OSD: size 1920x1080 offset 0+0 2015-04-24 20:03:04.818695 I OSD: Created window aa_OSD_SUBTITLES 2015-04-24 20:03:04.818740 I Player(0): ClearAfterSeek?(0) 2015-04-24 20:03:04.819523 I VDP: GetFilteredDeint?() : opengl -> 'greedyhdoubleprocessdeint' 2015-04-24 20:03:04.819670 I VDP: GetFilteredDeint?() : opengl -> 'greedyhdoubleprocessdeint' 2015-04-24 20:03:04.820361 I FilterManager?: GetFilterInfo?(convert) returning: 0x0 2015-04-24 20:03:04.820377 I FilterManager?: GetFilterInfo?(greedyhdoubleprocessdeint) returning: 0x7d51180 2015-04-24 20:03:04.820864 I VideoOutput?: Using deinterlace method greedyhdoubleprocessdeint QOpenGLContext::swapBuffers() called with non-exposed window, behavior is undefined QOpenGLContext::swapBuffers() called with non-exposed window, behavior is undefined 2015-04-24 20:03:04.851193 I Player(0): Video timing method: DRM 2015-04-24 20:03:04.851210 I Player(0): Display Refresh Rate: 60.020 Video Frame Rate: 30.000 2015-04-24 20:03:04.851222 I Player(0): SetFrameInterval? ps:1 scan:1 2015-04-24 20:03:04.865182 I playCtx: StartPlaying?(): took 0 ms to start player. 2015-04-24 20:03:04.865229 I TV::StartPlayer?(): Created player. 2015-04-24 20:03:04.865326 I TV::HandleStateChange?(): Changing from None to WatchingPreRecorded? 2015-04-24 20:03:04.867210 I TV::HandleStateChange?(): Main UI disabled. 2015-04-24 20:03:04.867317 I TV::StartTV(): Entering main playback loop. 2015-04-24 20:03:04.879371 I ScreenSaverDBus: Successfully inhibited screensaver via org.freedesktop.ScreenSaver?. cookie 1168825301. nom nom 2015-04-24 20:03:04.879886 E ScreenSaverDBus: Failed to disable screensaver: Method "Inhibit" with signature "ss" on interface "org.gnome.SessionManager?" doesn't exist

2015-04-24 20:03:04.880006 I Player(0): Waiting for video buffers... 2015-04-24 20:03:04.897885 I Player(0): Video Aspect ratio changed from 1.78218 to 1.78212 2015-04-24 20:03:04.897914 I Display Rect left: -323, top: 0, width: 2566, height: 1080, aspect: 1.33333 QOpenGLContext::swapBuffers() called with non-exposed window, behavior is undefined 2015-04-24 20:03:04.897928 I Video Rect left: 0, top: 0, width: 720, height: 404, aspect: 1.78212 2015-04-24 20:03:04.897944 I Player(0): progressive frame seen after 2 interlaced frames QOpenGLContext::swapBuffers() called with non-exposed window, behavior is undefined QOpenGLContext::swapBuffers() called with non-exposed window, behavior is undefined QOpenGLContext::swapBuffers() called with non-exposed window, behavior is undefined QOpenGLContext::swapBuffers() called with non-exposed window, behavior is undefined QOpenGLContext::swapBuffers() called with non-exposed window, behavior is undefined QOpenGLContext::swapBuffers() called with non-exposed window, behavior is undefined 2015-04-24 20:03:04.970343 I Display Rect left: -323, top: 0, width: 2566, height: 1080, aspect: 1.33333 2015-04-24 20:03:04.970369 I Video Rect left: 0, top: 0, width: 720, height: 404, aspect: 1.78212 2015-04-24 20:03:04.970410 I Player(0): Disabled deinterlacing QOpenGLContext::swapBuffers() called with non-exposed window, behavior is undefined QOpenGLContext::swapBuffers() called with non-exposed window, behavior is undefined QOpenGLContext::swapBuffers() called with non-exposed window, behavior is undefined QOpenGLContext::swapBuffers() called with non-exposed window, behavior is undefined

That continues until I interrupt with Ctrl-c

Attachments (1)

playbackcrash.txt (12.1 KB) - added by Justin Alcorn <justin@…> 4 years ago.
Output from mythfrontend -v playback at time of crash

Download all attachments as: .zip

Change History (4)

Changed 4 years ago by Justin Alcorn <justin@…>

Attachment: playbackcrash.txt added

Output from mythfrontend -v playback at time of crash

comment:1 Changed 4 years ago by Justin Alcorn <justin@…>

I discovered that the crash happens in any OPENGL, VDPAU or VAAPI Video PLlayback profile in frontend settings, but I was able to get it to work with just "High QUality" setting (But at clearly degraded quality).

comment:2 Changed 4 years ago by Frank Phillips <fphillips81@…>

Duplicate #12421

You need to give the mythfrontend --version so we know specifically what you're using.

When running master, please follow the recent bugs and commits so you're not reporting something that has already been reported/fixed.

comment:3 Changed 4 years ago by Jonatan Lindblad

Milestone: 0.28
Resolution: Duplicate
Status: newclosed

Closing as duplicate of #12421.

You can reopen this ticket if you still can reproduce this on commit 2b01ed3 or later. Also please don't trim the logs since it contains important information like MythTV and Qt version.

https://code.mythtv.org/trac/wiki/TicketHowTo

https://www.mythtv.org/wiki/Posting_Logs

Last edited 4 years ago by Jonatan Lindblad (previous) (diff)
Note: See TracTickets for help on using tickets.