Opened 3 years ago

Closed 3 years ago

#12915 closed Bug Report - General (Duplicate)

Mytharchive failed to produce DVD but appears to have deleted the files to be archived

Reported by: myth@… Owned by:
Priority: critical Milestone: 0.28.1
Component: Plugin - MythArchive Version: 0.28.0
Severity: high Keywords: dataloss
Cc: Ticket locked: no

Description

I attempted to create a DVD with four recordings but it failed with the error "cannot write mode I as jpeg". I googled that and found this page:

<https://ubuntuforums.org/showthread.php?t=1959406&p=12151885#post12151885>

where it suggested working around that by changing the theme to Compact. I tried that and ran into various oddities (sizes showing as many terabytes, for instance) but eventually was able to get the DVD set up, at which point the log file (attached) told me the files couldn't be found. And sure enough, they were gone; if I try to play them from dvd front end, I get a message saying they are not present (and looking in the directory, the .ts files are missing, just the .ts.png files are there).

This is with Ubuntu 16.10 with the mytharchive in the mytharchive package version 2:0.28.0+fixes.20160413.15cf421-0ubuntu2.

Attachments (2)

mythburn.log (1.4 KB) - added by myth@… 3 years ago.
Log file from 2nd attempt (first one is gone, I guess overwritten)
progress.log (1.6 KB) - added by myth@… 3 years ago.
Log file from 2nd attempt (first one is gone, I guess overwritten)

Download all attachments as: .zip

Change History (8)

Changed 3 years ago by myth@…

Attachment: mythburn.log added

Log file from 2nd attempt (first one is gone, I guess overwritten)

Changed 3 years ago by myth@…

Attachment: progress.log added

Log file from 2nd attempt (first one is gone, I guess overwritten)

comment:1 Changed 3 years ago by J.Pilk@…

Those logs just say that the recording couldn't be found. I suppose that they were in a format that required transcoding, and mythburn.py line 1748 shows it is using the --outfile option. See #12845.

I have no problems with pre-cut recordings that do not need re-encoding.

comment:2 Changed 3 years ago by myth@…

Maybe I wasn't clear, these are from the second attempt, not the first. The files really aren't there. Unfortunately, and logs from the run that deleted them appear to have been overwritten. If there are other logs I could send, please let me know.

comment:3 Changed 3 years ago by J.Pilk@…

No, I'm afraid it all fits together. This link from #12845 suggests a workaround - make a .tmp copy first - but won't restore anything already lost.

http://lists.mythtv.org/pipermail/mythtv-users/2016-August/388220.html

comment:4 Changed 3 years ago by myth@…

I see. I think my work around will be to uninstall mytharchive and use other means to burn CDs. Unfortunate, as it would have been handy, but this kind of data loss is unacceptable.

comment:5 Changed 3 years ago by Stuart Auchterlonie

Milestone: unknown0.28.1

comment:6 Changed 3 years ago by JYA

Resolution: Duplicate
Status: newclosed

duplicate of #12845

Note: See TracTickets for help on using tickets.