Opened 7 months ago

Last modified 6 months ago

#13418 infoneeded Bug Report - Crash

Segmentation fault: when starting livetv with ExternalStreamHandler using jpoet Colossus2 support

Reported by: ibedonc Owned by: jpoet
Priority: major Milestone: needs_triage
Component: MythTV - General Version: v29.1
Severity: medium Keywords: colossus2
Cc: Ticket locked: no

Description

was asked by jpoet to open this

my dump is to big so here is a link to my cloud server https://www.roosterclaw.net/owncloud/index.php/s/yyDXrduT3l3to7l

recordings work , just not livetv also using hdhrrecorder blackbox works with livetv

Change History (8)

comment:1 Changed 7 months ago by jpoet

Owner: set to jpoet
Status: newaccepted

comment:2 Changed 7 months ago by jpoet

ibedonc, is that attachment a back trace? A back trace should not be near that big -- it is just a text file.

comment:3 Changed 7 months ago by jpoet

Status: acceptedinfoneeded

Hi ibedonc. Thank you for creating the ticket. Please attach a backtrace. You can find instructions here:

https://code.mythtv.org/trac/wiki/TicketHowTo https://www.mythtv.org/wiki/Debugging

Thanks.

comment:4 Changed 7 months ago by ibedonc

sorry first time I have ever done this , creating the back trace now

comment:5 Changed 7 months ago by ibedonc

that link is a zip (179M) file of /var/crash/_usr_bin_mythbackend.110.crash that is not what you need ?

ProblemType?: Crash Architecture: amd64 Date: Thu Feb 28 19:39:40 2019 DistroRelease?: Ubuntu 18.04 ExecutablePath?: /usr/bin/mythbackend ExecutableTimestamp?: 1550607517 ProcCmdline?: /usr/bin/mythbackend --quiet --syslog local7 ProcCwd?: / ProcEnviron?:

LANG=en_US.UTF-8 PATH=(custom, no user) SHELL=/bin/bash

ProcMaps?:

55f27698e000-55f276c0c000 r-xp 00000000 09:00 4718731 /usr/bin/mythback

comment:6 Changed 7 months ago by ibedonc

Status: infoneededassigned

forgot to change status

comment:7 Changed 6 months ago by jpoet

Status: assignedinfoneeded

Hi ibedonc. I am available again, and can work on this.

The file you have linked to seems to have a core dump embedded in it. There is not much I can do with that since my system is not identical to yours. A back trace is a textual representation of what all the threads in the program where doing when it crashed. That combined with a log file should allow me to figure out what when wrong.

I did try and reproduce the crash on my own system, but LiveTV with the hauppauge2 external recorder worked okay -- within the limits of LiveTV and MythTV. In other words, I did get some "Could no open decoder" errors, but when it got past that, everything worked as expected.

comment:8 Changed 6 months ago by ibedonc

ubuntu puts crash files in /var/crash , that is where that came from

I was out of town for a week , I have a new system that I have not had the time to put in place , I plan on putting .30 on it and I will test it with that

Note: See TracTickets for help on using tickets.