Opened 14 years ago

Closed 13 years ago

Last modified 13 years ago

#1964 closed defect (fixed)

MythWeb program listing does not properly display channels with duplicate numbers

Reported by: Yeechang Lee <ylee@…> Owned by: xris
Priority: minor Milestone: 0.21
Component: mythweb Version: 0.19
Severity: medium Keywords: mythweb program listings channels
Cc: Ticket locked: no

Description

On my 0.19-fixes (ATrpms) system, I have some channels that, although they are on different tuners (cable box and OTA) and are different stations, have identical channel numbers.

While mythfrontend's program listings properly display all such duplicate channels, MythVideo?'s equivalent feature does not, only displaying one of the two duplicates (the one on the lower-numbered tuner), making scheduling recordings on the missing channels impossible.

Change History (10)

comment:1 Changed 13 years ago by Yeechang Lee <ylee@…>

Component: mythvideomythweb
Keywords: mythweb added; mythvideo removed
Owner: changed from Anduin Withers to xris
Summary: MythVideo program listing does not properly display channels with duplicate numbersMythWeb program listing does not properly display channels with duplicate numbers

I of course mean MythWeb, not MythVideo?. Apologies for the egregious typo.

comment:2 Changed 13 years ago by xris

Milestone: 0.21

Marked #1036 as a dupe. MythWeb needs to group things by callsign instead of channum/etc. This will hopefully happen in .21, but unfortunately won't make it into .20.

comment:3 Changed 13 years ago by xris

oops, that should be #2036

comment:4 in reply to:  2 Changed 13 years ago by knowledgejunkie@…

Replying to xris:

Marked #1036 as a dupe. MythWeb needs to group things by callsign instead of channum/etc. This will hopefully happen in .21, but unfortunately won't make it into .20.

xris,

I noticed that this bug can also affect the scheduling of recordings if you set one up via a search/canned search.

If you have specified channel priorities based on source quality etc, you have to be careful which of the duplicate results you click on to schedule a recording, as the recordng inherits the priority of the channel. There therefore appears to be the possbility of setting up a recording and having it not record due to its final priority in the scheduler.

comment:5 Changed 13 years ago by josesuarez1983

I have this channel number problem too. In Madrid there are two local DVB muxes with 4 channels both of them. They are numbered from 1 to 4 in both muxes, so there are two 1s,... and two 4s. What happens to me is that I can see all the channels in the TV Guide (the EIT thing) but when I zap channels in LiveTV (I mean, just TV, with no TV Guide showing) there are 4 of them which don't appear at all (Their names don't show up on the OSD after going through a complete channel change cycle). So I guess this is not a problem only related to MythWeb, but also to LiveTV.

This is the relevant part of the dump of the channel database stuff:

INSERT INTO channel VALUES (1001,'1',NULL,1,'8MADRID','8MADRID','none',NULL,,,0,32768,32768,32768,32768,'Default',0,1,,0,1,1,NULL,0,0,0),
(1002,'2',NULL,1,'POPULARTV','POPULARTV','none',NULL,
,,0,32768,32768,32768,32768,'Default',0,1,,0,1,2,NULL,0,0,0),
(1003,'3',NULL,1,'Intereconomia','Intereconomia','none',NULL,,,0,32768,32768,32768,32768,'Default',0,1,,0,1,3,NULL,0,0,0),
(1004,'4',NULL,1,'KissTV','KissTV','none',NULL,
,,0,32768,32768,32768,32768,'Default',0,1,,0,1,4,NULL,0,0,0),
(1005,'1',NULL,1,'EM2','EM2','none',NULL,,,0,32768,32768,32768,32768,'Default',0,1,,0,2,1,NULL,0,0,0),
(1006,'2',NULL,1,'Libertad Digital TV','Libertad DigitalTV','none',NULL,
,,0,32768,32768,32768,32768,'Default',0,1,,0,2,2,NULL,0,0,0),
(1007,'3',NULL,1,'VER-T','VER-T','none',NULL,,,0,32768,32768,32768,32768,'Default',0,1,,0,2,3,NULL,0,0,0),
(1008,'4',NULL,1,'esMADRIDtv','esMADRIDtv','none',NULL,
,,0,32768,32768,32768,32768,'Default',0,1,,0,2,4,NULL,0,0,0),
[...]

comment:6 Changed 13 years ago by xris

Is this still an issue in svn trunk?

comment:7 Changed 13 years ago by Janne Grunau

Resolution: fixed
Status: newclosed

it is fixed in trunk

comment:8 Changed 13 years ago by Nick Morrott <knowledgejunkie@…>

Resolution: fixed
Status: closedreopened

As I reported in #2036 (which was marked as a dupe of this ticket as it has a common root) I see all duplicate channels - same channum and callsign - across all video sources when using the channel selector list on the mythweb page host/mythweb/tv/channel/xx/ where xx is a chanid.

I *still* see this behavour on 13242. Was Janne referring to a different but related issue, or this whole ticket in general?

Cheers, Nick

comment:9 Changed 13 years ago by Janne Grunau

Resolution: fixed
Status: reopenedclosed

This ticket is about the mythweb/tv/list page. This issue is solved. Channels with identical channum and callsign are grouped together, channels with the same channum but different callsigns aren't.

I see still "duplicates" in the channel selection dropdown box. But it's for me a feature, not a bug. Even if they channels are the same I use different data sources for each (DVB EIT and a xmltv grabber). So the duplication allows me to compare the different data without remembering my chanids.

I close this ticket again. You're free to reopen the other ticket. It's not an exact duplicate.

comment:10 Changed 13 years ago by Nick Morrott <knowledgejunkie@…>

Janne,

Thanks for the update. I will re-open #2036 (I re-opened this ticket because when I did open #2036 initially, it was immediately closed as a dupe of this ticket...).

If you have different channums and callsigns, I would expect the channel dropdown to contain all different channels, as the scheduler will treat them as different stations. However, one would never want to have channels on different sources configured with the same channum/callsigns but use different listings data, as this would surely cause the scheduler to have fits.

If the channels are configured properly as being the same station, and use the same listings data for scheduling, I would only expect to see 1 copy of the channel (either off the matching chanids), as there is no reason at all to show them all.

Cheers, Nick

Note: See TracTickets for help on using tickets.