Opened 13 years ago

Closed 13 years ago

#2094 closed defect (duplicate)

DVB-T EIT data problems (bogus dates, insufficient descriptions)

Reported by: otto at kolsi dot fi Owned by: danielk
Priority: minor Milestone: unknown
Component: dvb Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

With SVN 10631, there are still some problems with DVB-T EIT data.

Almost daily, program table gets data with either very old or future dates (years like 1902 or 2037). Below is one example. This only really causes problems with mythweb, which doesn't handle this kind of data very well.

 
2006-07-25 09:04:58.736 MSqlQuery: DELETE from program WHERE chanid    = 1007 AND       starttime = '1902-03-23T18:59:21'
2006-07-25 09:04:58.743 MSqlQuery: DELETE from credits WHERE chanid    = 1007 AND       starttime = '1902-03-23T18:59:21'
2006-07-25 09:04:58.750 MSqlQuery: REPLACE INTO program (  chanid,         title,          subtitle,        description,   category,       category_type,   starttime,      endtime,   closecaptioned, subtitled,      stereo,          hdtv,   partnumber,     parttotal,   airdate,        originalairdate,listingsource ) VALUES ( 1007,        '',         '',       '',  '',      '',  '1902-03-23T18:59:21',     '1902-03-30T18:47:06',  0,            0,     0,         0,  0,    0,  '0000',       NULL,   1 )

Additionally, some programs get insufficient descriptions. Description column in DB is of type text and column_size is 65535. There is no fixed upper limit for length of the descriptions that are cutted. Couple of examples of these descriptions have following lengths in DB: 211, 233, 235. I've started to put extra logging in place but so far haven't found anything interesting related to this problem.

Change History (1)

comment:1 Changed 13 years ago by Stuart Auchterlonie

Resolution: duplicate
Status: newclosed

Duplicate of #2051

Note: See TracTickets for help on using tickets.