Opened 13 years ago

Closed 12 years ago

#2930 closed enhancement (fixed)

enhancement: if all tuners are busy add ability to select a current recording when you select "watch tv".

Reported by: skamithi Owned by: skamithi
Priority: minor Milestone: 0.21
Component: mythtv Version: 0.20
Severity: medium Keywords:
Cc: mythtv@… Ticket locked: no

Description

Not sure if folks are interested in this, so I'll let it sit in my ticket folder for a while and wait for comments.

basically if you select Watch TV and all the tuners are busy, an option will come up and present you with all the currently recording shows on all the tuners.

I only have 1 tuner so i really just wanted a quicker way to jump straight into the active recording instead of having to to "Watch Recordings", then select the recording show.

Right now the option doesn't check if the show on the tuner is in the livetv recgroup or in another recgroup. I'll wait for comments to see if folks wants me to make sure that show(s) presented as an option is a recording show and not a live tv show.

Attachments (3)

tuner_busy.3.diff (4.1 KB) - added by skamithi 13 years ago.
tuner_busy.diff (4.9 KB) - added by skamithi 13 years ago.
final patch.
livetv.patch (2.9 KB) - added by Robin Neatherway <robthebob+myth@…> 12 years ago.

Download all attachments as: .zip

Change History (19)

comment:1 Changed 13 years ago by jose.bandos@…

That would be a nice enhancement. It's easier to tell my wife she can only see the show that is recording as the tuner is busy, than to have her go down to the "Watch recordings" and select the show currently recording.

comment:2 Changed 13 years ago by skamithi

Owner: changed from Isaac Richards to skamithi

comment:3 Changed 13 years ago by skamithi

Status: newassigned

comment:4 Changed 13 years ago by skamithi

Milestone: unknown0.21

Changed 13 years ago by skamithi

Attachment: tuner_busy.3.diff added

Changed 13 years ago by skamithi

Attachment: tuner_busy.diff added

final patch.

comment:5 Changed 12 years ago by Neil McBride <neil@…>

I've just patched my box with this to test it out. I have three tuners on there, kicked off three recordings and tried Watch Live TV. It worked like a charm. Nice work ;)

comment:6 Changed 12 years ago by skamithi

(In [12704]) Refs #2930. enhancement. if all tuners are busy, add ability to select a current recording when you select "watch tv".

comment:7 Changed 12 years ago by hads

Cc: mythtv@… added

This is a cool sounding feature - nice one. I just updated to trunk from 0.20-fixes to check it out but it doesn't appear to be working for me. The frontend just flicks a black screen and goes back to the main menu.

With verbose set to playback I see the error message;

TV Error: Failed to get recording show list

in the frontend log. From reading the source it looks like it can't get the currently recording list for some reason or other.

Cheers,

hads

comment:8 Changed 12 years ago by anonymous

This appears to be caused by the bug in #3040 - the way I was testing there were no shows marked as currently recording which would be the reason that it couldn't get the currently recording list.

comment:9 Changed 12 years ago by skamithi

Resolution: fixed
Status: assignedclosed

comment:10 Changed 12 years ago by keller

Resolution: fixed
Status: closedreopened

TV Error: Failed to get recording show list

I see above where someone else had this issue. I'm seeing this error with an immediate return to the main menu. This is a brand new install with a fresh database and latest SVN.

I've tried to tweak the code to get past it. It's almost like, since this is a fresh install, the code doesn't know what to do when there are no recordings available in history at all.

Any hints on what I might add to the database to get past this error once? Something in the code? I've reinstalled twice and am still having this issue. Anyone else?

Let me know if I can give any other helpful information.

-Keller

comment:11 Changed 12 years ago by keller

I found a workaround to this.

I downloaded [12703], the revision just before this new feature was added. Installed on all machines and setup myth as normal.

Then, I upgraded all machines to latest SVN. Error went away and TV works fine. Looks like the latest SVN requires an earlier version to work properly.

Let me know if I can provide any more information that would be helpful.

-Keller

comment:12 Changed 12 years ago by keller

Nevermind, the issue came back again. Output from -v most :

2007-11-29 17:50:34.745 MythSocket?(b239bd68:20): attempting connect() to (10.2.0.12:6543) 2007-11-29 17:50:34.745 MythSocket?(b239bd68:20): state change Idle -> Connected 2007-11-29 17:50:34.745 write -> 20 27 ANN Monitor KellerDesktop? 1 2007-11-29 17:50:34.771 read <- 20 2 OK 2007-11-29 17:50:34.771 MythSocket?(b239bd68:20): UpRef?: 1 2007-11-29 17:50:34.771 write -> 22 23 GET_FREE_RECORDER_COUNT 2007-11-29 17:50:34.771 MythSocket?: readyread thread start 2007-11-29 17:50:34.772 read <- 22 1 0 2007-11-29 17:50:34.772 write -> 22 26 QUERY_RECORDINGS Recording 2007-11-29 17:50:34.776 read <- 22 1 0 2007-11-29 17:50:34.777 TV Error: Failed to get recording show list

comment:13 Changed 12 years ago by keller

Issue disappeared when I moved the master backend to the backend with the tuners. Looks like there's an issue with using a non-tuner backend as the master backend. Probably not a myth issue, but my settings issue.

Thanks!

-Keller

comment:14 Changed 12 years ago by skamithi

Resolution: fixed
Status: reopenedclosed

comment:15 Changed 12 years ago by Robin Neatherway <robthebob+myth@…>

Resolution: fixed
Status: closedreopened

For systems with only one tuner, the well-intended behaviour of going straight to the only current recording is still confusing. I would like to recommend that the popup be displayed whether or not the system only has one tuner. Please see this brief discussion: http://www.gossamer-threads.com/lists/mythtv/dev/302609

Patch attached. Apologies as svn diff hasn't been very clever about it.

Changed 12 years ago by Robin Neatherway <robthebob+myth@…>

Attachment: livetv.patch added

comment:16 Changed 12 years ago by skamithi

Resolution: fixed
Status: reopenedclosed

(In [15037]) Closes #2930. display recording list popup on systems with only one tuner, if tuner is recording and "Watch TV" is selected.

Note: See TracTickets for help on using tickets.