Modify

Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#3189 closed defect (fixed)

Mythfrontend rescales themes every startup.

Reported by: anonymous Owned by: stuartm
Priority: trivial Milestone: 0.21
Component: mythtv Version: head
Severity: low Keywords:
Cc: Ticket locked: no

Description

Although there is caching I see the rescaling progress bar every time I (re)start mythfrontend. This takes time.

Attachments (2)

mylog2.txt (3.8 KB) - added by anonymous 11 years ago.
mythfrontend log
image_cache.diff (680 bytes) - added by stuartm 11 years ago.

Download all attachments as: .zip

Change History (23)

comment:1 Changed 11 years ago by janne

  • Resolution set to worksforme
  • Status changed from new to closed

please attach the output of mythfrontend -v most

Changed 11 years ago by anonymous

mythfrontend log

comment:2 Changed 11 years ago by anonymous

  • Resolution worksforme deleted
  • Status changed from closed to reopened

comment:3 Changed 11 years ago by ijr

  • Resolution set to invalid
  • Status changed from reopened to closed

It's just checking to see if there's anything to rescale.

comment:4 Changed 11 years ago by anonymous

  • Resolution invalid deleted
  • Status changed from closed to reopened

It is generating cache images as well.

comment:5 Changed 11 years ago by ijr

  • Resolution set to invalid
  • Status changed from reopened to closed

2 very small images, which looks like it's taking about 0.2 seconds. Make sure the timestamp on them isn't in the future, and the "problem" will go away.

comment:6 Changed 11 years ago by anonymous

  • Resolution invalid deleted
  • Status changed from closed to reopened

Timestamp is not in the future:

# ls -l /usr/share/mythtv/themes/default/blank.png -rw-r--r-- 1 root root 151 Feb 23 08:24 /usr/share/mythtv/themes/default/blank.png # ls -l /usr/share/mythtv/themes/Retro/blank.png -rwxr--r-- 1 1000 1000 151 Mar 13 2006 /usr/share/mythtv/themes/Retro/blank.png

comment:7 Changed 11 years ago by ijr

  • Resolution set to invalid
  • Status changed from reopened to closed

I still don't consider taking an extra 2 tenths of a second on startup to be a bug.

comment:8 Changed 11 years ago by anonymous

The progess bar is longer on the screen than 2 tenths of a second. And if the images are processed, why at all if the cache allows for 2 cached copies? If not a bug may I at least understand?

comment:9 Changed 11 years ago by anonymous

  • Resolution invalid deleted
  • Status changed from closed to reopened

comment:10 Changed 11 years ago by cpinkham

  • Resolution set to invalid
  • Status changed from reopened to closed

When the lead developer of a project closes your ticket THREE times, it's a sign that the issue you are seeing is not an issue and probably won't be investigated. Trac is not a discussion forum. If you want to talk about this and get some help, try asking on the mythtv-users mailing list or in the #mythtv-users IRC channel. Constantly reopening this ticket will just tick the developers off and get you ignored.

comment:11 Changed 11 years ago by anonymous

Nice to know that a developer does not want to pay attention to a problem I observe and support with a logfile. The fact that a logfile does not cohere with what is on teh screen is their issue as well.

comment:12 Changed 11 years ago by someone else

I see this everytime I startup mythtv as well.

comment:13 follow-up: Changed 11 years ago by anonymous

This started happening to me only once I changed from the default theme. I'm using blue, but I didn't test any other. I can't find the mythfrontend.log file even using find, and the files in the blue theme directory are all dated 12/20/2006.

By any chance, could the code that's checking the timestamp be looking in a third directory or even failing in the check?

comment:14 in reply to: ↑ 13 Changed 11 years ago by anonymous

For me this does not take 2/10 of a second. It does the prescaling theme images 3 times and several minutes in total, maybe slower because i have a humble 32mb graphics card on my VIA EPIA MII motherboard. So for me this is a real issue.

comment:15 Changed 11 years ago by anonymous

KnoppMyth? user (R5E50) here, using blootube wide. My timestamps are ok, and I see this too. Takes about 5-8 seconds, every time, even when aborting from the "do you want to quit" screen. I'm just offering another data point.

comment:16 Changed 11 years ago by sphery <mtdean@…>

KnoppMyth? user: you are (like many of the people here probably are) seeing Myth checking to verify it already has pre-scaled images (and it does, or it would take much more than 10 seconds). To prove this, shut down mythfrontend and remove the cache directories ("rm -r $HOME/.mythtv/{theme,osd}cache"), then restart mythfrontend. You'll notice a /large/ difference in the time required to scale the images.

anonymous who's seeing prescaling "3 times and several minutes in total": the graphics card has no effect on scaling speed, only the CPU, RAM, and I/O subsystem does (so, your Via processor is why it takes 3 minutes). The reason it's scaling every time is a configuration issue, probably like below.

anonymous who's using bluetube: the user running mythfrontend doesn't have write permissions on $HOME/.mythtv/ or $HOME/.mythtv/{theme,osd}cache or some subdirectory. You can probably fix it by a) verifying you've specified the proper "export HOME=/whatever" in the script that starts mythfrontend and b) "rm -r $HOME/.mythtv/{theme,osd}cache"

anonymous who uploaded a log file (and who feel slighted because he doesn't get the support to which he's entitled): you are starting mythfrontend in an environment in which the HOME environment variable resolves to "/root", so mythfrontend is using /root/.mythtv for its image cache. There is no possible way that any user (other than root) would have access to this directory on a properly-configured system. You are running as root, so it works. (But for others reading this ticket's comments, please keep in mind what I mentioned about HOME resolving to /root). You'll also notice that your log only shows the generation of 2 images and attempts to generate 4 (for files missing from the theme) and it only takes seconds. Therefore, you're seeing the same as KnoppMyth? user, above.

All: this is not a discussion forum. Please post questions to the -users mailing list or ask on #mythtv-users on freenode to verify that you're seeing a bug before creating tickets or adding comments to tickets. Oh, and we don't need more "me too's." Thanks.

comment:17 Changed 11 years ago by stuartm

  • Priority changed from major to trivial
  • Resolution invalid deleted
  • Severity changed from medium to low
  • Status changed from closed to reopened

Although most images are loaded from the cache each time, a handful are loaded before themecachedir is defined so they are rescaled every time.

I've attached a one-line fix which seems to work fine but as I'm not sure whether there are undesirable consequences that I haven't had the time to spot, so please test.

comment:18 Changed 11 years ago by stuartm

  • Owner changed from ijr to stuartm
  • Status changed from reopened to new

Changed 11 years ago by stuartm

comment:19 Changed 11 years ago by devel@…

Wow! Mythfrontend starts almost instantaneously for me now, the image scaling dialog barely flashes on the screen. Thanks for this, certainly works for me

comment:20 Changed 11 years ago by stuartm

  • Resolution set to fixed
  • Status changed from new to closed

(In [13506]) Closes #3189

Initialise the theme cache earlier to avoid rescaling images loaded in the creation of MythThemeBase?. Should decrease the startup time of mythfrontend.

comment:21 Changed 11 years ago by stuartm

(In [13557]) Backports [13506] to -fixes.

Refs #3189. Initialise the theme cache earlier to avoid rescaling images loaded in the creation of MythThemeBase?. Should decrease the startup time of mythfrontend.

Add Comment

Modify Ticket

Action
as closed The owner will remain stuartm.
The resolution will be deleted. Next status will be 'new'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.