Opened 13 years ago

Closed 11 years ago

#3254 closed defect (invalid)

Hybrid card : MythSocket timeout on set_channel

Reported by: anonymous Owned by: danielk
Priority: minor Milestone: unknown
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I use hybrid digital/analog card ASUSTeK P7131 Hybrid. I cannot switch from digital to analog channel properly, there's MythSocket? timeout, "SendReceiveStringList?(): No response." on frontend, NVP is started sooner than it should and crashes with "Unknown error, exiting decoder.". Subsequent attempts to run LiveTV usually succeed on a second or more likely third try, since the card is usually fully switched and tuned at that time. The card is correctly configured as a hybrid type as per #2617 instructions.

The problem is that mythtv is set to use "quick" 7 second timeout on all MythSocket? connections, while SET_CHANNEL operation on my card may take a bit longer when switching from digital to analog. I patched SET_CHANNEL to use "slow" timeout and I was able to switch between channels without any problem.

I suppose this issue might be similar to #3079 or #1133.

I am including my take on a patch against svn 13114.

Attachments (1)

SetChannel_slowTimeout.patch (1.5 KB) - added by jerry.tk+mythtv@… 13 years ago.
Longer timeout for SetChannel?

Download all attachments as: .zip

Change History (3)

Changed 13 years ago by jerry.tk+mythtv@…

Longer timeout for SetChannel?

comment:1 Changed 11 years ago by danielk

Owner: changed from Isaac Richards to danielk
Status: newaccepted

comment:2 Changed 11 years ago by danielk

Resolution: invalid
Status: acceptedclosed

This was a valid ticket once, but hybrid support has changed...

Note: See TracTickets for help on using tickets.