Opened 12 years ago

Closed 11 years ago

#3435 closed defect (duplicate)

Program Guide crashes mythfrontend

Reported by: anonymous Owned by: Isaac Richards
Priority: minor Milestone: 0.21
Component: mythtv Version: 0.20
Severity: medium Keywords: program guide frontend crash
Cc: Ticket locked: no

Description

Whenever I go to the program guide from live TV, mythfrontend crashes. This has been going on for a long time, but I use the guide rarely enough that it's not a big deal.

In particular, the guide will flash on the screen for a fraction of the second, and then mythfrontend will exit, not gracefully.

The program guide works fine if I access it from the "schedule recordings" menu.

The program guide used to work fine with my computer, for a previous installation of MythTV. The differences are that I went from Fedora to Ubuntu (Edgy), from mythtv .18 to .20, and from a computer monitor to a different video card and tv-out.

Every other feature of MythTV which I've tried to use has worked fine.

I am attaching two files: a log and and the results of pushing &> to a file, while performing the minimal actions necessary to generate the bug: opening mythfrontend, selecting "Watch TV", bringing up the on-screen menu, and selecting "Program Guide."

Attachments (1)

err.txt (4.7 KB) - added by Todd Johnson 12 years ago.
The output to STDERR & STDOUT when the error happens, plus some output to the console (a backtrace) not caught by either.

Download all attachments as: .zip

Change History (8)

Changed 12 years ago by Todd Johnson

Attachment: err.txt added

The output to STDERR & STDOUT when the error happens, plus some output to the console (a backtrace) not caught by either.

comment:1 Changed 12 years ago by stuartm

Could you attach a backtrace created with gdb? http://mythtv.org/docs/mythtv-HOWTO-22.html#ss22.2

comment:2 in reply to:  1 Changed 12 years ago by johnsong@…

Hm. Is it possible to have two mythtv installations at once? I'd love to provide a trace, but I don't want to potentially break the otherwise-perfectly-fine installation that my fiancee knows and loves.

comment:3 Changed 12 years ago by stuartm

A debug build won't behave any differently to a normal build, so there is no danger of breaking your current setup by replacing it.

It is possible to have two installations at once, but I wouldn't really recommend it as it could end up causing more problems than it's worth.

comment:4 Changed 12 years ago by anonymous

Seems likely to be a dup of #2448 (that is, having a GUI size different from the TV resolution makes the program guide crash).

comment:5 in reply to:  4 Changed 12 years ago by anonymous

Replying to anonymous:

Seems likely to be a dup of #2448 (that is, having a GUI size different from the TV resolution makes the program guide crash).

Was having the same or a similar problem but a workaround which solved it for me was to switch from the proprietary 'fglrx' driver back to the open source 'ati' or 'radeon' driver for my ATI graphics card.

comment:6 Changed 12 years ago by stuartm

Milestone: 0.21
Status: newinfoneeded_new

We still need a backtrace created with gdb.

comment:7 Changed 11 years ago by danielk

Resolution: duplicate
Status: infoneeded_newclosed

Duplicate of #4148, #2448

Note: See TracTickets for help on using tickets.