Opened 13 years ago

Closed 11 years ago

#3441 closed defect (wontfix)

Recorded Programmes page does not show no of recordings/disk usage correctly

Reported by: Nick Morrott <knowledgejunkie@…> Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: mythtv Version: head
Severity: medium Keywords: mythweb recordings diskspace
Cc: Ticket locked: no

Description

I run 2 backends which each have local storage for recordings - the slave backend usually only records LiveTV as the master backend contains 4 tuners and caters for almost all scheduled recordings.

Looking at the recordings/disk usage stat shows numbers that do not make sense:

"64 programmes, using 138 GB (3 days 22 mins) out of 186 GB (67 GB free)"

In total, there really are 64 programmes, of which 17 are LiveTV recordings on the slave backend disk. However, the size of these recordings (~20GB) is being included in the total usage figure of 138GB, when the other two figures - total space and free space - only relate to the master backend, when the slave is not connected. The actual usage on the master machine is ~119GB, which agrees with the other two values in the above stat.

Should we count and label recordings per host, and only update the relevant stats depending on whether other backends are connected? For example, if my slave is not connected, I would prefer to see something like:

"master.backend: 47 programmes, using 119 GB (2 days 11 mins) out of 186 GB (67 GB free)" "slave.backend: 17 programmes, using 19 GB (1 days) (offline)"

and when connected:

"master.backend: 47 programmes, using 119 GB (2 days 11 mins) out of 186 GB (67 GB free)" "slave.backend: 17 programmes, using 19 GB (1 days) out of 140 GB (121 GB free)"

When the slave backend is connected currently, combined usage and combined free space are correctly updated to include both:

"64 programmes, using 138 GB (3 days 22 mins) out of 326 GB (188 GB free)"

Nick

Change History (8)

comment:1 Changed 13 years ago by xris

Component: mythwebmythtv
Owner: changed from xris to Isaac Richards

All of this data comes straight from the backend. Nothing MythWeb can do about it for now.

comment:2 Changed 12 years ago by paulh

Status: newinfoneeded_new

This is a really old ticket is this still a problem?

comment:3 in reply to:  2 Changed 12 years ago by Nick Morrott <knowledgejunkie (at) gmail (dot) com>

Replying to paulh:

This is a really old ticket is this still a problem?

I no longer run a slave backend, so can't say...

I've just posted a request to -users to see if anyone can confirm the current status of this issue before you close it.

Do any devs run slave backends that can confirm/refute this behaviour quickly?

comment:4 Changed 12 years ago by ylee@…

On my 0.21-fixes system with two backends, MythWeb displays the correct free space with the slave backend connected. I can't conclusively determine the accuracy of the total usage and total space figures as MythWeb rounds to the nearest tenth of a terabyte.

Note that each backend has all Myth storage directories mounted, which may prevent your bug (if it still exists) from triggering.

comment:5 Changed 12 years ago by anonymous

with slave backend connected: 62 programs, using 124 GB (3 days 2 hrs 50 mins) out of 523 GB (308 GB free).

with slave backend disconnected: 62 programs, using 124 GB (3 days 2 hrs 50 mins) out of 293 GB (134 GB free).

looks like problem is still there.

comment:6 Changed 11 years ago by Dibblah

Status: infoneeded_newnew

comment:7 Changed 11 years ago by sphery <mtdean@…>

See #6589 for a patch implementing the feature-request portion (show LiveTV (and other "re-usable") storage usage) and why counting/labeling recordings per host is (currently) impossible.

comment:8 Changed 11 years ago by stuartm

Resolution: wontfix
Status: newclosed

Sorry, but I have to close this as wontfix for now, since this the information to do what you want simply isn't there right now. The problem is rather trivial compared to the fix. If someone wants to work on it and submit a patch then re-open the ticket, Sphery may be able to give advice since he's looked into this.

Note: See TracTickets for help on using tickets.