Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#433 closed defect (worksforme)

mythtv-setup segfaults on channel scan with qam

Reported by: anonymous Owned by: danielk
Priority: minor Milestone: 0.20
Component: mythtv Version: head
Severity: low Keywords:
Cc: Ticket locked: no

Description

svn checkout #7404 HD card hd5000

While scanning for OTA channels the full scan works as planned. When doing a full QAM scan (or any QAM scan) the mythtv-setup program will segfault after it get's a lock on a station.

Attached is a backtrace from a failed scan.

Below is the console output from a failed scan

2005-10-07 13:23:33.943 DVB#0 Using DVB card 0, with frontend LG Electronics LGDT3303 VSB/QAM

Frontend.

2005-10-07 13:23:52.211 DVB#0 WARNING - Symbol Rate setting (0) is out of range (min/max:1076 2000/10762000) 2005-10-07 13:24:55.376 DVB#0 WARNING - Symbol Rate setting (0) is out of range (min/max:1076 2000/10762000) 2005-10-07 13:24:56.553 Could not find channel -1_-1 in CVCT 2005-10-07 13:24:56.553 VCT Cable: channels(1) tsid(0x1a) seclength(45) Channel #0 name() 1008-0 mod(SCTE mode 2) cTSID(0x1a)

pnum(10) ETM_loc(0) access_ctrl(0) hidden(0)

path_select(0) out_of_band(0) hide_guide(1) service_type(2) source_id(811)

2005-10-07 13:24:56.579 DVB#0 WARNING - Symbol Rate setting (0) is out of range (min/max:1076 2000/10762000) 2005-10-07 13:25:36.588 Program Association Table

PSIP prefix(0x0) tableID(0x0) length(17) extension(0x924)

version(22) current(1) section(0) last_section(0)

tsid: 2340

programCount: 2

program number 0 has PID 0x1ffc data 0x0 0x0 0x255 0x252 program number 24 has PID 0x 27 data 0x0 0x24 0x224 0x39

2005-10-07 13:25:36.629 PAT: Warning couldn't find better mplex.

Attachments (1)

scan_qam256 (22.9 KB) - added by anonymous 14 years ago.
backtrace after compiling with debug

Download all attachments as: .zip

Change History (6)

comment:1 Changed 14 years ago by danielk

Resolution: invalid
Status: newclosed

Broken backtrace.

You need to compile for debugging before making the backtrace, do something like this:

cd /mythtv-source-directory make distclean ./configure --compile-type=debug [..plus any other options you need..] qmake make su [type root password] make install

Changed 14 years ago by anonymous

Attachment: scan_qam256 added

backtrace after compiling with debug

comment:2 Changed 14 years ago by anonymous

Resolution: invalid
Status: closedreopened

Recompiled myth with debug support and attached a new backtrace.

comment:3 Changed 14 years ago by danielk

Thanks, it looks like the cached PMT is an invalid pointer. I can't figure out why, but I'll try to repeat this here next week.

comment:4 Changed 14 years ago by danielk

Milestone: 0.20
Resolution: worksforme
Severity: mediumlow
Status: reopenedclosed

I can't reproduce this and the backtrace doesn't help me.

Can print out the pmt tables it's getting, the pmt map, etc?

Perhaps this is something specific to the HD5000? Do you have an HD-3000 or Air2PC you can try?

comment:5 Changed 14 years ago by anonymous

I've got an HD-3000 that's exhibiting the same problem. When I run a scan, it will lock on to the first few stations fine, but there is one specific station it seems to crash on every time. I'll try to submit a backtrace soon.

Note: See TracTickets for help on using tickets.