Opened 12 years ago

Closed 12 years ago

#4339 closed patch (fixed)

Channel lock error message even though channel is tuned and displaying fine.

Reported by: Bill <cizek@…> Owned by: danielk
Priority: minor Milestone: 0.21
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

This is my patch the partially fixes the problem where sometimes in LiveTV the "You should have gotten a channel lock by now..." dialog appears, even though the channel is locked and playing fine. Reference dev list thread http://www.gossamer-threads.com/lists/mythtv/dev/305583?do=post_view_threaded#305583

Attachments (2)

070-livetvplay.patch (3.1 KB) - added by Bill <cizek@…> 12 years ago.
Partial fix for channel lock problem
4339-dbg-v1.patch (7.4 KB) - added by danielk 12 years ago.
Possible fix + plenty of extra debugging if this doesn't do it..

Download all attachments as: .zip

Change History (10)

Changed 12 years ago by Bill <cizek@…>

Attachment: 070-livetvplay.patch added

Partial fix for channel lock problem

comment:1 Changed 12 years ago by danielk

Milestone: unknown0.21
Owner: changed from Isaac Richards to danielk
Status: newassigned

comment:2 Changed 12 years ago by anonymous

While this seems to stop the lock error message displaying shortly after a channel lock. However, if you then start the channel changing process by pressing channel up or down, but rather than selecting a channel to change to you cancel the process to remove the OSD and continue viewing the current channel, the channel lock message then appears. Not sure if this helps fixing the problem or not but thought it might be useful to know.

comment:3 Changed 12 years ago by danielk

Thanks, additional info is helpful. I haven't actually sat down to debug this, but I do see it on occasion myself. For me it only appears upon entering LiveTV without an immediate channel change, and I never see any signal monitoring info upon entering LiveTV anymore which is probably related to this problem.

comment:4 Changed 12 years ago by matt.doran@…

I also see this problem.

I too see the warning dialog upon entering LiveTV. However it happens almost every time (if not every time)... which gets pretty annoying, and adversely effects the WAF. :)

The warning never appears when changing channels.

The tuning timeout settings in mythtv-setup don't seem to have any effect.

Sometimes the OSD doesn't even appear... other times it does appear and I can see the signal strength and that the lock has been achieved.

Daniel, given that I can reproduce this very consistently ... is there anything I can do to help? e.g. verbose logging, or anything else?

Changed 12 years ago by danielk

Attachment: 4339-dbg-v1.patch added

Possible fix + plenty of extra debugging if this doesn't do it..

comment:5 Changed 12 years ago by danielk

Can some of you experiencing this, test the patch I just attached?

From what I could tell this happens when we get a lock in between the time we temporarily disable locking inside the code handling the kState_None and kState_WatchingLiveTV transition. This could always happen in theory, but due to improvements in tuning time it now actually happens sometimes. This patch just records the time before we disable the lockTimer and if we get a lock in between that time and the time at which we re-enable the lockTimer we don't start the lockTimer up near the end of the state transition code.

comment:6 Changed 12 years ago by danielk

Type: defectpatch

comment:7 Changed 12 years ago by matt.doran@…

Daniel,

That looks good. I did some tests before applying the patch the warning displayed 7 out of 8 times entering live TV.

After the patch the warning wasn't displayed after entering live TV 8 times.

comment:8 Changed 12 years ago by danielk

Resolution: fixed
Status: assignedclosed

(In [15720]) Fixes #4339. Makes sure that we don't display the channel lock warning message if we get a lock during the transition from the none to livetv state in the TV class.

Note: See TracTickets for help on using tickets.