Opened 10 years ago

Closed 9 years ago

#5630 closed defect (fixed)

dvd gets stuck on copyright notice screen.

Reported by: nigel.jewell@… Owned by: skamithi
Priority: minor Milestone: 0.21.1
Component: mythdvd Version: 0.21-fixes
Severity: medium Keywords:
Cc: Ticket locked: yes

Description

Hi,

I have recently upgraded from MythTV 0.20-fixes on CentOS 4.x, to MythTV 0.21-fixes on CentOS 5.x.

Unfortunately I am now finding that 50% of my DVDs no longer play. With MythTV 0.20 I had no problems. With 0.21 the drive spins up, stops and a black screen is shown. On some DVDs if I press Enter the DVD will spin up again and show the copyright notice.

The same DVDs play fine from the same user account with mplayer, xine, vlc and ogle.

I will attach the output of "mythfrontend -v all", from startup to the point at which the frontend gets stuck on the black screen.

Settings of ./configure listed below. I'm have three Nova-T DVB-T cards and I am using the NVidia binary video drivers.

$./configure --enable-proc-opt --enable-opengl-vsync

# Basic Settings
Compile type              release
Compiler cache            no
DistCC                    no
install prefix            /usr/local
runtime prefix            /usr/local
CPU                       x86_32 (athlon)
big-endian                no
MMX enabled               yes
CMOV enabled              yes
CMOV is fast              no

# Input Support
Joystick menu             yes
lirc support              yes
Video4Linux sup.          yes
ivtv support              yes
FireWire support          yes
DVB support               yes [/usr/include]
DBox2 support             yes
HDHomeRun support         yes
IPTV support              yes

# Sound Output Support
OSS support               yes
ALSA support              yes
aRts support              yes
JACK support              no
libfftw3 support          no

# Video Output Support
x11 support               yes
xrandr support            yes
xv support                yes
XvMC support              yes
XvMC VLD support          yes
XvMC pro support          no
XvMC OpenGL sup.          no
XvMC libs                 -lXvMCW
OpenGL video              no
OpenGL vsync              yes
DirectFB                  yes
Fribidi formatting        no

# Misc Features
multi threaded libavcodec yes
Frontend                  yes
Backend                   yes

# Bindings
bindings_perl             yes
bindings_python           yes

Attachments (2)

mythfrontend.log.gz (38.6 KB) - added by nigel.jewell@… 10 years ago.
mythfrontend log
POCdvd.txt (8.3 KB) - added by jbpub@… 10 years ago.
pirates of the caribbean 1 mythfrontend.log cut

Download all attachments as: .zip

Change History (13)

Changed 10 years ago by nigel.jewell@…

Attachment: mythfrontend.log.gz added

mythfrontend log

comment:1 Changed 10 years ago by skamithi

Owner: changed from Anduin Withers to skamithi
Priority: majorminor
Status: newassigned
Summary: DVD Playback Regression (0.20 -> 0.21)dvd gets stuck on copyright notice screen.

comment:2 Changed 10 years ago by maillists@…

I'm seeing this too, and just about to raise a new ticket when I spotted this.

I'm running SVN TRUNK on a AMD64X2.

I've seen it on DVDs that have an initial language selection screen (eg. Region 2 Finding Nemo). I'd actually see the selection menu (typically with a static frame behind, I do remember that not so long ago that whether the background was visible or not was somewhat random and that has since been fixed), on making a selection the copyright screen would display and any attempt to nagivigate would fail (OSD indicating attempts to Skip Still Frame).

I've done a bit of digging, and I don't know if this will help but:

Once on the Copyright screen (which I assume is a still frame with an indication of period of display), DVDRingBufferPriv::safe_read isn't been called at all (which looking at the code it seems like it should be being called periodically until the period of display has elapsed).

Further to that, I found that if I comment out the InStillFrame?(true) call in AvFormatDecoder::GetFrame? giving a diff thus:

@@ -3171,7 +3175,7 @@

             if (mpeg_seq_end_seen && storevideoframes)
             {
-                ringBuffer->DVD()->InStillFrame(true);
+                //ringBuffer->DVD()->InStillFrame(true);
             }

The initial menu and the copyright notice aren't displayed, but on selecting an option (in the now invisible menu) playing of the DVD continues as one would expect.

Simon.,

comment:3 Changed 10 years ago by skamithi

i already have a dvd with the issue and will resolve the problem in a few weeks. workaround if you encounter this issue is to start the dvd from the scene selection menu.

comment:4 Changed 10 years ago by anonymous

skamithi,

Thanks for your reply - it would be good if you could sort this. I would help if I had a clue where to start ;)

I may be being completely dumb - but what "scene selection menu"? For example; if select "Play DVD" with "The Chronicles of Narnia - The Lion The Witch And The Wardrobe" (Region 2), the DVD spins up and I get a black screen with a single red line, presumably highlighting the menu option (it moves up and down). As soon as I press Select, I get the copyright notice and I can't move away from that. I can't select any scene, or find a scene selection menu.

Therefore, as I see it there are two problems:

  • the menu doesn't get displayed
  • the dvd gets stuck on the copyright notice screen

Nige.

comment:5 Changed 10 years ago by jbpub@…

I'm encountering this problem on Mythbuntu 8.10beta with Myth version 0.21.20080304-1 18722. The work around mentioned here works ONLY if there are no still frames before the root menu. Here are two example of disk that have still frames before the root menu and are unplayable.

1) Pirates of the Caribbean 1 -- disk shows the FBI warning page then freezes. I have to kill the frontend to regain control. I've attached a cut from my mythfrontend.log for this attempt.

2) Dexter Season 1 Disk 1 -- FBI then Showtime promo then drop back to mythfrontend

More on this issue: http://ubuntuforums.org/showthread.php?t=957143 https://bugs.launchpad.net/mythbuntu/+bug/288816 http://www.gossamer-threads.com/lists/mythtv/users/342498

I would love to see this issue upgraded from minor to major.

Thanks to the devs for all their hard work, Jon

Changed 10 years ago by jbpub@…

Attachment: POCdvd.txt added

pirates of the caribbean 1 mythfrontend.log cut

comment:6 Changed 10 years ago by skamithi

Status: assignedinfoneeded

your problem looks like a dup of #4902. can you confirm this ?

comment:7 Changed 10 years ago by nigel.jewell@…

I have seen that problem as well, but this is different as no menu is shown. The copyright notice is shown forever and the frontend has to be restarted. Do you think that you may have time to sort this?

comment:8 Changed 10 years ago by skamithi

Status: infoneededassigned

i got the same issue using Mad money dvd. the issue is not reproducible in trunk after the ffmpeg resync. I spent some time looking into the issue using a pre ffmpeg resync version, and couldn't figure it out. its not stuck on dvd_wait, it stuck reading the next frame from AFD..not sure why. If you can't figure it out, guess you'll have to just upgrade to trunk or wait for 0.22

comment:9 Changed 10 years ago by nigel.jewell@…

Fair enough - thanks for the update - appreciated.

comment:14 Changed 9 years ago by stuartm

Ticket locked: set

comment:15 Changed 9 years ago by skamithi

Resolution: fixed
Status: assignedclosed

fixed in trunk.

Note: See TracTickets for help on using tickets.