Opened 11 years ago

Closed 11 years ago

#5978 closed defect (fixed)

frame drop causes dvb subtitles to disappear

Reported by: jheikkal@… Owned by: danielk
Priority: trivial Milestone: 0.22
Component: Video Playback Version: head
Severity: low Keywords:
Cc: Ticket locked: no

Description

Hi, Noticed this defect recently... When watching channel/recording with dvb teletext on and frames are being dropped, subtitles disappear. When skipping backwards a bit, video is synced and subtitles are shown again for a while until frame drop. Don't know the cause of dropping because it's been working fine until now and dropping isn't even noticable. This happens with xv and xvmc. But I don't think frame drops should break subtitle rendering?

Attachments (1)

playback.log (5.4 KB) - added by jheikkal@… 11 years ago.
mythfrontend playback log

Download all attachments as: .zip

Change History (12)

Changed 11 years ago by jheikkal@…

Attachment: playback.log added

mythfrontend playback log

comment:1 Changed 11 years ago by jheikkal

Actually frame dropping isn't causing this. Disabling opengl vsync fixes dropping but still subtitles just disappear with no apparent reason in playback log.

'video_output' mean = '39999.29', std. dev. = '339.99', fps = '25.00' 2008-12-06 19:52:24.865 Clearing expired subtitles from OSD set 'video_output' mean = '39998.93', std. dev. = '129.54', fps = '25.00' 'video_output' mean = '39997.31', std. dev. = '348.05', fps = '25.00

Thats it, no more "setting subtitles visible" log output after that. Only seeking backwards fixes it.

Tried with two different machines with svn 19246. I'm out of ideas...

comment:2 Changed 11 years ago by danielk

Priority: majortrivial
Severity: mediumlow
Status: newinfoneeded_new

We will need a short sample of the video that exhibits this problem, ~15 seconds.

comment:3 in reply to:  2 Changed 11 years ago by nietu@…

Replying to danielk:

We will need a short sample of the video that exhibits this problem, ~15 seconds.

See more on #5991. In mine case problem appear after 5-10 min playback. I can upload needed stream. to where?

/Tommi

comment:4 Changed 11 years ago by jheikkal@…

Because problem appears between 10s to 10min here is one 10min clip. https://juhis.dy.fi/mythtv/DVB-text_sample.mpg Subtitle is finnish.

comment:5 Changed 11 years ago by danielk

Status: infoneeded_newnew

I'm putting this in my queue, but if anyone else wants to grab this ticket and fix this, please feel free.

comment:6 Changed 11 years ago by danielk

Owner: changed from Isaac Richards to danielk
Status: newassigned

comment:7 Changed 11 years ago by otto at kolsi dot fi

I can also reproduce this here with latest trunk. If needed I can try to produce more samples (if the problem remains in cut down version of the file).

comment:8 Changed 11 years ago by danielk

Status: assignedinfoneeded

I can't reproduce the problem with the DVB-text_sample.mpg. Otto if you have a sample that would help, the smaller the better. <30 seconds would be best.

comment:9 Changed 11 years ago by tomimo@…

I have noticed that this problem appears on every single recording that contains the DVB subtitles. It's only a matter of time (anything from a 30s to 10 minutes as somebody mentioned earlier). Interesting thing is that whenever the dvb subtitles disappear, it is enough to rewind 5-10s and start playing again and the subtitles start again. First I thought that it might be related to some problem with timecode (start & stop) values being out of sync or something, but now I noticed that whenever the subtitles disappear, nobody has been calling AddAVSubtitle() for a short while --> the existing decoded dvb subtitles get consumed and after that there is nothing to display anymore.

comment:10 Changed 11 years ago by tomimo@…

It looks like the fix mentioned here https://roundup.ffmpeg.org/roundup/ffmpeg/issue536 really does seems to work ---> checked one full movie with dvb subtitles without problems which hasn't been working for a long time.

comment:11 Changed 11 years ago by danielk

Resolution: fixed
Status: infoneededclosed

Fixed by [19641]. Apply robcam fix for subtitle issue, this has not yet been resolved upstream so I left a note for anyone doing the ffmpeg merge. Thanks to tomino for finding the upstream bug report.

Note: See TracTickets for help on using tickets.