Opened 11 years ago

Closed 10 years ago

#6469 closed defect (invalid)

Strange MythWeb Issue - "Unknown Program" on Upcoming Recordings screen when program has been previously recorded

Reported by: markdavidoff@… Owned by: xris
Priority: minor Milestone: unknown
Component: Plugin - MythWeb Version: 0.21
Severity: medium Keywords: recording
Cc: Ticket locked: no

Description

I went to check up on my mythweb.

It tells me on the Upcoming Recordings Screen that two programs are currently recording.

One is from the 8th (it did finish recording, and i did actually watch the show, so there was no problem there)

The other is recording now.

Upon clicking the actual completed program (from the 8th) It jumps to the program guide and says "Unknown Program"

I have one TV Tuner in my backend.

Attached are two relevant images

Attachments (2)

The Problem.jpg (151.1 KB) - added by anonymous 11 years ago.
Clicked.jpg (111.5 KB) - added by anonymous 11 years ago.

Download all attachments as: .zip

Change History (8)

Changed 11 years ago by anonymous

Attachment: The Problem.jpg added

Changed 11 years ago by anonymous

Attachment: Clicked.jpg added

comment:1 Changed 11 years ago by sphery <mtdean@…>

Restart your MythTV system (shut down all frontends and all backends, then restart).

comment:2 in reply to:  1 Changed 10 years ago by anonymous

Replying to sphery <mtdean@thirdcontact.com>:

Restart your MythTV system (shut down all frontends and all backends, then restart).

I have exactly the same issue.

After restarting manually stopping and then restarting the mythtv frontend/backend processes on this machine (the other frontend has been offline for days), there was no change.

comment:3 Changed 10 years ago by sphery <mtdean@…>

MythTV system = all Myth processes on all hosts. Did you do so?

Note that doing so will only fix the "still-recording" problem. However, the "Unknown Program" problem is due to the fact that listings info is only kept for 7 days, so (for the OP) on the 18th, the listings data from the 8th is gone--it is truly an "Unknown Program" (therefore, that part is not a bug).

comment:4 in reply to:  3 ; Changed 10 years ago by ian@…

Replying to sphery <mtdean@thirdcontact.com>:

MythTV system = all Myth processes on all hosts. Did you do so?

Yep, I shutdown all the Myth processes on the master backend and the only other Myth machine is a frontend that has been off for at least a week (and still is off).

The only possible exception is not closing MythWeb windows on various client machines, but that should make no difference at all as HTTP is not stateful in that sense and the backend was certainly shutdown.

I guess the next step is to reboot the machine, but I had hoped we could find the source of the problem.

If anyone has any ideas of things I should try before rebooting, let me know.

Out of interest, I'm running Mythbuntu (Intrepid, 0.21+fixes) with the MythTV weekly updates source enabled.

And yes, I understand about the "Unknown program".

comment:5 in reply to:  4 Changed 10 years ago by ian@…

Replying to ian@grug.redirectm.net:

Yep, I shutdown all the Myth processes on the master backend and the only other Myth machine is a frontend that has been off for at least a week (and still is off).

Ok, now this is interesting...

I decided to prove to myself once again that this was actually the case, I closed the frontend, shutdown the backend and did a "ps aux |grep -i "myth" to check there were no processes running. There was nothing except the session manager*. Just to be on the safe side, I exceuted a killall mythbackend, and restarted everything, and lo-and-behold it is fixed.

Now I am confused... if I ran everything under sudo, why should the killall make any difference. There was no process listed by ps under sudo!

  • The session manager is just a harmless bash script to load and unload stuff on session start and end

--- Nothing to see here, move along... ---

comment:6 Changed 10 years ago by Dibblah

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.