Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#6660 closed defect (fixed)

OSD not displaying in LiveTV when using xvmc-blit

Reported by: Marc Tousignant <drayson@…> Owned by: markk
Priority: minor Milestone: 0.22
Component: MythTV - General Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I have 2 profiles setup for playback, > 0 0 use xv-blit and chromakey and > 1280 720 use xvmc-blit and ia44blend.

Went watching LiveTV everything up to 720p works fine with the OSD. However, in LiveTV, anything over 720p that should use xvmc does not display the OSD.

If I reccord the channels that are having this issue and watch the recording the OSD works.

MarkK believes he knows the cause: When starting livetv, a dummy video stream is created before the channel is tuned. This is standard def (720x576) and the player uses standard xv-blit (based on your profiles).

Something however isn't being reset properly when the real hidef stream starts playing - and the osd isn't working. Should just be a matter of figuring out what needs to be re-initialised.

I am seeing this in r20745. Earliest known version that has this is unknown at this time.

Attachments (5)

colorkey_patch.diff (530 bytes) - added by markk 10 years ago.
colorkey_patch_better.diff (531 bytes) - added by markk 10 years ago.
improved colorkey/chroma osd check
colorkey_v3.diff (959 bytes) - added by markk 10 years ago.
LiveTV-07-01-2009.log (35.9 KB) - added by Marc Tousignant <drayson@…> 10 years ago.
Frontend playback logging on
colorkey_v4.diff (1.2 KB) - added by markk 10 years ago.

Download all attachments as: .zip

Change History (17)

comment:1 Changed 10 years ago by sphery <mtdean@…>

Perhaps similar to #5025 and [18114] ?

comment:2 Changed 10 years ago by Marc Tousignant <drayson@…>

Not #5025. In my situation the correct profile is being used. It is just that the OSD gets turned off in LiveTV when using that profile. I know this because my system is not powerfull enough to do 1080i without offloading to the video card via xvmc.

It might be similar to the issue that [18114] fixed with deinterlacing thou. But it is not a deinterlace issue, it is a reset OSD issue.

From what I gather from the explanation mark gave, is that when loading LiveTV it initially uses my other profile for the dummy stream. This dummy is using the chromakey OSD. But when switching to the other profile it is not resetting the OSD type and since chromakey does not work with nvidia cards after the 5 series it turns off chroma.

I am going to do some profile testing later tonight when I get home to see if using xvmc for all video bypasses the issue as well as seeing if using ia44blend, if I can, for both profiles works.

comment:3 Changed 10 years ago by Marc Tousignant <drayson@…>

I had a chance to test using xvmc-blit with ia44blend for all formats, OSD worked in LiveTV on all channels. Xv-blit does not have an ia44blend osd renderer so I was unable to test that idea.

This reinforces the idea that mark believes is the cause.

Changed 10 years ago by markk

Attachment: colorkey_patch.diff added

comment:4 Changed 10 years ago by anonymous

For various reasons, I just can't recreate this particular scenario here.

Can you try colorkey_patch.diff, which I think is needed anyway, and see if it helps.

Failing that I'll have to give you a debugging patch to run with.

Changed 10 years ago by markk

Attachment: colorkey_patch_better.diff added

improved colorkey/chroma osd check

comment:5 Changed 10 years ago by Marc Tousignant <drayson@…>

Compile fails with colorkey_patch_better.diff

videoout_xv.cpp: In member function âbool VideoOutputXv::CheckOSDInit()â: videoout_xv.cpp:1088: error: âletterbox_colorâ was not declared in this scope

Changed 10 years ago by markk

Attachment: colorkey_v3.diff added

comment:6 Changed 10 years ago by Marc Tousignant <drayson@…>

v3 compiled without complaints, but did not resolve the issue.

Changed 10 years ago by Marc Tousignant <drayson@…>

Attachment: LiveTV-07-01-2009.log added

Frontend playback logging on

Changed 10 years ago by markk

Attachment: colorkey_v4.diff added

comment:7 Changed 10 years ago by anonymous

I'm fairly sure v4 should fix it (famous last words) - we were never actually removing the chroma_osd when changing inputs .

comment:8 Changed 10 years ago by Marc Tousignant <drayson@…>

Last words indeed. Still no go.

comment:9 Changed 10 years ago by markk

Owner: changed from Isaac Richards to markk
Status: newaccepted

comment:10 Changed 10 years ago by markk

(In [20785]) Fix disappearing OSD when using XvMC and the profile switches from the Chroma OSD to ia44blend. Refs #6660. This has however exposed a similar issue whereby the chromakey osd is not initialised as needed following a resolution change only - fix to follow.

comment:11 Changed 10 years ago by markk

Resolution: fixed
Status: acceptedclosed

(In [20786]) Rework the OSD initialisation in VideoOutputXv?. This should ensure the OSD in use matches the display profile preference (subject to hardware constraints). Refs r20785. Closes #6660.

comment:12 Changed 10 years ago by Marc Tousignant <drayson@…>

Confirmed, resolved the reported issue.

Note: See TracTickets for help on using tickets.