Opened 10 years ago

Closed 10 years ago

#7051 closed defect (invalid)

Use of "special" keys on Hauppauge Nova T-500 remote control has stopped working for MythTV

Reported by: elijah21477-mythtv@… Owned by: stuartm
Priority: minor Milestone: unknown
Component: MythTV - User Interface Library Version: unknown
Severity: low Keywords: Hauppauge Nova T-500 remote control
Cc: Ticket locked: no

Description

This happened a while ago so forgive me that I can't remember exactly what was upgraded at that time. I was using Mythbuntu 8.04.

The short description of the actual problem is that I'm running a Hauppauge Nova T-500 with IR remote. Some of the buttons on that remote have stopped working in MythTV. Buttons such as the hot keys (Home, TV, Videos, Music, Pictures etc.) and also keys such as skip forwards and backwards (fast forward and rewind are ok). Other keys such as up, down, left, right, OK and the number keys are working correctly.

The strange thing is that IRW reports the correct information when I press all the keys so I know that the remote is working and that LIRC is receiving the signals ok.

MythTV doesn't respond that the "malfunctioning" keys have been pressed at all. If I try to remap them, it doesn't recognise a key press.

If I press the same mapped key combination on a keyboard (e.g. ALT+T) MythTV responds as expected. It's just the remote signal it ignores.

Recently I upgraded to 9.04 but this is still faulty.


The number on the remote is A415 OH/S 1-4

I have attached lircd.conf and I have confirmed that the expected numbers tie exactly to those reported by IRW.

I have also attached lircrc.


I only put this link in just in case I forget to add some information. This was the original post I put up on the myth tv forum. (It may give some more background?)

http://www.mythtvtalk.com/forum/hardware/10973-hauppauge-nova-t-500-keybindings-new-post.html

Then later onto the MythBuntu? forum as it was still unresolved (but says little extra):

http://ubuntuforums.org/showthread.php?t=1242532

Attachments (2)

lircd.conf (2.6 KB) - added by elijah21477-mythtv@… 10 years ago.
lircd.conf (values equate exactly to IRW output)
lircrc (3.5 KB) - added by elijah21477-mythtv@… 10 years ago.
lircrc

Download all attachments as: .zip

Change History (6)

Changed 10 years ago by elijah21477-mythtv@…

Attachment: lircd.conf added

lircd.conf (values equate exactly to IRW output)

Changed 10 years ago by elijah21477-mythtv@…

Attachment: lircrc added

lircrc

comment:1 Changed 10 years ago by elijah21477-mythtv@…

FYI, this fault is still present in Mytbuntu 9.10 with MythTV 0.22 - fixes

comment:2 Changed 10 years ago by Nick Morrott <knowledgejunkie (at) gmail (dot) com>

This may well be related to the issues described (and fixed) in #7359.

LIRC commands using modifiers (Ctrl, Alt, etc) or Fn keys and which stopped working in 0.22-fixes should work normally since r22635 of 0.22-fixes.

The reversed skip fwd/back issue was fixed in r22547 of 0.22-fixes.

Please run a newer version of 0.22-fixes that is at revision 22635 and retest, reporting any outstanding issues here.

comment:3 Changed 10 years ago by elijah21477-mythtv@…

As it turns out I've just solved it. The problem was the version of lircrc that MythTV was using was not the one that I had verifed to be correct. It hadn't occurred to me that I was not logged on specifically as MythTV.

I updated the file /home/<USER>/.mythtv/lircrc and it works a treat now. It's only taken me eight months to work it out!

Feel free to mark as invalid, thank you for your assistance.

comment:4 Changed 10 years ago by Dibblah

Resolution: invalid
Status: newclosed

Thank you for your fast response!

Note: See TracTickets for help on using tickets.