Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#7336 closed patch (fixed)

Re-implement "Delete Recordings" after MythUI port

Reported by: Nigel Owned by: Isaac Richards
Priority: major Milestone: unknown
Component: MythTV - General Version: 0.22rc1
Severity: medium Keywords:
Cc: Ticket locked: no

Description

After playbackbox.cpp was ported to MythUI in all its fully configurable glory, the Delete Recordings screen was effectively disabled - the button shows the Watch Recordings screen. This was partly by design because the two screens were so similar, but in my house we need access to a screen containing the recording sizes and machine fullness. I think keeping the dual behaviour in playbackbox is OK?
The attached patch allows themes to have a custom 'deleterecordings' window which is loaded from that button, and adds it to the current standard themes. If a theme is missing that window, it falls back to watch recordings - the current behaviour. It also adds the storage size of a group into the description, and a progressbar fill where 100% is red, not green.
In the future, I hope to rename 'Delete Recordings' back to 'Manage Recordings', have different sort orders (e.g. by size within autoexpire), and text entry in the theme to change the Title/Subtitle?. But for now, reverting to 0.21-ish behaviour is enough?

Attachments (2)

delete-recs.patch (33.5 KB) - added by Nigel 10 years ago.
code and theme changes
progressbar_fill2.png (1.8 KB) - added by Nigel 10 years ago.
Alternate fill for base progressbar - place in themes/default

Download all attachments as: .zip

Change History (7)

Changed 10 years ago by Nigel

Attachment: delete-recs.patch added

code and theme changes

Changed 10 years ago by Nigel

Attachment: progressbar_fill2.png added

Alternate fill for base progressbar - place in themes/default

comment:1 Changed 10 years ago by rowinggolfer@…

the version in Ubuntu 9.10 has this problem still. I am unable to delete recordings at the moment.

However, I have to say that I am astounded at the improvements which 0.22 brings. Good Work folks. Many thanks indeed.

comment:2 Changed 10 years ago by Nigel

(In [23284]) Re-enable some of the "Delete Recordings" screen (if the theme uses it). Refs #7336. Doesn't commit any of the default theme changes yet. Of course, since I opened that ticket, something has changed, so usedbar/freereport are never updated, but I'll work on that.

comment:3 Changed 10 years ago by Nigel

(In [23293]) Re-enable some of the "Delete Recordings" screen (if the theme uses it). Refs #7336. Doesn't commit any of the default theme changes yet. Of course, since I opened that ticket, something has changed, so usedbar/freereport are never updated, but I'll work on that.

comment:4 Changed 10 years ago by Nigel

Resolution: fixed
Status: newclosed

(In [23492]) Slightly customised default Delete Recordings screen. Closes #7336. Needs lots of theming work in everything but MythCenter? (or any other theme that doesn't use the default recordings page).

comment:5 Changed 10 years ago by Nigel

(In [23519]) Make default Delete Recording list like it used to be ages ago - listing all recordings' sizes. Reminded by Daniel's [23510]. Refs #7336

Note: See TracTickets for help on using tickets.