Opened 9 years ago

Closed 8 years ago

#7652 closed defect (worksforme)

quit key combo's via remote do not register

Reported by: adeffs.mythtv@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: MythTV - General Version: 0.22
Severity: low Keywords:
Cc: Ticket locked: no

Description

from the email thread on the users list, http://www.gossamer-threads.com/lists/mythtv/users/409103

"Mythcontrols recognise the Ctrl+Esc as Ctrl+Ctrl+Esc for me. I think this issue relates to the changes Daniel made to lirc event handling, http://svn.mythtv.org/trac/changeset/19499.

To be honest I forgot I was having this problem, I mentioned it to Daniel and meant to look into it before 0.22 was cut."

Change History (2)

comment:1 Changed 8 years ago by martin_ginkel@…

I experienced the same problems, no code with modifiers works for exiting. I really would like to distinguish the <get to next menu level> from <exit app>.

I'm not quite sure about QT API but in http://svn.mythtv.org/trac/browser/trunk/mythtv/libs/libmythui/lirc.cpp?annotate=blame&rev=22911#L379 ff, the keycode and the key modifiers are decomposed. The key modifiers are a mask-part of the code, detected by

 code & mask != null

Finally I would expect the modifier bits to be removed from the keycode by some

keycode &= NO_MODIFIER_MASK

(with the mask set to 0xFFFFFF). I see currently see the possible problem, that the modifiers are passed in a separate field/member, while the keycode still contains the modifier bits, eventually leading to doubling the "CTRL+".

How complicated is a build of mythtv (I only used binary packs so far) for checking it out?

comment:2 Changed 8 years ago by sphery

Resolution: worksforme
Status: newclosed

Unable to reproduce with current trunk.

Note: See TracTickets for help on using tickets.