Opened 10 years ago

Closed 10 years ago

#8061 closed defect (fixed)

Subtitle position and size

Reported by: Per Heldal <heldal@…> Owned by: markk
Priority: minor Milestone: unknown
Component: MythTV - Video Playback Version: head
Severity: medium Keywords: subtitle position size
Cc: Ticket locked: no

Description

Subtitles in trunk (rev 23541) look like they are positioned and scaled for a fixed 720p format or similar. On a 1280x1200 display the text appear around mid-screen vertically and far to the left. The text should also be larger at this resolution. Two sample images are attached, one from a HD channel using DVB subtitles, and one from a SD-channel using teletext captions.

Attachments (6)

nat-geo-sub.png (93.0 KB) - added by Per Heldal <heldal@…> 10 years ago.
subtitles on sd-channel
nat-geo-hd-sub.png (175.8 KB) - added by Per Heldal <heldal@…> 10 years ago.
subtitle on hd-channel
ch-info.txt (951 bytes) - added by Per Heldal <heldal@…> 10 years ago.
siparser info for the 2 channels
mythfrontend.log (68.2 KB) - added by Per Heldal <heldal@…> 10 years ago.
hd_dvbsubs.diff (8.1 KB) - added by markk 10 years ago.
Patch to support Display Definition Segment in the DVB subtitle decoder.
hd_dvbsubsv2.diff (8.7 KB) - added by markk 10 years ago.
version2 of patch including libavcodec changes submitted upstream to ffmpeg.

Download all attachments as: .zip

Change History (21)

Changed 10 years ago by Per Heldal <heldal@…>

Attachment: nat-geo-sub.png added

subtitles on sd-channel

Changed 10 years ago by Per Heldal <heldal@…>

Attachment: nat-geo-hd-sub.png added

subtitle on hd-channel

Changed 10 years ago by Per Heldal <heldal@…>

Attachment: ch-info.txt added

siparser info for the 2 channels

comment:1 Changed 10 years ago by robertm

Component: MythTV - GeneralMythTV - Video Playback
Owner: changed from Isaac Richards to markk
Status: newassigned

Assigning to Mark since he has been looking at this stuff lately, feel free to bounce it back if not interested.

comment:2 Changed 10 years ago by markk

Status: assignedaccepted

comment:3 Changed 10 years ago by markk

(In [23770]) Fix dvb_teletext subtitle positioning for OSD themes that are not 800x600 in size. (This was presumably an issue for teletext as well.) Refs #8061.

comment:4 Changed 10 years ago by markk

Status: acceptedinfoneeded

Per, Teletext subtitles should be fixed and there are no issues with dvb subtitles that I can replicate with any material I have. If you are still having problems can you please post clips (again something like filebin.ca) and the full output from mythfrontent -v playback.

Otherwise please indicate that the ticket can be closed.

thanks and regards, Mark

comment:5 Changed 10 years ago by Per Heldal <heldal@…>

Teletext subtitles seem to be in the right place now.

DVB-subtitles however are still placed about center vertically and to the left on a screen with 1920x1200 resolution. All my SD-channels use teletext subtitles so I can only check HD.

A sample clip from HistoryChannelHD can be found at http://www.megaupload.com/?d=L9OL7VIP The frontend log from viewing this clip in mythvideo is attached

(I would have used filebin.ca if I could. It's not available from here, nor have I yet found a decent proxy to relay trough. Seems like most "filebins" are gone by now, probably due to abuse)

Changed 10 years ago by Per Heldal <heldal@…>

Attachment: mythfrontend.log added

comment:6 Changed 10 years ago by Per Heldal <heldal@…>

Just want to confirm that the same goes for font-size. Teletext is fixed, DVB-text is still very small font.

comment:7 Changed 10 years ago by markk

Status: infoneededassigned

I'm not too sure if this is a MythTV/ffmpeg bug or a broadcasting issue.

In 0.22, DVB subtitle positioning was based upon fixed, standard definition resolutions. To fix HD subtitles, the positioning is now relative to the video size (i.e. for HD streams, we assume the subtitle bitmaps are sized and positioned relative to 1920x1080). This works for all standard definition streams and all other HD streams I have seen. In this instance (and #8287), subtitles are clearly still sized and positioned on the assumption of SD resoltions but within an HD video stream. FFMPEG does not appear to provide any additional hints, however, as to the appropriate scale to use.

VLC appears to get this right.

comment:8 Changed 10 years ago by markk

Status: assignedaccepted

Changed 10 years ago by markk

Attachment: hd_dvbsubs.diff added

Patch to support Display Definition Segment in the DVB subtitle decoder.

comment:9 Changed 10 years ago by markk

I've attached a patch that should fix this issue. It was generated against trunk but should, I think, apply to release-0-23-fixes as well. The bulk of the patch needs to be submitted upstream to the ffmpeg devs.

Changed 10 years ago by markk

Attachment: hd_dvbsubsv2.diff added

version2 of patch including libavcodec changes submitted upstream to ffmpeg.

comment:10 Changed 10 years ago by René H. Larsen <rhl@…>

I'm seeing the exact same problem (on HistoryChannelHD as well) with MythTV 0.23-fixes.

I can confirm that the hd_dvbsubsv2.diff patch applies to 0.23 and fixes the problem. Subtitles on other channels appear to be unaffected (i.e. they still display correctly).

comment:11 Changed 10 years ago by quint@…

Hello all,

First of all i don't know what i do is ilegal (against rules of this ticket system) if so a apology's for it.

I'm tracking this bug for a long time now, and waiting until the code is getting into the rpm repo. I updated to the latest mythtv-0.23-1.md12.i686 that is available in the repo but the bug still resides in that. I'm running iptv with HD tv content given from my provider, and if i access the ip stream 720p the subtitles are right where they need to be, but if i go to the 1080p content the subtitles are in the same position posted by the first bug poster above. Because the last update from the developer was 8 weeks ago i hoped the update was added to the newest version.

Can somebody please tell when this version will become available in the repo?

Thanks in advance

comment:12 Changed 10 years ago by markk

'quint' - For what it's worth, no - this isn't the appropriate place - the email lists are.

As far as status is concerned, as you'll see, nothing has been committed to trunk and hence there is nothing to appear in any repo. What's more, this may not be backported to 0-23-fixes even when complete. I'm still waiting on the outcome of the upstream patches to ffmpeg, which I haven't checked up on in a week or two.

comment:13 Changed 10 years ago by quint@…

Hello Markk,

I'm sorry for this. I thank you for the response so, it was unclear for me what/where the status was. Again sorry for my reply here and i will keep monitoring/wait for the update to arrive in the repo.

comment:14 Changed 10 years ago by markk

(In [25162]) Apply ffmpeg changeset r23626 (dvbsub: parse display definition segment ) to trunk.

Unfortunately the patch does not help (my fault for not keeping an eye on progress) as the actual display definition size is not made public but moving it into trunk will help to me work on fixing that.

Refs #8061.

comment:15 Changed 10 years ago by markk

Resolution: fixed
Status: acceptedclosed

(In [26090]) Fix parsing of Display Definition Segment in DVB subtitles and use the associated information to properly render standard definition subtitles transmitted with an HD stream.

At some point I'll revisit the libavcodec elements and submit upstream again. Closes #8061

Note: See TracTickets for help on using tickets.