Opened 9 years ago

Closed 9 years ago

#8062 closed defect (duplicate)

All DVB subtitles are not displayed

Reported by: Per Heldal <heldal@…> Owned by: markk
Priority: minor Milestone: unknown
Component: MythTV - Video Playback Version: head
Severity: medium Keywords: subtitles
Cc: Ticket locked: no

Description

Subtitles on DVB channels are just briefly displayed (a few seconds), and most sentences are not displayed at all. This problem does not affect SD-channels that use subtitles from teletext captions.

All HD channels are affected. This is the siparser description of one:

Program Map Table ver(5) pid(0x102) pnum(1) len(182)

 Stream #0 pid(0x202) type(video-h264  0x1b)
 Stream #1 pid(0x288) type(audio-mp1-layer[1,2,3]  0x3)
  ISO-639 Language: code(eng) canonical(eng) eng(English)
 Stream #2 pid(0x289) type(audio-mp2-layer[1,2,3]  0x4)
  ISO-639 Language: code(pol) canonical(pol) eng(Polish)
 Stream #3 pid(0x28a) type(audio-mp2-layer[1,2,3]  0x4)
  ISO-639 Language: code(hun) canonical(hun) eng(Hungarian)
 Stream #4 pid(0x28b) type(audio-mp2-layer[1,2,3]  0x4)
  ISO-639 Language: code(cze) canonical(cze) eng(Czech)
 Stream #5 pid(0x260) type(private-data  0x6)
  Subtitling Descriptor (0x59) length(8)
 Stream #6 pid(0x261) type(private-data  0x6)
  Subtitling Descriptor (0x59) length(8)
 Stream #7 pid(0x262) type(private-data  0x6)
  Subtitling Descriptor (0x59) length(8)
 Stream #8 pid(0x259) type(private-data  0x6)
  Subtitling Descriptor (0x59) length(8)
 Stream #9 pid(0x25a) type(private-data  0x6)
  Subtitling Descriptor (0x59) length(8)
 Stream #10 pid(0x25b) type(private-data  0x6)
  Subtitling Descriptor (0x59) length(8)
 Stream #11 pid(0x263) type(private-data  0x6)
  Subtitling Descriptor (0x59) length(8)
 Stream #12 pid(0x25c) type(private-data  0x6)
  Subtitling Descriptor (0x59) length(8)

Change History (2)

comment:1 Changed 9 years ago by markk

Owner: changed from Janne Grunau to markk
Status: newaccepted

comment:2 Changed 9 years ago by markk

Resolution: duplicate
Status: acceptedclosed

With the clip referenced in #8061 I've confirmed this is a timestamp issue. Closing as duplicate of #6753 (which I'm working on).

Note: See TracTickets for help on using tickets.