Opened 10 years ago

Closed 10 years ago

#8342 closed defect (duplicate)

MythFrontend throws a Bus Error on OSX Snow Leopard when starting LiveTV

Reported by: stridger@… Owned by: Nigel
Priority: major Milestone: unknown
Component: Ports - OSX Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I compiled MythFrontend in Snow Leopard with osx-packager -m32 and followed the comments relating to 10.6. It runs fine, but when starting LiveTV I get a fatal Bus Error. I have tried resetting all frontend settings. Log below. I can provide further info if necessary.

2010-04-12 23:47:13.223 TV: StartTV() -- begin
2010-04-12 23:47:13.223 TV: ctor -- begin
2010-04-12 23:47:13.241 TV: ctor -- end
2010-04-12 23:47:13.241 TV: Init -- begin
2010-04-12 23:47:13.243 TV: Init -- end channel groups
2010-04-12 23:47:13.264 TV: DrawUnusedRects() -- begin
2010-04-12 23:47:13.264 TV: DrawUnusedRects() -- end
2010-04-12 23:47:13.300 TV: DrawUnusedRects() -- begin
2010-04-12 23:47:13.300 TV: DrawUnusedRects() -- end
2010-04-12 23:47:13.377 TV: Init -- end
2010-04-12 23:47:13.378 SendReceiveStringList(GET_FREE_RECORDER_COUNT) called from UI thread
2010-04-12 23:47:13.418 TV: tv->LiveTV() -- begin
2010-04-12 23:47:13.418 SendReceiveStringList(GET_NEXT_FREE_RECORDER,-1) called from UI thread
2010-04-12 23:47:13.431 TV: tv->LiveTV() -- end
2010-04-12 23:47:13.431 TV: StartTV -- process events begin
2010-04-12 23:47:13.492 TV: HandleStateChange(0) -- begin
2010-04-12 23:47:13.492 TV: Attempting to change from None to WatchingLiveTV
2010-04-12 23:47:13.493 MythContext: Connecting to backend server: 10.29.0.10:6543 (try 1 of 1)
2010-04-12 23:47:13.494 Using protocol version 56
2010-04-12 23:47:13.497 Spawning LiveTV Recorder -- begin
2010-04-12 23:47:15.566 Spawning LiveTV Recorder -- end
2010-04-12 23:47:15.571 LiveTVChain(live-macsvin2-2010-04-12T23:47:13): ReloadAll(): Added new recording
2010-04-12 23:47:15.576 ProgramInfo(): Updated pathname '':'' -> '1001_20100412234714.mpg'
2010-04-12 23:47:15.576 SendReceiveStringList(QUERY_CHECKFILE,1...) called from UI thread
2010-04-12 23:47:15.605 SendReceiveStringList(QUERY_CHECKFILE,0...) called from UI thread
2010-04-12 23:47:15.607 We have a playbackURL(myth://10.29.0.10:6543/1001_20100412234714.mpg) & cardtype(DUMMY)
2010-04-12 23:47:15.607 We have a RingBuffer
2010-04-12 23:47:15.666 TV: StartRecorder(): took 1 ms to start recorder.
2010-04-12 23:47:15.666 TV: StartPlayer(0, WatchingLiveTV, main) -- begin
2010-04-12 23:47:15.666 TV: Elapsed time since TV constructor was called: 2443 ms
dyld: loaded: /Applications/MythFrontend.app/Contents/Resources/lib/mythtv/filters/libadjust.dylib
dyld: loaded: /Applications/MythFrontend.app/Contents/Resources/lib/mythtv/filters/libbobdeint.dylib
dyld: loaded: /Applications/MythFrontend.app/Contents/Resources/lib/mythtv/filters/libcrop.dylib
dyld: loaded: /Applications/MythFrontend.app/Contents/Resources/lib/mythtv/filters/libdenoise3d.dylib
dyld: loaded: /Applications/MythFrontend.app/Contents/Resources/lib/mythtv/filters/libfieldorder.dylib
dyld: loaded: /Applications/MythFrontend.app/Contents/Resources/lib/mythtv/filters/libforce.dylib
dyld: loaded: /Applications/MythFrontend.app/Contents/Resources/lib/mythtv/filters/libgreedyhdeint.dylib
dyld: loaded: /Applications/MythFrontend.app/Contents/Resources/lib/mythtv/filters/libinvert.dylib
dyld: loaded: /Applications/MythFrontend.app/Contents/Resources/lib/mythtv/filters/libivtc.dylib
dyld: loaded: /Applications/MythFrontend.app/Contents/Resources/lib/mythtv/filters/libkerneldeint.dylib
dyld: loaded: /Applications/MythFrontend.app/Contents/Resources/lib/mythtv/filters/liblinearblend.dylib
dyld: loaded: /Applications/MythFrontend.app/Contents/Resources/lib/mythtv/filters/libonefield.dylib
dyld: loaded: /Applications/MythFrontend.app/Contents/Resources/lib/mythtv/filters/libquickdnr.dylib
dyld: loaded: /Applications/MythFrontend.app/Contents/Resources/lib/mythtv/filters/libyadif.dylib
2010-04-12 23:47:15.715 detectInterlace(Ignore Scan, Interlaced Scan, 25, 576) ->Interlaced Scan
2010-04-12 23:47:15.721 NVP(0): Disabling Audio, params(-1,2,44100)
2010-04-12 23:47:15.722 VideoOutput: Allowed renderers: quartz-blit,opengl
2010-04-12 23:47:15.722 VideoOutput: Allowed renderers (filt: dummy): quartz-blit,opengl
2010-04-12 23:47:15.727 VDP: Ignoring profile item 28 (renderer xv-blit is not supported w/decoder ffmpeg (supported: null,quartz-blit,opengl))
2010-04-12 23:47:15.727 VDP: Accepting: cmp(> 0 0) dec(libmpeg2) cpus(2) skiploop(disabled) rend(quartz-blit) osd(softblend) osdfade(disabled) deint(linearblend,linearblend) filt()
2010-04-12 23:47:15.727 VDP: LoadBestPreferences(2048x2048, 0)
2010-04-12 23:47:15.728 VDP: LoadBestPreferences(2048x2048, 60)
2010-04-12 23:47:15.728 VDP: LoadBestPreferences(720x576, 60)
2010-04-12 23:47:15.728 VideoOutput: Preferred renderer: quartz-blit
2010-04-12 23:47:15.728 VideoOutput: Trying video renderer: 'quartz-blit'
2010-04-12 23:47:15.761 VDP: Ignoring profile item 28 (renderer xv-blit is not supported w/decoder ffmpeg (supported: null,quartz-blit,opengl))
2010-04-12 23:47:15.761 VDP: Accepting: cmp(> 0 0) dec(libmpeg2) cpus(2) skiploop(disabled) rend(quartz-blit) osd(softblend) osdfade(disabled) deint(linearblend,linearblend) filt()
2010-04-12 23:47:15.761 VDP: LoadBestPreferences(2048x2048, 0)
2010-04-12 23:47:15.761 VDP: LoadBestPreferences(2048x2048, 60)
2010-04-12 23:47:15.772 VDP: SetVideoRenderer(quartz-blit)
2010-04-12 23:47:15.773 VDP: SetVideoRender(quartz-blit) == GetVideoRenderer()
2010-04-12 23:47:15.773 VideoOutWindow::SetPIPState. pip_state: 0]
2010-04-12 23:47:15.773 VideoOutputQuartz::Init(WxH 720x576, aspect=1.3333, winid=4214688
			win_bounds(x 0, y0, WxH 1920x1080), WId embedid=0)
2010-04-12 23:47:15.773 Display Rect  left: 0, top: 0, width: 1920, height: 1080, aspect: 1.33333
2010-04-12 23:47:15.773 Video Rect    left: 0, top: 0, width: 720, height: 576, aspect: 1.3333
2010-04-12 23:47:15.773 VDP: LoadBestPreferences(720x576, 60)
2010-04-12 23:47:15.773 VideoOutputQuartz::VideoAspectRatioChanged(aspect=1.3333) [was 1.3333]
2010-04-12 23:47:15.773 Display Rect  left: 0, top: 0, width: 1920, height: 1080, aspect: 1.33333
2010-04-12 23:47:15.773 Video Rect    left: 0, top: 0, width: 720, height: 576, aspect: 1.3333
2010-04-12 23:47:15.779 ProgramInfo(): Updated pathname '':'' -> '1001_20100412234714.mpg'
2010-04-12 23:47:15.782 SendReceiveStringList(QUERY_CHECKFILE,1...) called from UI thread
2010-04-12 23:47:15.786 Screen size is 160 x 90 (mm), aspect 1.77778
2010-04-12 23:47:15.792 Main window is 160 x 90 (mm), aspect 1.77778
2010-04-12 23:47:15.793 VideoOutputQuartz::CreateQuartzBuffers() render: quartz-blit, allowed: quartz-blit
2010-04-12 23:47:15.793 VDP: SetVideoRenderer(quartz-blit)
2010-04-12 23:47:15.793 VDP: SetVideoRender(quartz-blit) == GetVideoRenderer()
2010-04-12 23:47:15.793 VideoOutputQuartz::VProf: rend(quartz-blit) osd(softblend) deint(linearblend,linearblend) filt()
2010-04-12 23:47:15.822 Main window: Viewport currently 0,0 -> 1920,1080
dyld: loaded: /System/Library/QuickTime/QuickTimeComponents.component/Contents/MacOS/QuickTimeComponents
dyld: loaded: /System/Library/PrivateFrameworks/CoreAUC.framework/Versions/A/CoreAUC
dyld: loaded: /System/Library/Components/IOQTComponents.component/Contents/MacOS/IOQTComponents
2010-04-12 23:47:15.830 Main window: Viewport is 1920 x 1080
2010-04-12 23:47:15.830 Main window: Image is 720 x 576
2010-04-12 23:47:15.830 Main window: Scaling to 2.66667 x 1.875 of original
2010-04-12 23:47:15.830 Display Rect  left: 240, top: 0, width: 1440, height: 1080, aspect: 1.77778
2010-04-12 23:47:15.830 Video Rect    left: 0, top: 0, width: 720, height: 576, aspect: 1.3333
2010-04-12 23:47:15.830 Main window: Viewport is 1440 x 1080
2010-04-12 23:47:15.830 Main window: Image is 720 x 576
2010-04-12 23:47:15.830 Main window: Scaling to 2 x 1.875 of original
2010-04-12 23:47:15.830 Main window: Translating to 240, 0
2010-04-12 23:47:15.839 Over/underscan. V: 0, H: 0
2010-04-12 23:47:15.839 Display Rect  left: 240, top: 0, width: 1440, height: 1080, aspect: 1.77778
2010-04-12 23:47:15.839 Video Rect    left: 0, top: 0, width: 720, height: 576, aspect: 1.3333
2010-04-12 23:47:15.839 SetVideoFrameRate(25)
2010-04-12 23:47:15.842 NVP(0): LoadFilters(''..) -> 0x0
2010-04-12 23:47:15.842 ProgramInfo(): Updated pathname '':'' -> '1001_20100412234714.mpg'
2010-04-12 23:47:15.844 OSD Theme Dimensions W: 1280 H: 720
2010-04-12 23:47:15.845 SendReceiveStringList(QUERY_CHECKFILE,1...) called from UI thread
2010-04-12 23:47:15.908 ProgramInfo(): Updated pathname '':'' -> '1001_20100412234714.mpg'
2010-04-12 23:47:15.911 SendReceiveStringList(QUERY_CHECKFILE,1...) called from UI thread
2010-04-12 23:47:15.971 LiveTVChain(live-macsvin2-2010-04-12T23:47:13): ReloadAll(): Added new recording
2010-04-12 23:47:15.974 ProgramInfo(): Updated pathname '':'' -> '1001_20100412234715.mpg'
2010-04-12 23:47:15.977 SendReceiveStringList(QUERY_CHECKFILE,1...) called from UI thread
2010-04-12 23:47:16.042 ProgramInfo(): Updated pathname '':'' -> '1001_20100412234715.mpg'
2010-04-12 23:47:16.045 SendReceiveStringList(QUERY_CHECKFILE,1...) called from UI thread
2010-04-12 23:47:16.105 ProgramInfo(): Updated pathname '':'' -> '1001_20100412234715.mpg'
2010-04-12 23:47:16.108 SendReceiveStringList(QUERY_CHECKFILE,1...) called from UI thread
2010-04-12 23:47:16.167 ProgramInfo(): Updated pathname '':'' -> '1001_20100412234715.mpg'
2010-04-12 23:47:16.169 SendReceiveStringList(QUERY_CHECKFILE,1...) called from UI thread
2010-04-12 23:47:16.199 playCtx: StartDecoderThread(): took 477 ms to start player.
2010-04-12 23:47:16.199 NVP(0): ClearAfterSeek(1)
2010-04-12 23:47:16.200 TV: StartPlayer(0, WatchingLiveTV, main) -- end ok
2010-04-12 23:47:16.200 VideoOutputQuartz::GetDisplayInfo() [returning 60]
2010-04-12 23:47:16.200 TV: Changing from None to WatchingLiveTV
2010-04-12 23:47:16.200 VDP: GetFilteredDeint() : quartz-blit -> 'linearblend'
2010-04-12 23:47:16.200 TV: State is LiveTV & mctx == ctx
2010-04-12 23:47:16.204 FilterManager: GetFilterInfo(convert) returning: 0x0
2010-04-12 23:47:16.204 FilterManager: GetFilterInfo(linearblend) returning: 0x3658a0
2010-04-12 23:47:16.204 Using deinterlace method linearblend
2010-04-12 23:47:16.204 New DB connection, total: 3
2010-04-12 23:47:16.205 TV: UpdateOSDInput done
2010-04-12 23:47:16.205 TV: UpdateLCD done
2010-04-12 23:47:16.207 Connected to database 'mythtv' at host: 10.29.0.10
2010-04-12 23:47:16.212 TV: ITVRestart done
2010-04-12 23:47:16.212 NVP(0): DoPause() -- begin
2010-04-12 23:47:16.212 rate: 25 speed: 1 skip: 1 = interval 40000
2010-04-12 23:47:16.212 NVP(0): DoPause() -- setting paused
2010-04-12 23:47:16.212 LiveTVChain(live-macsvin2-2010-04-12T23:47:13): SwitchTo(1)
2010-04-12 23:47:16.212 LiveTVChain(live-macsvin2-2010-04-12T23:47:13): Entry@1: '1001_20100412234715'
2010-04-12 23:47:16.212 JumpToProgram(void)
2010-04-12 23:47:16.213 DRMVideoSync: Could not open device /dev/dri/card0, No such file or directory
2010-04-12 23:47:16.213 OpenGLVideoSync()
2010-04-12 23:47:16.213 ~OpenGLVideoSync() -- closing opengl vsync
2010-04-12 23:47:16.213 VideoOutputQuartz::GetDisplayInfo() [returning 60]
2010-04-12 23:47:16.213 Video timing method: USleep with busy wait
2010-04-12 23:47:16.213 Refresh rate: 16666, frame interval: 40000
2010-04-12 23:47:16.214 TV: DrawUnusedRects() -- begin
2010-04-12 23:47:16.214 TV: DrawUnusedRects() -- end
2010-04-12 23:47:16.214 TV: HandleStateChange(0) -- end
2010-04-12 23:47:16.215 ProgramInfo(): Updated pathname '':'' -> '1001_20100412234715.mpg'
2010-04-12 23:47:16.223 NVP(0): LoadFilters(''..) -> 0x0
2010-04-12 23:47:16.234 RingBuf(myth://10.29.0.10:6543/1001_20100412234714.mpg): OpenFile(myth://10.29.0.10:6543/1001_20100412234715.mpg, 12)
2010-04-12 23:47:16.275 RingBuf(myth://10.29.0.10:6543/1001_20100412234715.mpg): CalcReadAheadThresh(0 KB)
			 -> threshhold(64 KB) min read(0 KB) blk size(32 KB)
dyld: loaded: /System/Library/QuickTime/AppleProResDecoder.component/Contents/MacOS/AppleProResDecoder
dyld: loaded: /usr/lib/libmx.A.dylib
dyld: loaded: /System/Library/QuickTime/QuickTimeH264.component/Contents/MacOS/QuickTimeH264
dyld: loaded: /System/Library/QuickTime/AppleVAH264HW.component/Contents/MacOS/AppleVAH264HW
dyld: loaded: /System/Library/QuickTime/QuickTimeFireWireDV.component/Contents/MacOS/QuickTimeFireWireDV
dyld: loaded: /System/Library/QuickTime/QuickTimeMPEG4.component/Contents/MacOS/QuickTimeMPEG4
dyld: loaded: /System/Library/PrivateFrameworks/CoreMedia.framework/Versions/A/CoreMedia
dyld: loaded: /System/Library/PrivateFrameworks/CoreMediaAuthoring.framework/Versions/A/CoreMediaAuthoring
dyld: loaded: /System/Library/PrivateFrameworks/MediaToolbox.framework/Versions/A/MediaToolbox
dyld: loaded: /System/Library/PrivateFrameworks/VideoToolbox.framework/Versions/A/VideoToolbox
dyld: loaded: /System/Library/QuickTime/ApplePixletVideo.component/Contents/MacOS/ApplePixletVideo
dyld: loaded: /System/Library/Extensions/GeForceGA.plugin/Contents/MacOS/GeForceGA
Bus error

Thanks for looking into this.

Change History (3)

comment:1 Changed 10 years ago by robertm

Component: MythTV - GeneralPorts - OSX
Owner: changed from Isaac Richards to Nigel

comment:2 Changed 10 years ago by stridger@…

Sorry, this is actually a duplicate of

http://svn.mythtv.org/trac/ticket/8179

Changing kDecoderProbeBufferSize back to 64K fixes it for me.

comment:3 Changed 10 years ago by robertm

Resolution: duplicate
Status: newclosed

Dupe of #8179, thank you for reporting back.

Note: See TracTickets for help on using tickets.