Opened 9 years ago

Closed 9 years ago

#8455 closed defect (fixed)

segfault error 4 libmythavformat-0.23.so.0.23.0

Reported by: Rafael Moslin <rafmoslin@…> Owned by: Janne Grunau
Priority: blocker Milestone: 0.24
Component: MythTV - Video Playback Version: Master Head
Severity: high Keywords:
Cc: Ticket locked: no

Description

Latest trunk segfaults on any playback except for BBC HD. This is bizarre, it must be my machine but everything else seems to check out fine.

Attachments (3)

mythbeversion.txt (581 bytes) - added by Rafael Moslin <rafmoslin@…> 9 years ago.
Backend version
mythfeversion.txt (581 bytes) - added by Rafael Moslin <rafmoslin@…> 9 years ago.
Frontend version
mythsegfaultlog.txt (78.4 KB) - added by Rafael Moslin <rafmoslin@…> 9 years ago.
GDB Trace

Download all attachments as: .zip

Change History (12)

Changed 9 years ago by Rafael Moslin <rafmoslin@…>

Attachment: mythbeversion.txt added

Backend version

Changed 9 years ago by Rafael Moslin <rafmoslin@…>

Attachment: mythfeversion.txt added

Frontend version

Changed 9 years ago by Rafael Moslin <rafmoslin@…>

Attachment: mythsegfaultlog.txt added

GDB Trace

comment:1 Changed 9 years ago by robertm

Status: newinfoneeded_new

Did you clear out your old libraries (rm /usr/lib/libmyth* and/or rm /usr/local/lib/libmyth*) and make distclean before installing the new version? All seems to be fine here.

comment:2 Changed 9 years ago by Rafael Moslin <rafmoslin@…>

Good point I hadn't deleted any previous libraries, but then I haven't needed to do that before but hey I'll give anything a whirl but sadly no change. With regards to the latter then yes, my install script always does a distclean anyway.

What did seem really odd is that the prior HD recording in the list was fine so I dug further down and have worked out that it is channel specific, it appears to randomly affect Quest and Channel 4, which just so happens was what most of my recordings at the top of the All Programmes list consisted of. Watch TV is going to Channel 4 at the moment so it hadn't occurred to me that the channel might be the issue. Something in the Channel 4 transport stream that's not liked?

comment:3 Changed 9 years ago by Rafael Moslin <rafmoslin@…>

Thought I would add that one of the segfault causing files plays fine in smplayer, and that lists the file as having these properties:

1004_20100513120400.mpg

Size 1627097 KB (1588 MB) Length 00:14:48 Demuxer mpegts

Video Resolution 704 x 576 Aspect ratio 1.7778 Format 0x10000002 Bitrate 15000 kbps Frames per second 25.000 Selected codec ffmpeg2

Initial Audio Stream Format 80 Bitrate 192 kbps Rate 48000 Hz Channels 2 Selected codec

Audio Streams # Language Name ID 0 eng <empty> 561

Subtitles # Type Language Name ID 0 SUB eng <empty> 563

comment:4 Changed 9 years ago by stuartm

Milestone: unknown0.24
Priority: minorblocker
Severity: mediumhigh
Status: infoneeded_newnew

I can confirm the problem.

comment:5 Changed 9 years ago by stuartm

[24617] is the cause of the problem. You can revert that change from your working copy with "svn merge -r24617:24616 ." until it's reverted or fixed in trunk.

comment:6 Changed 9 years ago by Janne Grunau

Resolution: fixed
Status: newclosed

(In [24693]) mpegps: update probe changes in [24617] to ffmpeg version

maybe Fixes #8455

comment:7 Changed 9 years ago by stuartm

Resolution: fixed
Status: closednew

Still crashes, this time on mp3 in mythmusic.

comment:8 Changed 9 years ago by stuartm

Status: newinfoneeded_new

(In [24723]) lavf: fix segfaults in mpegps_probe

comment:9 Changed 9 years ago by robertm

Resolution: fixed
Status: infoneeded_newclosed

Should be fixed now.

Note: See TracTickets for help on using tickets.