Opened 9 years ago

Closed 9 years ago

#8586 closed defect (fixed)

Segfault while exiting recording and saving position

Reported by: otto at kolsi dot fi Owned by: markk
Priority: minor Milestone: 0.24
Component: MythTV - General Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Attached backtrace shows segfault from the situation where recording playback is ended with Esc, and then save position is selected from the menu. Most of the time this works just fine, but every now and then it segfaults.

Version information:

MythTV Version   : 25135M
MythTV Branch    : trunk
Network Protocol : 57
Library API      : 0.23.20100615-1
QT Version       : 4.6.2
Options compiled in:
 linux debug silent using_alsa using_pulse using_pulseoutput using_backend using_dvb using_frontend using_libfftw3 using_lirc using_opengl_video using_opengl_vsync using_qtdbus using_qtwebkit using_x11 using_xrandr using_xv using_bindings_perl using_bindings_python using_opengl using_ffmpeg_threads

Attachments (10)

mfe-playback-exit-bt3.txt (54.3 KB) - added by otto at kolsi dot fi 9 years ago.
mfe-playback-exit-bt4.txt (66.0 KB) - added by otto at kolsi dot fi 9 years ago.
mfe-playback-exit-bt5.txt (15.9 KB) - added by otto at kolsi dot fi 9 years ago.
mfe-playback-exit-bt6.txt (12.4 KB) - added by otto at kolsi dot fi 9 years ago.
mfe-playback-exit-log6.txt (33.6 KB) - added by otto at kolsi dot fi 9 years ago.
mfe-playback-exit-bt7.txt (39.4 KB) - added by otto at kolsi dot fi 9 years ago.
mfe-playback-exit-log7.txt (5.8 KB) - added by otto at kolsi dot fi 9 years ago.
mfe-playback-exit-bt6.2.txt (12.4 KB) - added by otto at kolsi dot fi 9 years ago.
mfe-playback-exit-bt8.txt (37.5 KB) - added by otto at kolsi dot fi 9 years ago.
mfe-playback-exit-log8.txt (49.1 KB) - added by otto at kolsi dot fi 9 years ago.

Download all attachments as: .zip

Change History (24)

Changed 9 years ago by otto at kolsi dot fi

Attachment: mfe-playback-exit-bt3.txt added

comment:1 Changed 9 years ago by markk

Owner: changed from Isaac Richards to markk
Status: newaccepted

comment:2 Changed 9 years ago by markk

Status: acceptedinfoneeded

Can you test whether this was fixed in r25161? thanks.

Changed 9 years ago by otto at kolsi dot fi

Attachment: mfe-playback-exit-bt4.txt added

comment:3 Changed 9 years ago by otto at kolsi dot fi

Problem still occurs with svnversion: 25161. I just attached fresh backtrace.

comment:4 Changed 9 years ago by robertm

Status: infoneededassigned

comment:5 Changed 9 years ago by otto at kolsi dot fi

Haven't seen this segfault in couple of weeks with daily usage. Can't pinpoint any changeset, but I suspect one of the changes after [25161] might have fixed this. Maybe this can be closed and then re-opened if it happens again.

comment:6 Changed 9 years ago by stuartm

Resolution: fixed
Status: assignedclosed

comment:7 Changed 9 years ago by stuartm

Milestone: unknown0.24

Changed 9 years ago by otto at kolsi dot fi

Attachment: mfe-playback-exit-bt5.txt added

comment:8 Changed 9 years ago by otto at kolsi dot fi

Resolution: fixed
Status: closednew

Seems this problem still exists (SVN 25578). I've attached fresh backtrace which looks different from the earlier two.

comment:9 Changed 9 years ago by markk

Can you try and capture -v playback logs (as in #8746) together with a back trace. I suspect there is a common underlying cause for the different issues you are seeing.

Changed 9 years ago by otto at kolsi dot fi

Attachment: mfe-playback-exit-bt6.txt added

Changed 9 years ago by otto at kolsi dot fi

Attachment: mfe-playback-exit-log6.txt added

comment:10 Changed 9 years ago by robertm

Status: newassigned

Changed 9 years ago by otto at kolsi dot fi

Attachment: mfe-playback-exit-bt7.txt added

Changed 9 years ago by otto at kolsi dot fi

Attachment: mfe-playback-exit-log7.txt added

comment:11 Changed 9 years ago by otto at kolsi dot fi

I've attached couple of new backtraces and logs, latest with svn r25626. Could this be MythUI related, at least bt looks like it?

How about these in logs, are these harmless?

QObject: Cannot create children for a parent that is in a different thread.
3	(Parent is MythScreenType(0xb5e42820), parent's thread is DecoderThread(0xa0edd08), current thread is QThread(0x9bd8568)

Changed 9 years ago by otto at kolsi dot fi

Attachment: mfe-playback-exit-bt6.2.txt added

Changed 9 years ago by otto at kolsi dot fi

Attachment: mfe-playback-exit-bt8.txt added

Changed 9 years ago by otto at kolsi dot fi

Attachment: mfe-playback-exit-log8.txt added

comment:12 Changed 9 years ago by otto at kolsi dot fi

Added another log & backtrace. I changed frontend build from profile to debug and maybe backtrace shows something more now. It seems to be related to MythUI/MythImage stuff.

comment:13 Changed 9 years ago by markk

Status: assignedinfoneeded

Otto - thanks for sticking with this. Can you please update to latest trunk - the 'Cannot create children' messages should now be fixed - and I'm hoping that those were triggering the problem due to incomplete creation of certain objects within the bowels of libmythui.

As for the symptoms, the actual point at which the crashes occur should be a simple fix but I'd like to ensure we figured out the cause first.

Mark

comment:14 Changed 9 years ago by markk

Resolution: fixed
Status: infoneededclosed

(In [25741]) Don't use the deleteLater method in MythUIType.

The current libmythui usage model suggests this is unnecessay but it is causing problems in the OSD. MythImages? are allocated via the painter classes but owned by their parent MythUIImage objects. When the painter is deleted immediately and the MythUIImage is not deleted until the event loop has finished, the painter pointer held by MythImage? is no longer valid.

This is the simplest and most obvious solution but if there are unforeseen consequences, there is a less elegant solution.

Closes #8586. Refs r25740

Note: See TracTickets for help on using tickets.