Opened 9 years ago

Closed 9 years ago

#8737 closed patch (fixed)

Fix crash bug in channel scanner

Reported by: Rune Petersen <rune@…> Owned by: Stuart Auchterlonie
Priority: major Milestone: 0.24
Component: MythTV - Channel Scanner Version: 0.23-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

ChannelScanSM doesn't delete the ScanStreamData? object in its, this results in a leak and a crash if ScanStreamData? calls one of the listeners after ChannelScanSM object has been deleted.

I would expect the crash to happen that often, because only new tables trigger calls to listeners. I am able to reliably reproduce this, because my DVB provider are constantly cycling NITo tables.

This patch also applies to trunk

Attachments (1)

fix_crash_ChannelScannerSM.patch (739 bytes) - added by Rune Petersen <rune@…> 9 years ago.

Download all attachments as: .zip

Change History (5)

Changed 9 years ago by Rune Petersen <rune@…>

comment:1 Changed 9 years ago by Nick Morrott <knowledgejunkie (at) gmail (dot) com>

Refs #7340, #8739

This patch fixes the segfault seen during DVB-S scanning with decryption checking enabled on #8739.

comment:2 Changed 9 years ago by Rune Petersen <rune@…>

I found another crash bug in ChannelScannerSM, a missing mutex... I'll see about updating the patch.

comment:3 Changed 9 years ago by Stuart Auchterlonie

Milestone: unknown0.24
Owner: changed from danielk to Stuart Auchterlonie
Status: newassigned

comment:4 Changed 9 years ago by Stuart Auchterlonie

Resolution: fixed
Status: assignedclosed

(In [25575]) Closes #8737. Make sure ChannelScanSM cleans up its use of ScanStreamData?.

Note: See TracTickets for help on using tickets.