Opened 10 years ago

Closed 10 years ago

#8989 closed defect (Duplicate)

QT 4.7 / MythTv problem

Reported by: zeloise <zeloise@…> Owned by: stuartm
Priority: minor Milestone: unknown
Component: MythTV - User Interface Library Version: Unspecified
Severity: medium Keywords: opengl, painter, libmythui
Cc: Ticket locked: yes

Description

Hello,

following the "locket" Ticket #8699

I have exactly the same problem with an ATI, NVIDIA and Intel graphic card, with Kunbutu QT 4.7 (rev 4.7.0~rc1+git20100917). with Kubuntu QT 4.6.2 + NVIDIA and exactly the same trunk version (26410) this problem do not exist. It seems that the problem is related to the way QT 4.7 handle openGl (which is different from QT 4.6?). It seems that MythTv? is not able to find the openGl information when needed for "OpenGL painter" (glxinfo gives all the correct open information).

From mythfrontend: 2010-09-23 01:13:06.496 Using the OpenGL painter X Error: BadMatch? (invalid parameter attributes) 8

Extension: 128 (Uknown extension) Minor opcode: 5 (Unknown request) Resource id: 0x4200003

QGLContext::makeCurrent(): Failed. X Error: BadMatch? (invalid parameter attributes) 8

Extension: 128 (Uknown extension) Minor opcode: 5 (Unknown request) Resource id: 0x4200003

QGLContext::makeCurrent(): Failed. X Error: BadMatch? (invalid parameter attributes) 8

Extension: 128 (Uknown extension) Minor opcode: 5 (Unknown request) Resource id: 0x4200003

QGLContext::makeCurrent(): Failed. 2010-09-23 01:13:07.415 OpenGL Error: Multi-texturing not supported. Certain OpenGL features will not work 2010-09-23 01:13:07.415 OpenGL: OpenGL vendor : 2010-09-23 01:13:07.415 OpenGL: OpenGL renderer: 2010-09-23 01:13:07.415 OpenGL: OpenGL version : 2010-09-23 01:13:07.415 OpenGL: Max texture size: 512 x 512 2010-09-23 01:13:07.415 OpenGL: Max texture units: 0 2010-09-23 01:13:07.415 OpenGL: Direct rendering: Yes 2010-09-23 01:13:07.415 OpenGL: Initialised MythRenderOpenGL

From glxinfo: OpenGL vendor string: NVIDIA Corporation OpenGL renderer string: GeForce? 9400 GT/PCI/SSE2 OpenGL version string: 3.3.0 NVIDIA 256.53 OpenGL shading language version string: 3.30 NVIDIA via Cg compiler

I hope this helps

Change History (1)

comment:1 Changed 10 years ago by stuartm

Resolution: Duplicate
Status: newclosed
Ticket locked: set

Duplicate of #8699.

Note: See TracTickets for help on using tickets.