Opened 9 years ago

Closed 9 years ago

#9087 closed defect (Invalid)

IPTV recorder dropping packets

Reported by: anaerin@… Owned by: danielk
Priority: minor Milestone: unknown
Component: MythTV - Recording Version: Master Head
Severity: low Keywords: IPTV recorder packet drop broken
Cc: Ticket locked: no

Description

My IPTV recorder(s) have started dropping packets, leading to playback errors and messages from commflagging like:

2010-10-06 23:08:35.083 [mp2 @ 0x30df980]Header missing
2010-10-06 23:08:35.121 AFD Error: Unknown audio decoding error
2010-10-06 23:08:38.364 [mpeg2video @ 0x30df980]mb incr damaged
2010-10-06 23:08:38.404 [mpeg2video @ 0x30df980]00 motion_type at 3 8
2010-10-06 23:08:38.437 [mpeg2video @ 0x30df980]00 motion_type at 0 9
2010-10-06 23:08:38.471 [mpeg2video @ 0x30df980]00 motion_type at 6 10
2010-10-06 23:08:38.504 [mpeg2video @ 0x30df980]invalid mb type in B Frame at 14 11
2010-10-06 23:08:38.538 [mpeg2video @ 0x30df980]00 motion_type at 0 12
2010-10-06 23:08:38.571 [mpeg2video @ 0x30df980]00 motion_type at 0 13
2010-10-06 23:08:38.613 [mpeg2video @ 0x30df980]00 motion_type at 5 14
2010-10-06 23:08:38.655 [mpeg2video @ 0x30df980]00 motion_type at 0 15
2010-10-06 23:08:38.697 [mpeg2video @ 0x30df980]00 motion_type at 0 16
2010-10-06 23:08:38.739 [mpeg2video @ 0x30df980]00 motion_type at 7 17
2010-10-06 23:08:38.781 [mpeg2video @ 0x30df980]00 motion_type at 5 18
2010-10-06 23:08:38.823 [mpeg2video @ 0x30df980]00 motion_type at 0 19
2010-10-06 23:08:38.865 [mpeg2video @ 0x30df980]00 motion_type at 0 20
2010-10-06 23:08:38.906 [mpeg2video @ 0x30df980]00 motion_type at 0 21
2010-10-06 23:08:38.948 [mpeg2video @ 0x30df980]mb incr damaged
2010-10-06 23:08:38.982 [mpeg2video @ 0x30df980]invalid mb type in B Frame at 16 23
2010-10-06 23:08:39.015 [mpeg2video @ 0x30df980]00 motion_type at 1 24
2010-10-06 23:08:39.057 [mpeg2video @ 0x30df980]00 motion_type at 0 25
2010-10-06 23:08:39.091 [mpeg2video @ 0x30df980]00 motion_type at 0 26
2010-10-06 23:08:39.124 [mpeg2video @ 0x30df980]00 motion_type at 0 27
2010-10-06 23:08:39.166 [mpeg2video @ 0x30df980]00 motion_type at 2 28
2010-10-06 23:08:39.208 [mpeg2video @ 0x30df980]mb incr damaged
2010-10-06 23:08:39.260 [mp2 @ 0x30df980]Header missing
2010-10-06 23:08:39.300 AFD Error: Unknown audio decoding error
2010-10-06 23:08:42.259 [mpeg2video @ 0x30df980]ac-tex damaged at 20 11
2010-10-06 23:08:42.304 [mp2 @ 0x30df980]Header missing
2010-10-06 23:08:42.342 AFD Error: Unknown audio decoding error
2010-10-06 23:08:45.717 [mpeg2video @ 0x30df980]00 motion_type at 9 18
2010-10-06 23:08:45.782 [mp2 @ 0x30df980]Header missing
2010-10-06 23:08:45.816 AFD Error: Unknown audio decoding error
2010-10-06 23:08:48.769 [mpeg2video @ 0x30df980]invalid mb type in P Frame at 0 29
2010-10-06 23:08:48.811 [mp2 @ 0x30df980]Header missing
2010-10-06 23:08:48.848 AFD Error: Unknown audio decoding error
2010-10-06 23:08:52.168 [mpeg2video @ 0x30df980]invalid mb type in P Frame at 7 16
2010-10-06 23:08:52.206 [mpeg2video @ 0x30df980]mb incr damaged
2010-10-06 23:08:52.239 [mpeg2video @ 0x30df980]ac-tex damaged at 6 15
2010-10-06 23:08:52.273 [mpeg2video @ 0x30df980]ac-tex damaged at 9 15
2010-10-06 23:08:52.315 [mpeg2video @ 0x30df980]ac-tex damaged at 1 16
2010-10-06 23:08:52.356 [mpeg2video @ 0x30df980]ac-tex damaged at 5 17

Playback of the stream in mplayer and VLC are perfectly fine and flawless, but playback of Myth's recorded files are not, indicating that packets are being dropped or discarded inside Myth's backend when the program is being recorded.

I am using:

MythTV Version   : 26719
MythTV Branch    : trunk
Network Protocol : 63
Library API      : 0.23.20100917-1
QT Version       : 4.7.0
Options compiled in:
 linux debug using_alsa using_jack using_oss using_pulse using_pulseoutput using_backend using_bindings_perl using_bindings_python using_dvb using_firewire using_frontend using_hdhomerun using_hdpvr using_iptv using_ivtv using_joystick_menu using_lirc using_mheg using_opengl_video using_opengl_vsync using_qtdbus using_qtwebkit using_v4l using_x11 using_xrandr using_xv using_xvmc using_xvmc_vld using_xvmcw using_bindings_perl using_bindings_python using_mythtranscode using_opengl using_vdpau using_ffmpeg_threads using_live using_mheg

I'll see what I can do with verbose debugging, but is there anything I should be looking for specifically? Any debugging options I should enable for better feedback as to what's going on? Logging with -v important,recording gives:

2010-10-09 15:03:11.450 scheduler: Scheduled items: Scheduled 834 items in 12.1 = 0.05 match + 12.04 place
2010-10-09 15:03:11.455 TVRec(1): ASK_RECORDING 1 0 0 0
2010-10-09 15:03:11.515 ProgramInfo(2005_20101009150300.mpg), Error: GetPlaybackURL: '2005_20101009150300.mpg' should be local, but it can not be found.
2010-10-09 15:03:11.516 TVRec(1): Changing from None to RecordingOnly
2010-10-09 15:03:11.526 TVRec(1): HW Tuner: 1->1
2010-10-09 15:03:11.670 AutoExpire: CalcParams(): Max required Free Space: 4.0 GB w/freq: 14 min
2010-10-09 15:03:11.686 Program #1 not found in PAT!
Program Association Table
 PSIP tableID(0x0) length(13) extension(0x9c9)
      version(1) current(1) section(0) last_section(0)
         tsid: 2505
 programCount: 1
  program number   505 has PID 0x  23   data  0x 1 0xf9 0xe0 0x23

2010-10-09 15:03:11.686 But there is only one program in the PAT, so we'll just use it
2010-10-09 15:03:11.858 TVRec(1): rec->GetPathname(): '/myth/tv/2005_20101009150300.mpg'
2010-10-09 15:03:12.680 scheduler: Started recording
2010-10-09 15:03:14.004 commflag: Commercial Detection Starting: "The Simpsons":"Saturdays of Thunder" recorded from channel 2005 at 2010-10-09T15:03:00
2010-10-09 15:03:14.181 Using runtime prefix = /usr
2010-10-09 15:03:14.181 Using configuration directory = /home/mythtv/.mythtv
2010-10-09 15:03:14.182 Empty LocalHostName.
2010-10-09 15:03:14.326 New DB connection, total: 1
2010-10-09 15:03:14.333 Closing DB connection named 'DBManager0'
2010-10-09 15:03:15.255 Using protocol version 63
2010-10-09 15:03:18.977 AutoExpire: CalcParams(): Max required Free Space: 4.0 GB w/freq: 14 min
2010-10-09 15:03:31.857 Using protocol version 63
2010-10-09 15:03:31.858 RecBase(1:/dev/video): GetKeyframePositions(476,9223372036854775807,#2) out of 23
2010-10-09 15:08:01.701 scheduler: Scheduled items: Scheduled 834 items in 12.8 = 0.00 match + 12.77 place
--(At this point, I cancelled the recording)
2010-10-09 15:08:51.886 TVRec(1): Changing from RecordingOnly to None
2010-10-09 15:08:51.897 scheduler: Finished recording: The Simpsons "Saturdays of Thunder": channel 2005
2010-10-09 15:08:57.260 Preview Error: Encountered problems running '/usr/bin/mythpreviewgen --size 0x0 --chanid 2005 --starttime 20101009150300  > /dev/null'
2010-10-09 15:08:57.265 commflag: Commercial Detection Unknown: "The Simpsons":"Saturdays of Thunder" recorded from channel 2005 at 2010-10-09T15:03:00 (0 commercial break(s))
2010-10-09 15:09:04.689 scheduler: Last message repeated 1 times: Finished recording: The Simpsons "Saturdays of Thunder": channel 2005
2010-10-09 15:09:04.693 scheduler: Scheduled items: Scheduled 833 items in 12.7 = 0.00 match + 12.74 place

But there appears to be nothing untoward or out of place happening there, so I'm not sure if that helps or not.

It's not being dropped at the NIC or kernel, as both NICs report 0 dropped packets, and as mentioned neither MPlayer nor VLC have any issues with dropped packets.

Change History (3)

comment:1 Changed 9 years ago by robertm

Priority: majorminor
Severity: highlow
Status: newassigned
Version: UnspecifiedTrunk Head

Please see the ticket howto, do not set priority or severity.

comment:2 Changed 9 years ago by anaerin@…

Apparently, packets WERE being dropped in the kernel, just not reported by ifconfig (Though they were reported by netstat).

Switching the IPTV interface from eth1 (The PCI add-in card) to eth0 (The on-board NIC) solved these problems. It doesn't solve the network card dropping packets, but it does remove MythTV from the cause. So this ticket can be closed. My apologies.

And, for further reference, the add-in card is identified as Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)

comment:3 Changed 9 years ago by beirdo

Resolution: Invalid
Status: assignedclosed

Closing at user request.

Note: See TracTickets for help on using tickets.