Opened 9 years ago

Closed 8 years ago

#9137 closed defect (Duplicate)

Channel browsing starts on wrong channel (no browse all tuners)

Reported by: arizonamythtv@… Owned by: danielk
Priority: minor Milestone: unknown
Component: MythTV - General Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: yes

Description

I have browse all channels off. Say I'm on channel 60, I go to browse the other channels and the OSD starts at the first channel which is three. I would think if I hit the next channel I should be taken to channel 61.

Change History (14)

comment:1 Changed 9 years ago by robertm

Owner: set to markk
Status: newassigned

Mark, not sure if this is related to the port-- if not, we can figure out who to bounce it to.

comment:2 Changed 9 years ago by robertm

Owner: changed from markk to danielk

Upon a closer reading, I think the issue here is the tvbrowsehelper class, which was added a little later on. m_chanid is initialized to 0 and doesn't look like it gets updated for the starting channel.

comment:3 Changed 9 years ago by danielk

Summary: OSD loses its placeChannel browsing starts on wrong channel (no browse all tuners)

comment:4 Changed 9 years ago by danielk

Status: assignedinfoneeded
Version: 0.24-fixesTrunk Head

This works for me. I'm going to need some additional information.

1st/ I'm assuming your channel ordering is set to "channum" not "callsign" To verify:

select * from settings where value="ChannelOrdering";

The data column should be 'channum'

2nd/ do you have multiple inputs on this card? If so, do any of the channels on the various inputs have the same channum?

comment:5 Changed 9 years ago by anonymous

I ended up having to downgrade because of a seek table issue. I assume the database would've carried over my settings from 0.23 so I just looked. I have my channel ordering set to channum. I didn't see the same channums in the database. I have a OTA ATSC card that numbers the channel say 11-2 and if I I hit 112 on my remote I'm taken to 11-2 so it appears they're they same channum.

comment:6 Changed 9 years ago by arizonamythtv@…

I just upgraded to 0.24 and I'm still seeing the issue. I do have it sorted by channum. No one else sees this?

comment:7 Changed 9 years ago by Kenni Lund [kenni a kelu dot dk]

arizonamythtv, please check if any of your channels from different inputs, have the same channel number (channum) assigned. If you only have one input, please confirm that. You can check the channel number for each of the channels in mythtv-setup under the channel editor or you can pull out a list with:

select name,channum from channel order by channum asc;

Please keep questions, discussions etc. to the mailing lists, tickets quickly gets bloated if people start discussing issues within a ticket.

comment:8 Changed 9 years ago by arizonamythtv@…

Sorry I won't ask questions. I have two sources of input one is for the STB and one is just regular cable from the wall so I entered the command above and it says 94 duplicates. I then entered

select chanid, count(chanid) as cnt from channel group by chanid having cnt > 1;

and it said I didn't have any duplicates.

comment:9 Changed 9 years ago by JYA

I know that the "me-too" comment are frowned upon, but this is something that started to occur in the past 2 months only and wanted to report it. Plus I think I can provide more information to help troubleshooting the issue

When doing channel browsing in LiveTV, the channel browsing will start on appears to be slightly random (though it may always be the first one).

4 DVB-T tuners here, 8 in total if we include virtual. Have one tuner for IPTV feed from local ISP Channels are numbered: 2,3,4,5,7,9,10,70, 90,100,300,... 399. Two sources. 1-299 is DVB-T 300-399 is IPTV

Browse on all tuners is active.

Watching channel 9. Pressing Prog+ will not show 10 as it used to, but instead will start at 2. Prog- will show 399 instead of 7. Continuing pressing channelup or channeldown works as expected from this point, increasing or decreasing the channel number.

select * from settings where value="ChannelOrdering?"; shows channum for all frontends

To the question: "do you have multiple inputs on this card? If so, do any of the channels on the various inputs have the same channum? " no, and myth has always been configured that way since I can ever remember. One tuner type = one source. One TV station = one channel number

Funnily, crashes do not give my wife much grief, but she keeps complaining about browsing channels in livetv.

comment:10 Changed 9 years ago by mythtv@…

I am also experiencing this issue (sorry if I'm me-too'ing). I reported this on the user's list first... no response... please let me know how/if I can contribute to resolution.

http://www.gossamer-threads.com/lists/mythtv/users/463845

Dave

comment:11 Changed 9 years ago by Simon Kenyon <simon@…>

see also #6948, #9025 and #9161.

i think they are all the same problem.

the patch on #6948 seemed to fix it for me.

comment:12 Changed 9 years ago by dluzin@…

Sorry for me-tooing... I have one input. Numeric ordering of channels. Same behaivor on any combinations on groups, all channels, etc.
After start of LiveTV I can do:

  1. Press 'I' (INFO) twice - got OSD showing right channel number and channel info.
  2. Press 'UP' (CHANNELUP) once - got OSD showing second channel in numeric ordering instead of current channel. After this point browsing will be related to the last selected channel no matter will you confirm change or not. So if you press 'ESC' (STOP) to close OSD and press 'UP' once again - you will get third channel.
  3. Same behaivor for 'DOWN' (CHANNELDOWN) - first browse after LiveTV start will show last channel in numeric ordering.

Nothing interesting in logs: 2011-01-06 03:28:03.786 BrowseDispInfo?()

2011-01-06 03:28:03.786 BrowseStart?()

2011-01-06 03:28:03.922 browsechanid: 0 -> 1002

First channel in numeric ordering is 1001, as you can see current channel is detected as '0'

Version from github.com, downloaded Jan-2-2011, aaf8cd6 (not sure how to number versions from github)

I'm trying to understand how tvbrowsehelper looks for current channel info, so as soon as I will find where the problem exactly is I will post update.

comment:13 Changed 9 years ago by robertm

Status: infoneededassigned
Ticket locked: set

Can't say I didn't warn you.

comment:14 Changed 8 years ago by sphery

Resolution: Duplicate
Status: assignedclosed

Closing as a duplicate of #6948. As Simon points out, we have far too many tickets for this issue.

Note: See TracTickets for help on using tickets.