Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#9590 closed Bug Report (Fixed)

SIGSEGV after starting second instance of mythtv

Reported by: manuel.kampert@… Owned by: beirdo
Priority: minor Milestone: 0.25
Component: MythTV - UPnP Version: 0.24-fixes
Severity: medium Keywords: SIGSEGV second instance
Cc: Ticket locked: no

Description (last modified by Raymond Wagner)

Frontend segfaults in mediarenderer.cpp trying to start UPNP server on an in-use port when trying to open a second instance.

Attachments (1)

backtrace.txt (418 bytes) - added by manuel.kampert@… 8 years ago.
Backtrace

Download all attachments as: .zip

Change History (5)

Changed 8 years ago by manuel.kampert@…

Attachment: backtrace.txt added

Backtrace

comment:1 Changed 8 years ago by manuel.kampert@…

I don't know if this is at all supported but when I start a second instance of mythtv I always get a SIGSEGV from the frontend.

I have tracked this down to a invalid call of m_mList.lock() in file threadpool.cpp

Here ist the backtrace: gdb) backtrace #0 0xb372c179 in QMutex::lock() () from /usr/lib/qt4/libQtCore.so.4 #1 0xb69e5af3 in ThreadPool::ThreadTerminating? (this=0x8323ea0, pThread=0x831fe38) at threadpool.cpp:477 #2 0xb69e3918 in WorkerThread::run (this=0x831fe38) at threadpool.cpp:271 #3 0xb3732886 in ?? () from /usr/lib/qt4/libQtCore.so.4 #4 0xb35bf97e in start_thread () from /lib/libpthread.so.0 #5 0xb340969e in clone () from /lib/libc.so.6 (gdb)

To solve this issue I have disabled the call to g_pUpnp = new MediaRenderer?() in main.cpp from file /mythtv/programs/mythfrontend

What I have else tried:

tried to start mythbackend with disable-upnp -> no success tried to start mythfrontedn with disable-autodiscover -> no success.

Unfortunately I can not provide a complete patch here as I do not yet understand too much of the inner workings of mythtv.

Best Regards,

Manuel

comment:2 Changed 8 years ago by Raymond Wagner

Milestone: unknown0.25
Owner: changed from dblain to beirdo
Status: newassigned

comment:3 Changed 8 years ago by Raymond Wagner

Description: modified (diff)
Resolution: Fixed
Status: assignedclosed

comment:4 Changed 8 years ago by Raymond Wagner

Description: modified (diff)

Whoops, filled in the wrong box.

Issue has already been fixed in aba1fb05dd3.

For 0.24, you can set the 'UPnP/MythFrontend/ServicePort' value in your config.xml to force the server to a different port than the first instance, to allow a second instance to run.

Note: See TracTickets for help on using tickets.