Modify
Warning Please read the Ticket HowTo before creating or commenting on a ticket. Failure to do so may cause your ticket to be rejected or result in a slower response.

Opened 14 months ago

Closed 10 months ago

Last modified 10 months ago

#11455 closed Bug Report - General (fixed)

DVD subpictures without an explicit 'end' time are not shown.

Reported by: peper03@… Owned by: peper03
Priority: minor Milestone: 0.27
Component: MythTV - DVD Playback Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

The 'end' time for DVD subpictures defaults to zero, which prevents them being shown if they don't include an explicit command to set it.

The attached patch initializes the 'end' time so that the subpicture shows forever (or until the next subpicture). This allows DVDs such as those found here to play (note subtitles must be turned on to see anything!)

Additionally, the also adds minimal handling for the 'CHG_COLCON' command, which doesn't occur often, but is currently not recognised. This could lead to issues due to the code attempting to interpret the data for the command as new commands. The new handling simply skips over the data to the next command.

Attachments (3)

0001-Ensure-that-DVD-subpictures-that-don-t-explicitly-se.patch (2.1 KB) - added by peper03@… 14 months ago.
0001a-Ensure-that-DVD-subpictures-that-don-t-explicitly-se.patch (3.0 KB) - added by peper03@… 14 months ago.
Updated patch
0001b-Ensure-that-DVD-subpictures-that-don-t-explicitly-se.patch (3.5 KB) - added by peper03@… 13 months ago.

Download all attachments as: .zip

Change History (10)

Changed 14 months ago by peper03@…

Changed 14 months ago by peper03@…

Updated patch

comment:1 Changed 14 months ago by peper03@…

The updated patch initializes end_display_time to the same value as start_display_time.

Also, the number of subtitles that can be buffered is increased to 40 to (hopefully) allow as many subtitles to be buffered as video frames (OpenGL on my machine buffers 29 frames, so for full frame-rate subtitles/subpictures, it must be possible to buffer the same number of subtitles).

Note that the patch from #11451 must be applied before either of these patches.

comment:2 Changed 13 months ago by stichnot

  • Owner set to stichnot
  • Status changed from new to accepted

Changed 13 months ago by peper03@…

comment:3 Changed 13 months ago by peper03@…

New patch (0001b) adds a check to ensure that an end time has actually been set before clearing a menu highlight. Otherwise the highlight would only appear for one frame on menus where no end time was specified.

comment:4 Changed 10 months ago by stichnot

  • Owner changed from stichnot to peper03
  • Status changed from accepted to assigned

comment:5 Changed 10 months ago by Richard <peper03@…>

  • Resolution set to fixed
  • Status changed from assigned to closed

In e5e9cc8ce4841c233db9604d3296e243aa0a3e54/mythtv:

Ensure that DVD subpictures that don't explicitly set the 'end' time are still shown. Also, handle 'CHG_COLCON' command by skipping over the data. This should prevent any issues caused by incorrectly interpreting the data as subpicture commands.

Fixes #11455

comment:6 Changed 10 months ago by peper03

  • Milestone changed from unknown to 0.27

comment:7 Changed 10 months ago by Richard Hulme <peper03@…>

In 811be23159604626ee8675400692cccc4599229f/mythtv:

Apply additional changes from third patch in ticket #11455 that should have been applied in [e5e9cc8ce]. The first patch was applied by mistake.

Refs #11455

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'new'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.