Opened 3 years ago

Closed 22 months ago

Last modified 12 months ago

#12586 closed Bug Report - General (fixed)

JumpPoints blocked by MythNotify

Reported by: warpme@… Owned by: Peter Bennett
Priority: minor Milestone: unknown
Component: MythTV - General Version: Master Head
Severity: medium Keywords: JumpPoints
Cc: Ticket locked: no

Description (last modified by Peter Bennett)

Current master has following bug with JumpPoints: if user tries to use JumpPoint while MythNotify is displaying - JumpPoint isn't working. JumpPoint is also not working after diminishing notification. User must press Esc to unblock JumpPoints.

Steeps to reproduce:

1.try any action causing MythNotify notification

2.when notification is displaying, try any JumpPoint (it not works)

3.after diminishing Notification, try again any JumpPoint (still not works)

4.press Esc

5.try again any JumpPoint (now works again)

Change History (11)

comment:1 Changed 2 years ago by Peter Bennett

According to the wiki https://www.mythtv.org/wiki/MythNotify , MythNotify uses an obsolete protocol, and it would be better to use MythMessage. Can you run a test to see if MythMessage causes the same problem. see https://www.mythtv.org/wiki/MythMessage . You can send MythMessage using the mythutil program.

comment:2 Changed 2 years ago by warpme@…

oh my mistake :) I'm using of course MythMessage?.

comment:3 Changed 2 years ago by Peter Bennett

Owner: set to Peter Bennett
Status: newassigned

comment:4 Changed 2 years ago by Peter Bennett

Description: modified (diff)
Keywords: MythNotify removed
Summary: JumpPoints blocked by MythNotifyJumpPoints blocked by MythMessage

comment:5 Changed 22 months ago by Peter Bennett

I cannot recreate this. I tried the following -

  1. Assigned key ctrl-alt-v to jumppoint video browser
  2. Play a recording
  3. While recording is playing, run this command :

mythutil --message --message_text "Test message" --timeout 5

  1. I see ""Test message" displayed over the video for 5 seconds then it fades
  2. I press ctrl-alt-v and I see the video browser.

I tried the same test with this command :

mythutil --notification --message_text "Test message" --timeout 5

I got the same result.

I tried again, pressing ctrl-alt-v during the display of the message and the notification. It still works and goes to the video browser.

I also tried when there is no playback - works every time ...

comment:6 Changed 22 months ago by warpme@…

Peter, Thx for looking for this ticket!

May You pls try following:

-define jumppoint for 'Main Menu' (i.e. Alt+H)

-enter i.e. MythMusic

-send mythnotify

-while You have notify on screen - press Alt+H

in my case myth there is no expected jump to main menu. (without mythnotify on screen all works OK)

comment:7 Changed 22 months ago by Peter Bennett

Description: modified (diff)
Summary: JumpPoints blocked by MythMessageJumpPoints blocked by MythNotify

OK I can reproduce it now without plugins.

  1. Go into Program Guide
  2. Run this

mythutil --notification --message_text "Test message" --timeout 10

  1. During the time the message is displayed press Alt-h
  2. the message goes away but the jumppoint is not taken until you press escape.

If you wait until the message has faded, the jump point works OK.

The problem does not seem to exist if using --message instead of --notification.

comment:8 Changed 22 months ago by Peter Bennett <pbennett@…>

Resolution: fixed
Status: assignedclosed

In f5fb29daf9efc8d683fc6452a0c2fa9953a1e340/mythtv:

Fixes #12586 - Jump Points not working when a MythNotification? is displayed.

comment:9 Changed 22 months ago by warpme@…

Peter, Thx for working on this ticket. It looks like we are almost there. Only issue I have now with jumppoints and mythnotify is mythmusic.

Pls try jumping to main menu when You have mythmusic running.

In my case notification disappears but myth still stays in mythmusic instead go going to main menu.

comment:10 Changed 22 months ago by warpme@…

Perer - forget my last comment (#9). I tested wrong version.

All seems to be perfect with r510.

Thx for your work on this ticket!

comment:11 Changed 12 months ago by Peter Bennett

Owner: changed from Peter Bennett to Peter Bennett
Note: See TracTickets for help on using tickets.