Opened 10 years ago

Closed 10 years ago

#8538 closed defect (duplicate)

Crash when toggling record on/off after program/keyword search

Reported by: Per Heldal <heldal@…> Owned by: stuartm
Priority: minor Milestone: 0.23-fixes
Component: MythTV - User Interface Library Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

SVN Revision: 24996

In the program planner, search for a keyword. Select one item from the list of results and hit the record button --> Crash

After restart the recording of a single instance of the program has been enabled as expected.

Opening the sub-menu and enable recording there works fine. After returning to the list of results from the schedule editor one can also enable recording of additional items in the list with the 'r' key without crashes.

See attachment for frontend output and backtrace.

Attachments (2)

mythui-schedule-crash.txt (15.3 KB) - added by Per Heldal <heldal@…> 10 years ago.
frontend output and backtrace
backtrace.txt (23.2 KB) - added by stuartm 10 years ago.
Very different backtrace for same crash

Download all attachments as: .zip

Change History (6)

Changed 10 years ago by Per Heldal <heldal@…>

Attachment: mythui-schedule-crash.txt added

frontend output and backtrace

comment:1 Changed 10 years ago by sphery

Component: MythTV - SchedulingMythTV - User Interface Library
Owner: changed from gigem to stuartm

Seems to be related to image usage in the UI.

Changed 10 years ago by stuartm

Attachment: backtrace.txt added

Very different backtrace for same crash

comment:2 Changed 10 years ago by stuartm

Milestone: unknown0.23-fixes
Status: newaccepted

I can reproduce, but I get a very different backtrace. I've not looked into it, but I suspect we're trying to remember the position in the list in the wrong way which would also explain the erratic behaviour seen when update and scheduling events are received, we jump all over the place.

comment:3 Changed 10 years ago by danielk

If this uses ProgList?, it could be a dup of #8494.

comment:4 Changed 10 years ago by stuartm

Resolution: duplicate
Status: acceptedclosed

Duplicate of #8494

Note: See TracTickets for help on using tickets.