Opened 8 years ago

Closed 7 years ago

#9297 closed Bug Report (Duplicate)

Cannot switch to or watch HD Channels with firewire STB in LiveTV, but recording from the same channels works fine

Reported by: Erik Sejr <esejr@…> Owned by:
Priority: minor Milestone: unknown
Component: MythTV - General Version: Unspecified
Severity: medium Keywords:
Cc: Ticket locked: no

Description

This may be loosely related to my original ticket #9284, but in that case I was not able to watch any channels. Now all SD & radio channels work just fine, this only appears to happen when I try to watch an HD channel (channel number 7xx on my provider) in liveTV mode.

I have attached two backend logs with -v record,channel. One was created Trying to watch a show on channel 700 live, the other simply recording the same show on the same channel, then watching it in the "recorded programs" as it records, but without using the "live TV" mode. The exact steps to create these logs are below:

mythbackend-live.log

  1. Startup the backend with -v record,channel. Backend tunes STB to channel 3 (an SD channel) at startup
  2. Startup the fontend and select "Watch Live TV".
  3. LiveTV starts fine on channel 3.
  4. Enter channel "700"
  5. I see the digits "7" "0" "0" are sent to the STB on its LED display, the STB switches channels
  6. I see the OSD showing program info and "Signal 100% TLAM LOCK" appear on the screen for channel 700
  7. Without me doing anything, about 2 seconds later I see the digits "0" "0" "3" are sent to the STB on its LED display.
  8. The STB changes channels
  9. The screen goes black for about 3 seconds, then the frontend returns to the menu with the error "Error Opening Jump Program File Buffer"
  10. Exit the frontend
  11. Exit the backend

mythbackend-rec.log

  1. Startup the backend with -v record,channel
  2. From the program guide, select channel 700 and tell mythtv to "record this showing"
  3. I see the digits "7" "0" "0" are sent to the STB on its LED display, the STB switches channels. The recording begins.
  4. Go to "recorded programs" and select the recording in progress, watched it for about 10 seconds to ensure it was recording properly.
  5. Exit the playback. Cancel & Delete the recording.
  6. Exit the frontend
  7. Exit the backend

The patch I applied to add in the model/ID's of my STB is attached as well as the relevant version numbers.

Attachments (5)

patch.diff (1.2 KB) - added by Erik Sejr <esejr@…> 8 years ago.
mythfrontver.txt (653 bytes) - added by Erik Sejr <esejr@…> 8 years ago.
mythbackver.txt (674 bytes) - added by Erik Sejr <esejr@…> 8 years ago.
mythbackend-rec.log (23.9 KB) - added by Erik Sejr <esejr@…> 8 years ago.
mythbackend-live.log (45.6 KB) - added by Erik Sejr <esejr@…> 8 years ago.

Download all attachments as: .zip

Change History (8)

Changed 8 years ago by Erik Sejr <esejr@…>

Attachment: patch.diff added

Changed 8 years ago by Erik Sejr <esejr@…>

Attachment: mythfrontver.txt added

Changed 8 years ago by Erik Sejr <esejr@…>

Attachment: mythbackver.txt added

Changed 8 years ago by Erik Sejr <esejr@…>

Attachment: mythbackend-rec.log added

Changed 8 years ago by Erik Sejr <esejr@…>

Attachment: mythbackend-live.log added

comment:1 Changed 8 years ago by sphery

Status: newinfoneeded_new

dup of #9177 ?

comment:2 in reply to:  1 Changed 8 years ago by Erik Sejr <esejr@…>

Replying to mdean:

dup of #9177 ?

I'm not sure, the problem sounds very similar, but there's no mention in that ticket of the odd channel changing behaviour. I don't think I can attempt the workaround the reporter of #9177 has in his ticket as I only have a single tuner at my disposal. I have found no way to work around this beyond simply setting the show to record, then going and watching the recording.

I will admit that I did not see #9177 while I was looking at some of the other bugs.

comment:3 Changed 7 years ago by stuartm

Resolution: Duplicate
Status: infoneeded_newclosed

Probable duplicate of #9177, monitor that ticket for fixes.

Note: See TracTickets for help on using tickets.