Opened 11 years ago

Closed 10 years ago

#7421 closed defect (duplicate)

Input group bugs

Reported by: kbass@… Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: MythTV - Mythtv-setup Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I am new to using input groups, but there are some bugs in this area.

1) I've got an HVR-1950. I added the card twice, once for the analog portion and once for the digital portion. When I added it as a DVB for the digital side, mythtv-setup automagically changed Input Group 1: to HDR_/dev/dvb/adapter0/frontend0 rather than generic. I went back and edited the analog input and set the Input Group 1: to be the same name ( HDR_/dev/dvb/adapter0/frontend0)

I then Watch Live TV and select the analog side of the tuner. I then press 'R' to record a program. Then under LiveTV, I select bring up the menu, select a tuner and select the digital side. The frontend hangs. a) It shouldnt hang - it should timeout at some point b) Assuming i understand input groups, the choice should not have even been on the choose tuner menu - it looks like the logic that is used when entering watch tv needs to be used after a user starts recording within live tv mode.

2) When I was inside the Input Connections, I clicked the 'Create a New Input Group'. I started to type the word HVR1950 on the keyboard. After the HVR, the text input became buggy. It started showing characters that I did not type. Something is buggy there.

3) If I exit watch tv and re-enter it, it tells me 'All tuners are Busy. Select a recording: Exit or Chan xx'. This sounds like the correct behavior. However, once I select the 'Chan xx view mode', it is impossible to exit. The menu does not work and escape does not work. Killing the frontend seems like the only way.

(note sure it matters but I'm using MythCenter? theme)

Change History (2)

comment:1 Changed 11 years ago by sphery

Issue 3) is a dup of #7355.

Issue 2) is by design--the editable comboboxes in setup/settings are designed to auto-select matches as you type. There is, however, a bug that results in extra stuff being put into the combobox list (which may then be auto-selected and seem very confusing and, in combination with the auto-select, can result in things the user did not type being put in the list), but that bug would be a dup of #6662.

Only remaining portion of this ticket is issue 1).

comment:2 Changed 10 years ago by sphery

Resolution: duplicate
Status: newclosed

The remaining issue also seems to be a dup.

#1, LiveTV doesn't respect input groups: dup of #7123 #2, Editable comboboxes insert garbage: dup of #6662 #3, Lost window focus: dup of #7355 and #6815

Note: See TracTickets for help on using tickets.