Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#8567 closed defect (fixed)

mythmusic: Segfault when attempting to play music

Reported by: Pasha Golovko <mythtv@…> Owned by: Isaac Richards
Priority: minor Milestone: 0.24
Component: Plugin - MythMusic Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

After updating to latest SVN HEAD (r25117) from r25039, playing any music file in MythMusic results in segfault.

Backtrace and frontend logs are attached.

Reproduced from a clean install after make uninstall and manually removing /usr/share/mythtv, /usr/include/mythtv and /usr/lib/mythtv

Stepping through the code in the debugger, MainVisual? for the MythMusic playlist screen is the only Visual object present in the list that is iterated over inside prepareVisuals. No other visualizations are defined.

Attachments (2)

backtrace.log (13.4 KB) - added by Pasha Golovko <mythtv@…> 9 years ago.
mythfrontend.log (5.6 KB) - added by Pasha Golovko <mythtv@…> 9 years ago.

Download all attachments as: .zip

Change History (7)

Changed 9 years ago by Pasha Golovko <mythtv@…>

Attachment: backtrace.log added

Changed 9 years ago by Pasha Golovko <mythtv@…>

Attachment: mythfrontend.log added

comment:1 Changed 9 years ago by anonymous

This seems to occur when the playlist is empty. Adding all my music to the playlist results in it working correctly. I haven't tested selecting a file not in the playlist.

comment:2 Changed 9 years ago by Matthew Wire <devel@…>

This looks like a duplicate of #8506

comment:3 Changed 9 years ago by paulh

(In [25551]) MythMusic: Tidy up the visualiser starting and stopping. Refs #8506, #8567.

comment:4 Changed 9 years ago by paulh

Resolution: fixed
Status: newclosed

(In [25560]) MythMusic: Make sure the decoder is stopped when updating the playlist and fix a leak in MusicNode?. Fixes #8506, #8567. Refs #8683.

comment:5 Changed 9 years ago by stuartm

Milestone: unknown0.24
Note: See TracTickets for help on using tickets.